USB Grayed out can't add USB devices in Virtualbox

Hi, I’m trying to add my USB devices to my virtual machine, unfortunately they are gray and I can’t add them but they are viewable, I added my user to vbox users as documentation, what information can I give myself to receive adequate support?
I’m creating a new post because the ones that exist are really old, it probably won’t be like it was back then, Forgive my bad English, I speak it badly but I hope to be clear-

What host
What guest
output of

> zypper se -si virtualbox

Leap

> zypper se -si virtualbox
> Loading repository data...
> Reading installed packages...
> 
> S  | Name                   | Type    | Version                                   | Arch   | Repository
> ---+------------------------+---------+-------------------------------------------+--------+--------------------------
> i+ | virtualbox             | package | 7.0.12-lp155.2.13.1                       | x86_64 | openSUSE-Leap-15.5-Update
> i  | virtualbox-kmp-default | package | 7.0.12_k5.14.21_150500.55.31-lp155.2.13.1 | x86_64 | openSUSE-Leap-15.5-Update
> i  | virtualbox-qt          | package | 7.0.12-lp155.2.13.1                       | x86_64 | openSUSE-Leap-15.5-Update

Tumbleweed:

> 
> zypper se -si virtualbox
> Loading repository data...
> Reading installed packages...
> 
> S  | Name                   | Type    | Version              | Arch   | Repository
> ---+------------------------+---------+----------------------+--------+------------------------
> i+ | virtualbox             | package | 7.0.14-1.2           | x86_64 | openSUSE-Tumbleweed-Oss
> i+ | virtualbox-kmp-default | package | 7.0.14_k6.7.2_1-1.2  | x86_64 | openSUSE-Tumbleweed-Oss
> i+ | virtualbox-qt          | package | 7.0.14-1.2           | x86_64 | openSUSE-Tumbleweed-Oss

For command output that has wide lines of text (especially in columnar format), it’s preferred to use the Preformatted Text feature (</> icon on toolbar) vs using Blockquote (not easily readable) :+1: Example:

# zypper se -si virtualbox
Loading repository data...
Reading installed packages...

S  | Name                   | Type    | Version             | Arch   | Repository
---+------------------------+---------+---------------------+--------+------------------------
i+ | virtualbox             | package | 7.0.14-1.2          | x86_64 | openSUSE-Tumbleweed-Oss
i+ | virtualbox-guest-tools | package | 7.0.14-1.2          | x86_64 | openSUSE-Tumbleweed-Oss
i+ | virtualbox-kmp-default | package | 7.0.14_k6.7.2_1-1.2 | x86_64 | openSUSE-Tumbleweed-Oss
i+ | virtualbox-qt          | package | 7.0.14-1.2          | x86_64 | openSUSE-Tumbleweed-Oss
#

Install virtualbox only on the Host and virtualbox-guest-additions on the Guest - they are not supposed to both be on any machine.

This only for the Host OS and not for the Guest OS
i+ | virtualbox | package | 7.0.14-1.2

This is for the Guest OS not the Host OS
i+ | virtualbox-guest-tools | package | 7.0.14-1.2

Have you installed the Virtualbox-Extensions matching to Virtualbox on the host?
http://download.virtualbox.org/virtualbox/

This is my output with

zypper se -si virtualbox
Loading repository data...
Reading installed packages...

S  | Name                   | Type    | Version             | Arch   | Repository
---+------------------------+---------+---------------------+--------+------------------
i+ | virtualbox             | package | 7.0.14-1.2          | x86_64 | (System Packages)
i  | virtualbox-kmp-default | package | 7.0.14_k6.7.2_1-1.2 | x86_64 | (System Packages)
i  | virtualbox-qt          | package | 7.0.14-1.2          | x86_64 | (System Packages)

i try to install I thought I had to install virtualbox guest tools from the site, now I installed the missing package with zypper

S  | Name                   | Type      | Version             | Arch   | Repository
---+------------------------+-----------+---------------------+--------+------------------------------------
i+ | virtualbox             | pacchetto | 7.0.14-1.2          | x86_64 | (Pacchetti di sistema)
i+ | virtualbox-guest-tools | pacchetto | 7.0.14-1.3          | x86_64 | Repository principale (OSS)
i+ | virtualbox-guest-tools | pacchetto | 7.0.14-1.3          | x86_64 | http-download.opensuse.org-22f0047b
i  | virtualbox-kmp-default | pacchetto | 7.0.14_k6.7.2_1-1.2 | x86_64 | (Pacchetti di sistema)
i  | virtualbox-qt          | pacchetto | 7.0.14-1.2          | x86_64 | (Pacchetti di sistema)

It hasn’t changed, I’ll try restarting

yes i have installed


ps. after reboot the problem persist

i try to reinstall and this is the output

Please use LANG=C to get the English output of your commands:
This is German:

zypper se -si virtualbox
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...

S  | Name                   | Type  | Version                               | Arch   | Repository
---+------------------------+-------+---------------------------------------+--------+--------------
i+ | virtualbox             | Paket | 7.0.14-lp155.736.3                    | x86_64 | Sauerland-OSS
i+ | virtualbox-kmp-default | Paket | 7.0.14_k5.14.21_150500.53-lp155.736.2 | x86_64 | Sauerland-OSS
i+ | virtualbox-qt          | Paket | 7.0.14-lp155.736.3                    | x86_64 | Sauerland-OSS


This is now English:

LANG=C zypper se -si virtualbox
Loading repository data...
Reading installed packages...

S  | Name                   | Type    | Version                               | Arch   | Repository
---+------------------------+---------+---------------------------------------+--------+--------------
i+ | virtualbox             | package | 7.0.14-lp155.736.3                    | x86_64 | Sauerland-OSS
i+ | virtualbox-kmp-default | package | 7.0.14_k5.14.21_150500.53-lp155.736.2 | x86_64 | Sauerland-OSS
i+ | virtualbox-qt          | package | 7.0.14-lp155.736.3                    | x86_64 | Sauerland-OSS

Also use copy/paste and Code-Tags for your Konsole Output, not Pictures

Code-Tags

Makes things easier…

zypper se -si virtualbox
Loading repository data...
Reading installed packages...

S  | Name                   | Type    | Version             | Arch   | Repository
---+------------------------+---------+---------------------+--------+------------------------------------
i+ | virtualbox             | package | 7.0.14-1.3          | x86_64 | Repository principale (OSS)
i+ | virtualbox             | package | 7.0.14-1.3          | x86_64 | http-download.opensuse.org-22f0047b
i+ | virtualbox-guest-tools | package | 7.0.14-1.3          | x86_64 | Repository principale (OSS)
i+ | virtualbox-guest-tools | package | 7.0.14-1.3          | x86_64 | http-download.opensuse.org-22f0047b
i  | virtualbox-kmp-default | package | 7.0.14_k6.7.2_1-1.3 | x86_64 | Repository principale (OSS)
i  | virtualbox-kmp-default | package | 7.0.14_k6.7.2_1-1.3 | x86_64 | http-download.opensuse.org-22f0047b
i  | virtualbox-qt          | package | 7.0.14-1.3          | x86_64 | Repository principale (OSS)
i  | virtualbox-qt          | package | 7.0.14-1.3          | x86_64 | http-download.opensuse.org-22f0047b

perfect I think this is fine

Perfect…

You have added 2 times same Repo?

Post as root:
lsmod | grep -i lsmod | grep -i vbox
uname -a

This is my output

fatalii@ramarro:~> sudo lsmod | grep -i lsmod | grep -i vbox
fatalii@ramarro:~>  uname -a
Linux ramarro 6.7.2-1-default #1 SMP PREEMPT_DYNAMIC Fri Jan 26 11:01:28 UTC 2024 (a52bf76) x86_64 x86_64 x86_64 GNU/Linux
fatalii@ramarro:~> 


Ups my fault:
lsmod | grep -i vbox

vboxnetadp             28672  0
vboxnetflt             40960  0
vboxdrv               720896  2 vboxnetadp,vboxnetflt

I launch the command with sudo

Have you enabled it in the Virtaulabox-Settings of your Windows System


and

I think you can do this only if the Machine is not running…

Yes i have enabled




Even if I try drag and drop now that I’m noticing it it doesn’t work


Maybe that’s another clue, Being a noob and I don’t have the skills, could it be the permissions? Although we have verified this and it should be okay,

The crazy thing is that the webcam works

Maybe:

1 Like