Protonvpn won't let me login


When I try to login to protonvpn I get this message:

! Unknow API error.

1 Like

There’s not enough of an error message to even begin to determine what the issue is. But I suspect you’d likely get a more useful answer by asking ProtonVPN in their support channels.

1 Like

I already contacted protonvpn support. They said they don’t support the opensuse distribution.

1 Like

Just doing a quick websearch, I see a number of solutions for getting ProtonVPN working on openSUSE, including the protonvpn-cli and protonvpn-gui packages available on the OpenBuildService.

You just need to do some research, if ProtonVPN themselves aren’t going to be helpful.

The packages on the OpenBuildService didn’t solve this issue.

First deinstall the packages you installed and the see How to use Proton VPN with manual setup#Using NetworkManager

This is the most easy, basic method, just download a .ovpn file and use that to configure things.

Thanks for your reply but I want to make use of protonvpn-gui.

Sorry for the late reply. You can use the protonvpn gui. I installed it from yast, along with a couple of python files. For me, there is a downside. The gui runs a pvp leak protect which interfered with the network manager when protonvpn is NOT running. I just disconnect it but its an annoyance. Otherwise, the Network Manager setup, above, will get you going.

I did the same thing. They told me to connect to ProtonVPN using OpenVPN or WireGuard.

I’ve been using protonvpn almost since it’s beginning andnever had a problem with protonvpn-cli installed using pip.

Your login details… are you using the right ones? … the ones from the protonvpn dashboard?


sudo zypper install openvpn dialog python3-pip python3-setuptools
sudo pip3 install protonvpn-cli


sudo protonvpn init
protonvpn configure

Start on boot

sudo nano /etc/systemd/system/protonvpn-autoconnect.service

Add to the file… (change ‘user’ to your OS user and make sure ExecStart is correct

Description=ProtonVPN-CLI auto-connect
ExecStart=/usr/local/bin/protonvpn connect -f

Reload systemmd configuration

sudo systemctl daemon-reload

Enable the service at boot

sudo systemctl enable protonvpn-autoconnect
1 Like

I roolbacked the system to a previous snapshot, which was one month older.
I updated that snapshot.
I rebooted the system.
Everything is fine now.
Thanks for your replies.