Ffmpeg-6-mini-libs - Nichts stellt 'this-is-only-for-build-envs' bereit

Hallo alle zusammen,

seit heute Morgen wirft mir zypper dup folgende Meldung um die Ohren, die ich trotz Recherche gerade so gar nicht eingeordnet bekomme:

sudo zypper -vvv dup
Ausführlichkeitsgrad: 3
Ziel wird initialisiert
Es wird überprüft, ob die Metadaten für Haupt-Repository (NON-OSS) aktualisiert werden müssen
Es wird überprüft, ob die Metadaten für Haupt-Repository (OSS) aktualisiert werden müssen
Es wird überprüft, ob die Metadaten für Hauptaktualisierungs-Repository aktualisiert werden müssen
Es wird überprüft, ob die Metadaten für google-chrome aktualisiert werden müssen
Es wird überprüft, ob die Metadaten für libdvdcss2 aktualisiert werden müssen
Es wird überprüft, ob die Metadaten für packman aktualisiert werden müssen
Es wird überprüft, ob die Metadaten für Security tools (openSUSE_Tumbleweed) aktualisiert werden müssen
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...
Warnung: Sie sind im Begriff, eine Distributionsaktualisierung mit allen aktivierten Repositorys durchzuführen. Vergewissern Sie sich, dass diese Repositorys kompatibel sind, bevor Sie fortfahren. Weitere Informationen zu diesem Kommando finden Sie unter 'man zypper'.
Distributions-Aktualisierungen werden verarbeitet...
Auflösung erzwingen: Nein
Aktualisierung wird berechnet...
7 Probleme:
Problem: nichts stellt 'this-is-only-for-build-envs' bereit, das vom zu installierenden ffmpeg-6-mini-libs-6.0.1-2.1.x86_64 benötigt wird
Problem: nichts stellt 'this-is-only-for-build-envs' bereit, das vom zu installierenden ffmpeg-6-mini-libs-6.0.1-2.1.x86_64 benötigt wird
Problem: nichts stellt 'this-is-only-for-build-envs' bereit, das vom zu installierenden ffmpeg-6-mini-libs-6.0.1-2.1.x86_64 benötigt wird
Problem: nichts stellt 'this-is-only-for-build-envs' bereit, das vom zu installierenden ffmpeg-6-mini-libs-6.0.1-2.1.x86_64 benötigt wird
Problem: nichts stellt 'this-is-only-for-build-envs' bereit, das vom zu installierenden ffmpeg-6-mini-libs-6.0.1-2.1.x86_64 benötigt wird
Problem: nichts stellt 'this-is-only-for-build-envs' bereit, das vom zu installierenden ffmpeg-6-mini-libs-6.0.1-2.1.x86_64 benötigt wird
Problem: nichts stellt 'this-is-only-for-build-envs' bereit, das vom zu installierenden ffmpeg-6-mini-libs-6.0.1-2.1.x86_64 benötigt wird

Problem: nichts stellt 'this-is-only-for-build-envs' bereit, das vom zu installierenden ffmpeg-6-mini-libs-6.0.1-2.1.x86_64 benötigt wird
 Lösung 1: Folgende Aktionen werden ausgeführt:
  Deinstallation von ffmpegthumbs-23.08.4-1.1.x86_64
  Deinstallation von libheif-ffmpeg-1.17.6-1.1.x86_64
  Deinstallation von libqt5-qtwebengine-5.15.16-1.2.x86_64
  Deinstallation von simplescreenrecorder-0.4.4-2.8.x86_64
  Deinstallation von libksysguard5-5.27.10-1.1.x86_64
  Deinstallation von libksieve5-23.08.4-1.1.x86_64
  Deinstallation von libQt5WebView5-imports-5.15.12+kde0-1.1.x86_64
  Deinstallation von libQt5WebView5-5.15.12+kde0-1.1.x86_64
  Deinstallation von kontact-23.08.4-1.1.x86_64
  Deinstallation von kmail-23.08.4-1.1.x86_64
  Deinstallation von libssr-glinject-0.4.4-2.8.x86_64
  Deinstallation von akregator-23.08.4-1.1.x86_64
  Deinstallation von kaccounts-providers-23.08.4-1.1.x86_64
  Deinstallation von kdepim-addons-23.08.4-1.2.x86_64
  Deinstallation von kdepim-runtime-23.08.4-1.1.x86_64
  Deinstallation von messagelib-23.08.4-1.1.x86_64
  Deinstallation von opensuse-welcome-0.1.9+git.35.4b9444a-1.2.x86_64
  Deinstallation von plasma5-addons-5.27.10-1.1.x86_64
  Deinstallation von signon-ui-0.17+20171022-1.27.x86_64
  Deinstallation von stellarium-23.4-1.1.x86_64
  Deinstallation von kpipewire-imports-5.27.10-1.1.x86_64
  Deinstallation von qt6-webengine-6.6.1-3.1.x86_64
  Deinstallation von libQt6WebEngineWidgets6-6.6.1-3.1.x86_64
  Deinstallation von gegl-0_4-lang-0.4.46-1.3.noarch
  Deinstallation von gimp-2.10.36-1.1.x86_64
  Deinstallation von libgegl-0_4-0-0.4.46-1.3.x86_64
  Deinstallation von spectacle-23.08.4-1.1.x86_64
  Deinstallation von ksystemstats5-5.27.10-1.1.x86_64
  Deinstallation von kaddressbook-23.08.4-2.1.x86_64
  Deinstallation von libKPim5MailCommon5-23.08.4-1.1.x86_64
  Deinstallation von libKPim5AkonadiCalendar5-23.08.4-1.1.x86_64
  Deinstallation von signon-plugin-oauth2-0.25-1.12.x86_64
  Deinstallation von akonadi-import-wizard-23.08.4-1.1.x86_64
  Deinstallation von messagelib-lang-23.08.4-1.1.noarch
  Deinstallation von plasma5-addons-lang-5.27.10-1.1.noarch
  Deinstallation von libksysguard5-imports-5.27.10-1.1.x86_64
  Deinstallation von libksysguard5-lang-5.27.10-1.1.noarch
  Deinstallation von libksysguard5-plugins-5.27.10-1.1.x86_64
  Deinstallation von plasma5-desktop-5.27.10-1.1.x86_64
  Deinstallation von plasma5-systemmonitor-5.27.10-1.1.x86_64
  Deinstallation von plasma5-workspace-5.27.10-2.2.x86_64
  Deinstallation von plasma5-workspace-libs-5.27.10-2.2.x86_64
  Deinstallation von pim-sieve-editor-23.08.4-1.1.x86_64
  Deinstallation von discover-5.27.10-2.2.x86_64
  Deinstallation von kontact-lang-23.08.4-1.1.noarch
  Deinstallation von pim-data-exporter-23.08.4-1.1.x86_64
  Deinstallation von kmail-lang-23.08.4-1.1.noarch
  Deinstallation von kdepim-runtime-lang-23.08.4-1.1.noarch
  Deinstallation von korganizer-23.08.4-1.1.x86_64
  Deinstallation von ktnef-23.08.4-1.1.x86_64
  Deinstallation von kdepim-addons-lang-23.08.4-1.2.noarch
  Deinstallation von kaccounts-providers-lang-23.08.4-1.1.noarch
  Deinstallation von akregator-lang-23.08.4-1.1.noarch
  Deinstallation von baloo5-file-5.114.0-1.1.x86_64
  Deinstallation von baloo5-kioslaves-5.114.0-1.1.x86_64
  Deinstallation von baloo5-tools-5.114.0-1.1.x86_64
  Deinstallation von baloo5-widgets-23.08.4-1.1.x86_64
  Deinstallation von dolphin-part-23.08.4-1.1.x86_64
  Deinstallation von gwenview5-23.08.4-1.1.x86_64
  Deinstallation von kfilemetadata5-lang-5.114.0-1.1.noarch
  Deinstallation von libKF5Baloo5-5.114.0-1.1.x86_64
  Deinstallation von plasma-browser-integration-5.27.10-1.1.x86_64
  Deinstallation von gimp-lang-2.10.36-1.1.noarch
  Deinstallation von gimp-plugin-aa-2.10.36-1.1.x86_64
  Deinstallation von gimp-plugins-python-2.10.36-1.1.x86_64
  Deinstallation von gimp-plugin-jxl-0.8.2-2.1.x86_64
  Deinstallation von libgimp-2_0-0-2.10.36-1.1.x86_64
  Deinstallation von libgimpui-2_0-0-2.10.36-1.1.x86_64
  Deinstallation von spectacle-lang-23.08.4-1.1.noarch
  Deinstallation von libKPim5ImportWizard5-23.08.4-1.1.x86_64
  Deinstallation von mbox-importer-23.08.4-1.1.x86_64
  Deinstallation von akonadi-calendar-tools-23.08.4-1.1.x86_64
  Deinstallation von akonadi-plugin-calendar-23.08.4-1.1.x86_64
  Deinstallation von kalendarac-23.08.4-1.1.x86_64
  Deinstallation von libKPim5AkonadiCalendar5-lang-23.08.4-1.1.noarch
  Deinstallation von libKPim5CalendarSupport5-23.08.4-1.1.x86_64
  Deinstallation von libKPim5EventViews5-23.08.4-1.1.x86_64
  Deinstallation von libKPim5IncidenceEditor5-23.08.4-1.1.x86_64
  Deinstallation von akonadi-import-wizard-lang-23.08.4-1.1.noarch
  Deinstallation von plasma5-theme-openSUSE-84.87~git20231117T211718~757fefa-2.1.noarch
  Deinstallation von plasma5-session-5.27.10-2.2.noarch
  Deinstallation von khotkeys5-5.27.10-1.1.x86_64
  Deinstallation von plasma5-desktop-emojier-5.27.10-1.1.x86_64
  Deinstallation von plasma5-desktop-lang-5.27.10-1.1.noarch
  Deinstallation von plasma5-systemmonitor-lang-5.27.10-1.1.noarch
  Deinstallation von plasma5-workspace-branding-openSUSE-84.87~git20231117T211718~757fefa-2.1.noarch
  Deinstallation von plasma5-workspace-lang-5.27.10-2.2.noarch
  Deinstallation von sddm-theme-openSUSE-84.87~git20231117T211718~757fefa-2.1.noarch
  Deinstallation von kde-cli-tools5-5.27.10-1.1.x86_64
  Deinstallation von powerdevil5-5.27.10-1.1.x86_64
  Deinstallation von systemsettings5-5.27.10-1.1.x86_64
  Deinstallation von ksystemstats5-lang-5.27.10-1.1.noarch
  Deinstallation von pim-sieve-editor-lang-23.08.4-1.1.noarch
  Deinstallation von discover-backend-flatpak-5.27.10-2.2.x86_64
  Deinstallation von discover-backend-fwupd-5.27.10-2.2.x86_64
  Deinstallation von discover-backend-packagekit-5.27.10-2.2.x86_64
  Deinstallation von discover-lang-5.27.10-2.2.noarch
  Deinstallation von pim-data-exporter-lang-23.08.4-1.1.noarch
  Deinstallation von korganizer-lang-23.08.4-1.1.noarch
  Deinstallation von kaddressbook-lang-23.08.4-2.1.noarch
  Deinstallation von dolphin-23.08.4-1.1.x86_64
  Deinstallation von baloo5-imports-5.114.0-1.1.x86_64
  Deinstallation von plasma-browser-integration-lang-5.27.10-1.1.noarch
  Deinstallation von gwenview5-lang-23.08.4-1.1.noarch
  Deinstallation von dolphin-part-lang-23.08.4-1.1.noarch
  Deinstallation von baloo5-widgets-lang-23.08.4-1.1.noarch
  Deinstallation von baloo5-tools-lang-5.114.0-1.1.noarch
  Deinstallation von baloo5-kioslaves-lang-5.114.0-1.1.noarch
  Deinstallation von baloo5-file-lang-5.114.0-1.1.noarch
  Deinstallation von mbox-importer-lang-23.08.4-1.1.noarch
  Deinstallation von libKPim5CalendarSupport5-lang-23.08.4-1.1.noarch
  Deinstallation von libKPim5EventViews5-lang-23.08.4-1.1.noarch
  Deinstallation von libKPim5IncidenceEditor5-lang-23.08.4-1.1.noarch
  Deinstallation von akonadi-calendar-tools-lang-23.08.4-1.1.noarch
  Deinstallation von plasma5-defaults-openSUSE-84.87~git20231117T211718~757fefa-2.1.noarch
  Deinstallation von patterns-kde-kde_plasma-20231206-1.1.noarch
  Deinstallation von plasma5-session-wayland-5.27.10-2.2.x86_64
  Deinstallation von sddm-branding-openSUSE-0.20.0-3.2.noarch
  Deinstallation von kinfocenter5-5.27.10-1.1.x86_64
  Deinstallation von powerdevil5-lang-5.27.10-1.1.noarch
  Deinstallation von kcm_flatpak-5.27.10-1.1.x86_64
  Deinstallation von systemsettings5-lang-5.27.10-1.1.noarch
  Deinstallation von khotkeys5-lang-5.27.10-1.1.noarch
  Deinstallation von kde-cli-tools5-lang-5.27.10-1.1.noarch
  Deinstallation von patterns-kde-kde-20231206-1.1.noarch
  Deinstallation von kinfocenter5-lang-5.27.10-1.1.noarch
  Deinstallation von kcm_flatpak-lang-5.27.10-1.1.noarch
 Lösung 2: libavcodec60-6.0.1-2.2.x86_64 von Hersteller openSUSE installieren
und libavcodec60-6.0.1-1699.4.pm.3.x86_64 von Hersteller http://packman.links2linux.de ersetzen
 Lösung 3: veraltetes libavcodec60-6.0.1-1699.4.pm.3.x86_64 beibehalten
 Lösung 4: ffmpeg-6-mini-libs-6.0.1-2.1.x86_64 durch Ignorieren einiger Abhängigkeiten brechen

Was am besten tun?

VG
wmf42

Ist auch in der ML aufgeschlagen

Hab kurzzeitig die ffmpeg und codecs auf OSS zurückgeswitcht. Mesa und der Rest bleibt auf packman. Dann läuft zumindest zypper dup durch.

Bislang erscheint die Meldung weiterhin (auch zypper refresh ausgeführt). Ich warte mal noch ab.

Oder die mini-libs löschen:
zypper rm ffmpeg-6-mini-libs

Brauchst du eh nicht, schau mal was dort steht:

zypper if ffmpeg-6-mini-libs

ffmpeg-6-mini-libs ist gar nicht installiert. Leider wird dieses Paket durch eine falsche Abhängigkeit versucht zu installieren (beim update auf ffmpeg-6-6.1.1-1699.3.pm.1) und zieht damit einen dezenten Abhängigkeitsirrsinn nach sich…

Das ist aber komisch, bei mir läuft der dup gerade und ffmpeg-6-mini-libs ist nicht installiert, aber auch kein ffmpeg-6.

Und es ist kein Packman repo vorhanden…

Die mini-libs gibt es auch nur für ffmpeg-5 und ffmpeg-6.
Und wenn du gar kein packman repo eingerichtet hast, dann kannst du gar nicht auf das Problem stoßen :wink:

Mir nicht. Ich bin mit ffmpeg-5 von http://packman.links2linux.de zufrieden:

erlangen:~ # zypper if ffmpeg-5
Loading repository data...
Reading installed packages...


Information for package ffmpeg-5:
---------------------------------
Repository     : Packman
Name           : ffmpeg-5
Version        : 5.1.4-1699.9.pm.3
Arch           : x86_64
Vendor         : http://packman.links2linux.de
Installed Size : 2.4 MiB
Installed      : Yes
Status         : up-to-date
Source package : ffmpeg-5-5.1.4-1699.9.pm.3.src
Upstream URL   : https://ffmpeg.org/
Summary        : Set of libraries for working with various multimedia formats
Description    : 
    FFmpeg is a multimedia framework, able to decode, encode,
    transcode, mux, demux, stream, filter and play several formats
    that humans and machines have created.

erlangen:~ # 

ffmpeg-6 geht zur Zeit nicht so einfach.

Ja, hab ich gerade gemerkt, alles zurück und Entschuldigung.
Musste meine VM erst updaten.

Toll! Keks?

Auf den nächsten Snapshot warten…

Yup, wenn man den vendor-change Richtung packman jetzt forciert, deinstalliert es dir die kompletten Plasma pattern und du stehst mit einer IceWM da :smiley:

ich@rennsemmel:~> LANG=C sudo zypper dup -D --from packman  --allow-vendor-change
Loading repository data...
Reading installed packages...
Computing distribution upgrade...
7 Problems:
Problem: nothing provides 'this-is-only-for-build-envs' needed by the to be installed ffmpeg-6-mini-libs-6.0.1-2.1.x86_64
Problem: nothing provides 'this-is-only-for-build-envs' needed by the to be installed ffmpeg-6-mini-libs-6.0.1-2.1.x86_64
Problem: nothing provides 'this-is-only-for-build-envs' needed by the to be installed ffmpeg-6-mini-libs-6.0.1-2.1.x86_64
Problem: nothing provides 'this-is-only-for-build-envs' needed by the to be installed ffmpeg-6-mini-libs-6.0.1-2.1.x86_64
Problem: nothing provides 'this-is-only-for-build-envs' needed by the to be installed ffmpeg-6-mini-libs-6.0.1-2.1.x86_64
Problem: nothing provides 'this-is-only-for-build-envs' needed by the to be installed ffmpeg-6-mini-libs-6.0.1-2.1.x86_64
Problem: nothing provides 'this-is-only-for-build-envs' needed by the to be installed ffmpeg-6-mini-libs-6.0.1-2.1.x86_64

Problem: nothing provides 'this-is-only-for-build-envs' needed by the to be installed ffmpeg-6-mini-libs-6.0.1-2.1.x86_64
 Solution 1: Following actions will be done:
  deinstallation of libqt5-qtwebengine-5.15.16-1.2.x86_64
  deinstallation of kfilemetadata5-5.114.0-1.1.x86_64
  deinstallation of signon-ui-0.17+20171022-1.27.x86_64
  deinstallation of libksysguard5-5.27.10-1.1.x86_64
  deinstallation of clipgrab-3.9.7-1.16.x86_64
  deinstallation of libKF5Baloo5-5.114.0-1.1.x86_64
  deinstallation of signon-plugin-oauth2-0.25-1.12.x86_64
  deinstallation of libksysguard5-imports-5.27.10-1.1.x86_64
  deinstallation of libksysguard5-plugins-5.27.10-1.1.x86_64
  deinstallation of plasma5-desktop-5.27.10-1.1.x86_64
  deinstallation of plasma5-systemmonitor-5.27.10-1.1.x86_64
  deinstallation of plasma5-workspace-5.27.10-2.2.x86_64
  deinstallation of plasma5-workspace-libs-5.27.10-2.2.x86_64
  deinstallation of ksystemstats5-5.27.10-1.1.x86_64
  deinstallation of baloo5-imports-5.114.0-1.1.x86_64
  deinstallation of plasma5-session-5.27.10-2.2.noarch
  deinstallation of khotkeys5-5.27.10-1.1.x86_64
  deinstallation of kde-cli-tools5-5.27.10-1.1.x86_64
  deinstallation of plasma5-desktop-lang-5.27.10-1.1.noarch
  deinstallation of plasma5-systemmonitor-lang-5.27.10-1.1.noarch
  deinstallation of plasma5-workspace-lang-5.27.10-2.2.noarch
  deinstallation of powerdevil5-5.27.10-1.1.x86_64
  deinstallation of systemsettings5-5.27.10-1.1.x86_64
  deinstallation of kinfocenter5-5.27.10-1.1.x86_64
  deinstallation of patterns-kde-kde_plasma-20231206-1.1.noarch
  deinstallation of powerdevil5-lang-5.27.10-1.1.noarch
  deinstallation of khotkeys5-lang-5.27.10-1.1.noarch
  deinstallation of patterns-kde-kde-20231206-1.1.noarch
 Solution 2: keep obsolete libavcodec60-6.0.1-2.2.x86_64
 Solution 3: break ffmpeg-6-mini-libs-6.0.1-2.1.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/c/d/?] (c): 

1 Like

Das ist nicht notwendig. Der infame Host erlangen ist aktualisiert:

erlangen:~ # zypper dup
Loading repository data...
Reading installed packages...
Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
Computing distribution upgrade...
Nothing to do.
erlangen:~ # 

Mehr: https://forums.opensuse.org/t/zypper-dup-priorities/131842/3

Jetzt vielleicht einen Keks?
Schon im zweiten Beitrag wurde die Lösung genannt…

Funktioniert wieder. Außer nem Dateikonflikt beim nvidia-open-driver-G06-signed-kmp nix war heut nix aufregendes dabei.