Compiz and KDE in 11.2

I just learned from this thread that there’s an incompatibility between “compiz-kde4” and KDE 4.3, so I’m wondering what’s the state of Compiz/KDE support in 11.2? I can install it, but KDE window decorations don’t work. I get the GNOME decorations instead, I think. I could try Emerald decorations, but I heard Emerald is no longer being maintained. Is that true?

The Enhanced Zoom plugin doesn’t work either.

So am I out of luck if I want to use Compiz with KDE in 11.2?

  • rhasselbaum wrote, On 11/13/2009 07:16 PM:
    > So am I out of luck if I want to use Compiz with KDE in 11.2?

Maybe I’m not really helpful here, but do you have to use Compiz? If it is only for the desktop effects, I found the built in KDE effects much better than Compiz.


If you make Compiz the window manager, how do you expect Kwin window decorations to work? Use Emerald. Don’t know if it’s still “maintained” but Emerald themes certainly still work.

If you had read the thread you would realize the kde4-compiz package has been withdrawn.
kde4 desktop effects are best employed with kwin
If you must have Compiz then yes, you’ll get a load of gnome stuff. I should look out for an update on Compiz in kde from Ian (ijbreakey).

I did read the thread. As I said, I already know there’s an incompatibility. My question is if there’s a known fix for the zoom problem and whether the KDE window decoration problem is temporary or if using the GNOME decorations is just the way it’s going to work in 11.2. Emerald is not in the repos, BTW.

For what it’s worth, I prefer Compiz to KWin because I find the accessibility features in Compiz to work better for me. (I have low-vision.) I just want to see if I can get the same Compiz experience that I had prior to installing 11.2.

Zoom as in Ctrl-mouse wheel up

Right. It does nothing.

I don’t have a single Compiz package installed.
I use kwin
Just works
What more can I say.

Really hate to taint my current KDE 4 implementation with compiz, as when I use compiz, there are a couple of glitches with some things, such as Network Management allows itself to show below the panel when I right click it, and other things with fullscreen video. But I will take the dive and reinstall it and tell you how it goes. I know I tried compiz with the 11.2 RC’s and milestones and it worked with all of them as long as you follow the instructions from here:

Compiz Fusion - openSUSE

And ultimately my post here:

Compiz Fusion on 4.3 X - openSUSE Forums

Which is linked to from the site above.

If you have any problems with that or any more questions feel free to ask.

Take Care,


To be honest you are bettwer off with kwins effects, in the long run it works better then compiz in KDE, though compiz does have more “bling” in terms of how many effects it supports.

Compiz-fusion is up and running if you follow the steps from my guide. As the one-click installer still points to the 42 repos and 11.1, you’ll have to follow my guide for installing. Which means customizing your one-click install. Everything works, although I still have the same glitches as before. Here’s the results of opening a terminal and typing

rpm -qa --last “compiz

compizconfig-settings-manager-0.8.2-6.1 Sun 15 Nov 2009 02:09:21 AM EST
compiz-plugins-extra-0.8.2-102.1 Sun 15 Nov 2009 02:07:30 AM EST
python-compizconfig-0.8.2-3.1 Sun 15 Nov 2009 02:07:22 AM EST
libcompizconfig-0.8.2-9.1 Sun 15 Nov 2009 02:07:20 AM EST
compiz-plugins-main-0.8.2-101.7 Sun 15 Nov 2009 02:06:39 AM EST
compiz-manager-0.0.1_git080201-58.1 Sun 15 Nov 2009 02:06:33 AM EST
compiz-kde4-0.8.2-173.1 Sun 15 Nov 2009 02:06:32 AM EST
compiz-0.8.2-173.1 Sun 15 Nov 2009 02:05:44 AM EST
compiz-branding-openSUSE-0.8.2-173.1 Sun 15 Nov 2009 02:05:33 AM EST

As you can see all installed properly.

Take Care,


It’s not clear what OS version you are walking folks thru
It looks like you are suggesting 11.1 repos in 11.2:)

Well as far as 1-click-install goes, that’s the repo it installs. Until those get fixed then that’s what I’ve been using. And it works fine for now other than the couple things I’ve mentioned. Plus it includes the kde4 packages that the other repositories exclude. So for now that’s all I can suggest :\

Take Care,


I absolutely know - You know your stuff here Ian and I bow to your superior knowledge here. But I certainly would Not recommend this move. It might be OK when we know what we are doing, but as a general rule that will not be the case will it.
I’m negative in my feeling toward OneClick anyway.
Good luck if you try it out folks:X

Thanks for the tips, Ian.

As you have much more experience in repository management and linux in general, I yield my suggestion to not doing it the one-click install way with 11.1 repositories.

I’ve just added links for the 11.2 compiz.ymp in the compiz-fusion wiki. Had to create some templates as well, but I also added the note that the lack of a compiz-kde4 package will force compiz-gnome with some gnome dependencies. The thing I don’t get is that we’re still stuck with 0.7.8. So to get 0.8.2 with a working compiz-kde4 you would have to use the 11.1 compiz repository. If you can use 11.1 packages for 11.2 then this doesn’t cause a problem as a temporary fix for now does it? I’ve tested it out throughout the development of 11.2 and it’s always worked with the instructions in the compiz with kde 4.3 post. It’s what I had before I tried out the 11.2 packages for compiz.

The only reason I suggest the 11.1 repository is because with the compiz-gnome package that we now HAVE to use with 11.2, we lose the extra “commands” plugin, and thus KDE users have to manually set our screenshot to ksnapshot --current, and manually type in our commands to use alt+f2 with krunner in the General plugin.

Just some things to consider for now I guess. Either have a working compiz-fusion, or have a working supported compiz-fusion with some workarounds.

I guess I could make a thread about it for now in the how-to’s? But then when they finally include the kde4 package it’d have to be edited.

Take Care,


By all means Ian, we would welcome your input here. You have done excellent work on this already in the wiki (which is up for a major overhaul). If you do something in the Unreviewed HowTo section for now, well review it. And if things change, as they do, and it needs an edit, just pass on the changes and I’ll edit it for you.

Anyone know why 11.2 is using the older 0.7.8 version of Compiz? I discovered that (K)ubuntu 9.10 is using 0.8.4, and problems I saw with zoom and KDE decorations do not exist there.

Good question, It seems Compiz in Opensuse 11.2 stays with version 0.7.8. I tried figuring this out some time ago here but didnt get any sensable response. Kwin seems to be the prefered option. Perhaps Opensuse considers Compiz too unstable? Who knows?

Several people in this thread have said something like this, but please understand that this opinion isn’t shared by everyone. If KWin works great for you, then great. But Linux is about choice, right? :slight_smile: