Catastrophic result after today's graphics driver update

After I received an update this morning from:

Die folgenden 23 Pakete werden aktualisiert:
libgbm1 libgbm1-32bit libvdpau_r600 libvdpau_radeonsi libvulkan_radeon libvulkan_radeon-32bit Mesa Mesa-32bit
Mesa-dri Mesa-dri-32bit Mesa-gallium Mesa-gallium-32bit Mesa-KHR-devel Mesa-libEGL1 Mesa-libEGL-devel Mesa-libGL1
Mesa-libGL1-32bit Mesa-libglapi0 Mesa-libglapi0-32bit Mesa-libGL-devel Mesa-libva Mesa-vulkan-device-select
Mesa-vulkan-device-select-32bit

23 Pakete werden aktualisiert.

my entire graphical display was destroyed after the restart. Parts of the image were no longer displayed, Dolphin windows were simply black. My graphics card is an RX 580 with AMDGPU driver. I then booted a snapshot, which worked without any problems. So no hardware problem.

No idea which of these packages has messed this up and what to do about it.

10 Likes

I read only English, so am unsure of the gist of your paste. Is it showing a comprehensive list of upgraded packages?

If you read late Monday’s TW20240614 release announcement on the factory or announcements mailing lists you noted a version increment for Mesa. Are you using Packman’s yet newer version, or the fresh but older OSS version? The announcement also reports changes to KDE/Plasma, so lots more than 23 package changes in 20240614. If earlier in the day you only upgraded to 20240613, try upgrading to 20240614.

If from attempted boot from updated state you cat /var/log/Xorg.0.log | susepaste (only if attempting to use X11, not Wayland) and share the URL, someone maybe able to spot a clue. If the command fails, check if Xorg.0.log exists and is current in ~/.local/share/xorg, and susepaste it instead.

I forgot to say: I use Wayland.

And please, when your system is German and you want to post output in the English section, then precede your command with LANG=C . In this case most probably:

LANG=C zypper dup

That said, please always copy/paste things complete in your posts and not only the parts you think are important. Others may find that other things are important too. And complete is: starting with the prompt/command line (so we see what you did as whom), then all output, and the new prompt line (so we know it is complete).

1 Like

I have the exact same problem.

This afternoon I installed snapshot 20240614. I have two machines, one Ryzen 5950X, one Beelink mini-pc.

I installed the update using a virtual terminal and rebooted.

On BOTH machines, on reboot the desktop was trashed. On the main machine, portions of the desktop were blanked out, the KDE menu was completely black. On reboot, everything comes up “looking” fine, but when I started using it, it went back to completely trashed.

On the Beelink pretty much the same thing except the cursor became a thin line making it very hard to close out any windows except for watching when the close icon changes color. The rest of the desktop and the KDE menu is trashed.

I managed to recover the main machine using snapper back to 20240613 snapshot.

On the Beelink I decided to experiment by doing a fresh install of the latest Tumbleweed ISO with online updates. So that box is now on 20240614 - and doesn’t have any problems. Unfortunately now I have to reinstall everything on that box. Fortunately not too much is on there as it is primarily a backup box in case the main machines goes down.

But I can’t do a clean install on the main machine unless there is absolutely no other choice. So presently I’m sitting with one machine up to date with no software installed and the other one I don’t dare update because if it doesn’t work I have to do the reversion all over again - or another clean install which will take days to get back to speed.

I find it hard to believe that no one other than one person encountered this problem today.

I’m using X11, NOT Wayland.

Here are my specs on the Ryzen machine:

Operating System: openSUSE Tumbleweed 20240613

KDE Plasma Version: 6.0.5

KDE Frameworks Version: 6.3.0

Qt Version: 6.7.1

Kernel Version: 6.9.3-1-default (64-bit)

Graphics Platform: X11

Processors: 32 × AMD Ryzen 9 5950X 16-Core Processor

Memory: 62.7 GiB of RAM

Graphics Processor: AMD Radeon RX 550 Series

2 Likes

Same here. I also have an RX 580 GPU just like you, but I’m on Gnome 46.2, not KDE Plasma. I restored to a previous snapshot and everything is good now. This is how it looked like after the update:


The wallpaper changed to a solid black color.

Edit: Forgot to mention that I’m on Wayland and I have the Packman repo on for codecs.

Exactly the same here - messed up graphics - RX 580. I only installed to openSUSE Tumbleweed yesterday…

edit: tried both X11 and Wayland

1 Like

See my reply here: Error with the latest update in Gnome - #16 by suntorytimed

Removing packman and downgrading the packages helped for me.

I managed to install Mesa-24.1.1-1585.1.x86_64 from that mailing list item mentioned earlier and now X11 works but Wayland does not. Mesa-24.1.1-1582.1.x86_64 is not in the mentioned repo. For now I have a working system pretty much. Will see what happens over the next few days and see if I can get Wayland working.

If anyone has any suggestions as to how to get Wayland working I’d be interested!

Stuart

Just as test I rolled back to a pre-packman snapshot where it worked correctly then added packman and installed the codecs… broken system.

Oh BTW this was fresh net Tumbleweed installation from this morning.

@broadstairs have you thought about switch back to the Tumbleweed versions…

What does not work for you with the Tumbleweed version is probably the thing to determine, or because it’s in Packman I must need it?

As the linked thread on factory@ says, the issue is solved by not using Packman.

Tumbleweed without using Packman for Mesa or any graphics driver related libraries does not have this issue.

Hello,

So if Packman is not to be used ‘for the time being’ How would I go about installing the multimedia codecs etc?

please bare in mind I only installed openSUSE Tumbleweed yesterday and it was working fine up until this mornings update.

You don’t need to install graphics drivers from Packman to install the codecs.

Assuming you switched everything back to OSS, temporarily lock all Mesa*

zypper al Mesa*

Assuming you still have Packman enabled, switch everything else to Packman:

zypper dup --from Packman

(remember to substitute “Packman” with the Alias or number or URI it has on your system).
Unlock Mesa* for future upgrades from OSS:

zypper rl Mesa*
2 Likes

Switched everything back to openSUSE TW for Mesa but still no Wayland only X11. Loads of messages from wayland complaining unable to bind extensions and others.

Stuart

Hello mhurron/OrsoBruno

Right, I performed a fresh net install with the latest updates applied and everything was fine. When I installed the codecs from Packman my system broke. VLC complained about a pre-installed version especially.

Apologies I sound a little confused it because I am… I’m having steep learning curve introduction to openSUSE/Zypper etc. My background is more on the Debian side of things.

Kind Regards
Z

https://en.opensuse.org/SDB:Installing_codecs_from_Packman_repositories

To just install codecs, you don’t want to just add Packman with no further config before installing.

Hmm,

sudo zypper install opi
opi codecs

That’s what I did before and it broke my install.

?

Thanks
Z