Zypper Dup Having conflict with libvulkan and vlc code nox

sudo zypper dup
Refreshing service ‘NVIDIA’.
Refreshing service ‘openSUSE’.
Loading repository data…
Reading installed packages…
Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See ‘man zypper’ for more information about this command.
Computing distribution upgrade…
4 Problems:
Problem: 1: the installed libvulkan_intel-24.0.8-377.1.x86_64 requires ‘Mesa-vulkan-device-select = 24.0.8’, but this requirement cannot be provided
deleted providers: Mesa-vulkan-device-select-24.0.8-1699.380.pm.1.x86_64
not installable providers: Mesa-vulkan-device-select-24.0.8-377.1.x86_64[https-download.opensuse.org-00ce2562]
Mesa-vulkan-device-select-24.0.8-377.1.x86_64[https-download.opensuse.org-7aad9509]
Mesa-vulkan-device-select-24.0.8-377.1.x86_64[openSUSE:repo-oss]

Problem: 2: the to be installed vlc-codec-gstreamer-3.0.21-1.1.x86_64 requires ‘vlc-noX = 3.0.21’, but this requirement cannot be provided
not installable providers: vlc-noX-3.0.21-1.1.x86_64[https-download.opensuse.org-00ce2562]
vlc-noX-3.0.21-1.1.x86_64[https-download.opensuse.org-7aad9509]
vlc-noX-3.0.21-1.1.x86_64[openSUSE:repo-oss]

Problem: 3: the installed vlc-noX-3.0.20-1699.11.pm.19.x86_64 requires ‘libvlc5 = 3.0.20-1699.11.pm.19’, but this requirement cannot be provided
Problem: 4: the to be installed tlp-1.6.1-2.1.noarch conflicts with ‘tuned’ provided by the installed tuned-2.22.1.2+git.86ac977-3.1.noarch

Problem: 1: the installed libvulkan_intel-24.0.8-377.1.x86_64 requires ‘Mesa-vulkan-device-select = 24.0.8’, but this requirement cannot be provided
deleted providers: Mesa-vulkan-device-select-24.0.8-1699.380.pm.1.x86_64
not installable providers: Mesa-vulkan-device-select-24.0.8-377.1.x86_64[https-download.opensuse.org-00ce2562]
Mesa-vulkan-device-select-24.0.8-377.1.x86_64[https-download.opensuse.org-7aad9509]
Mesa-vulkan-device-select-24.0.8-377.1.x86_64[openSUSE:repo-oss]

Solution 1: install Mesa-vulkan-device-select-24.0.8-377.1.x86_64 from vendor openSUSE
replacing Mesa-vulkan-device-select-24.0.8-1699.380.pm.1.x86_64 from vendor http://packman.links2linux.de
Solution 2: install libvulkan_intel-24.0.9-1699.381.pm.1.x86_64 from vendor http://packman.links2linux.de
replacing libvulkan_intel-24.0.8-377.1.x86_64 from vendor openSUSE
Solution 3: keep obsolete Mesa-vulkan-device-select-24.0.8-1699.380.pm.1.x86_64
Solution 4: break libvulkan_intel-24.0.8-377.1.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/4/s/r/c/d/?] (c): ^C
Trying to exit gracefully…

And have a look at other already existing threads…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.