Zypper dup has vlc conflicts since this morning

Hy again!

Have on different machines with different repo configs since this morning (at least…):

sudo zypper dup
[sudo] password for root: 
Refreshing service 'NVIDIA'.
Refreshing service 'openSUSE'.
Retrieving repository 'packman' metadata .................................................................................[done]
Building repository 'packman' cache ......................................................................................[done]
Loading repository data...
Reading installed packages...
Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
Computing distribution upgrade...
2 Problems:
Problem: 1: the to be installed phonon-vlc-qt5-0.12.0-2.3.x86_64 requires 'vlc = 3.0.21', but this requirement cannot be provided
not installable providers: vlc-3.0.21-1.1.x86_64[openSUSE:repo-oss]

Problem: 2: the to be installed phonon-vlc-qt6-0.12.0-2.3.x86_64 requires 'vlc-noX = 3.0.21', but this requirement cannot be provided
not installable providers: vlc-noX-3.0.21-1.1.x86_64[openSUSE:repo-oss]


Problem: 1: the to be installed phonon-vlc-qt5-0.12.0-2.3.x86_64 requires 'vlc = 3.0.21', but this requirement cannot be provided
not installable providers: vlc-3.0.21-1.1.x86_64[openSUSE:repo-oss]

 Solution 1: deinstallation of phonon-vlc-qt5-0.12.0-2.2.x86_64
 Solution 2: install vlc-3.0.21-1.1.x86_64 from vendor openSUSE
  replacing vlc-3.0.20-1699.11.pm.10.x86_64 from vendor http://packman.links2linux.de
 Solution 3: keep obsolete phonon-vlc-qt5-0.12.0-2.2.x86_64
 Solution 4: break phonon-vlc-qt5-0.12.0-2.3.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/4/s/r/c/d/?] (c): 

Any advice? Wait another day? Or how to resolve?

I tried the solutions recommending switching VLC from packman to opensuse repo, but that results finally in some “missing” conflicts, so I canceled the update.

The switch back to OSS version worked flawlessly on several machines. Packman may need some more time to pick up the latest version…

1 Like

Hmm, I have a conflict here when switching to opensuse from packman:

sudo zypper dup
[sudo] password for root: 
Sorry, try again.
[sudo] password for root: 
Refreshing service 'NVIDIA'.
Refreshing service 'openSUSE'.
Loading repository data...
Reading installed packages...
Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
Computing distribution upgrade...
2 Problems:
Problem: 1: the to be installed phonon-vlc-qt5-0.12.0-2.3.x86_64 requires 'vlc = 3.0.21', but this requirement cannot be provided
not installable providers: vlc-3.0.21-1.1.x86_64[openSUSE:repo-oss]

Problem: 2: the to be installed phonon-vlc-qt6-0.12.0-2.3.x86_64 requires 'vlc-noX = 3.0.21', but this requirement cannot be provided
not installable providers: vlc-noX-3.0.21-1.1.x86_64[openSUSE:repo-oss]


Problem: 1: the to be installed phonon-vlc-qt5-0.12.0-2.3.x86_64 requires 'vlc = 3.0.21', but this requirement cannot be provided
not installable providers: vlc-3.0.21-1.1.x86_64[openSUSE:repo-oss]

 Solution 1: deinstallation of phonon-vlc-qt5-0.12.0-2.2.x86_64
 Solution 2: install vlc-3.0.21-1.1.x86_64 from vendor openSUSE
  replacing vlc-3.0.20-1699.11.pm.10.x86_64 from vendor http://packman.links2linux.de
 Solution 3: keep obsolete phonon-vlc-qt5-0.12.0-2.2.x86_64
 Solution 4: break phonon-vlc-qt5-0.12.0-2.3.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/4/s/r/c/d/?] (c): 2

Problem: 2: the to be installed phonon-vlc-qt6-0.12.0-2.3.x86_64 requires 'vlc-noX = 3.0.21', but this requirement cannot be provided
not installable providers: vlc-noX-3.0.21-1.1.x86_64[openSUSE:repo-oss]

 Solution 1: deinstallation of phonon-vlc-qt6-0.12.0-2.2.x86_64
 Solution 2: install vlc-noX-3.0.21-1.1.x86_64 from vendor openSUSE
  replacing vlc-noX-3.0.20-1699.11.pm.10.x86_64 from vendor http://packman.links2linux.de
 Solution 3: keep obsolete phonon-vlc-qt6-0.12.0-2.2.x86_64
 Solution 4: break phonon-vlc-qt6-0.12.0-2.3.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/4/s/r/c/d/?] (c): 2

Resolving dependencies...
Computing distribution upgrade...
4 Problems:
Problem: 1: the to be installed vlc-3.0.21-1.1.x86_64 requires 'vlc-qt = 3.0.21-1.1', but this requirement cannot be provided
not installable providers: vlc-qt-3.0.21-1.1.x86_64[openSUSE:repo-oss]

Problem: 2: the to be installed vlc-vdpau-3.0.20-1699.11.pm.19.x86_64 requires 'vlc-noX = 3.0.20', but this requirement cannot be provided
deleted providers: vlc-noX-3.0.20-1699.11.pm.10.x86_64
not installable providers: vlc-noX-3.0.20-1699.11.pm.19.i586[packman]
                   vlc-noX-3.0.20-1699.11.pm.19.x86_64[packman]

Problem: 3: the to be installed vlc-noX-3.0.21-1.1.x86_64 requires 'libvlc5 = 3.0.21-1.1', but this requirement cannot be provided
not installable providers: libvlc5-3.0.21-1.1.x86_64[openSUSE:repo-oss]

Problem: 4: the to be installed vlc-noX-3.0.21-1.1.x86_64 requires 'libvlccore9 = 3.0.21-1.1', but this requirement cannot be provided
not installable providers: libvlccore9-3.0.21-1.1.x86_64[openSUSE:repo-oss]


Problem: 1: the to be installed vlc-3.0.21-1.1.x86_64 requires 'vlc-qt = 3.0.21-1.1', but this requirement cannot be provided
not installable providers: vlc-qt-3.0.21-1.1.x86_64[openSUSE:repo-oss]

 Solution 1: install vlc-qt-3.0.21-1.1.x86_64 from vendor openSUSE
  replacing vlc-qt-3.0.20-1699.11.pm.10.x86_64 from vendor http://packman.links2linux.de
 Solution 2: do not install vlc-3.0.21-1.1.x86_64
 Solution 3: break vlc-3.0.21-1.1.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/c/d/?] (c): 1

Problem: 2: the to be installed vlc-vdpau-3.0.20-1699.11.pm.19.x86_64 requires 'vlc-noX = 3.0.20', but this requirement cannot be provided
deleted providers: vlc-noX-3.0.20-1699.11.pm.10.x86_64
not installable providers: vlc-noX-3.0.20-1699.11.pm.19.i586[packman]
                   vlc-noX-3.0.20-1699.11.pm.19.x86_64[packman]

 Solution 1: install vlc-vdpau-3.0.21-1.1.x86_64 from vendor openSUSE
  replacing vlc-vdpau-3.0.20-1699.11.pm.10.x86_64 from vendor http://packman.links2linux.de
 Solution 2: do not install vlc-noX-3.0.21-1.1.x86_64
 Solution 3: break vlc-vdpau-3.0.20-1699.11.pm.19.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/c/d/?] (c): 1

Problem: 3: the to be installed vlc-noX-3.0.21-1.1.x86_64 requires 'libvlc5 = 3.0.21-1.1', but this requirement cannot be provided
not installable providers: libvlc5-3.0.21-1.1.x86_64[openSUSE:repo-oss]

 Solution 1: install libvlc5-3.0.21-1.1.x86_64 from vendor openSUSE
  replacing libvlc5-3.0.20-1699.11.pm.10.x86_64 from vendor http://packman.links2linux.de
 Solution 2: deinstallation of phonon-vlc-qt5-0.12.0-2.2.x86_64
 Solution 3: keep obsolete phonon-vlc-qt5-0.12.0-2.2.x86_64
 Solution 4: break vlc-noX-3.0.21-1.1.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/4/s/r/c/d/?] (c): 1

Problem: 4: the to be installed vlc-noX-3.0.21-1.1.x86_64 requires 'libvlccore9 = 3.0.21-1.1', but this requirement cannot be provided
not installable providers: libvlccore9-3.0.21-1.1.x86_64[openSUSE:repo-oss]

 Solution 1: install libvlccore9-3.0.21-1.1.x86_64 from vendor openSUSE
  replacing libvlccore9-3.0.20-1699.11.pm.10.x86_64 from vendor http://packman.links2linux.de
 Solution 2: deinstallation of phonon-vlc-qt6-0.12.0-2.2.x86_64
 Solution 3: keep obsolete phonon-vlc-qt6-0.12.0-2.2.x86_64
 Solution 4: break vlc-noX-3.0.21-1.1.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/4/s/r/c/d/?] (c): 1

Resolving dependencies...
Computing distribution upgrade...
3 Problems:
Problem: 1: the to be installed vlc-codecs-3.0.20-1699.11.pm.19.x86_64 requires 'vlc-noX = 3.0.20', but this requirement cannot be provided
deleted providers: vlc-noX-3.0.20-1699.11.pm.10.x86_64
not installable providers: vlc-noX-3.0.20-1699.11.pm.19.i586[packman]
                   vlc-noX-3.0.20-1699.11.pm.19.x86_64[packman]

Problem: 2: the installed vlc-noX-3.0.20-1699.11.pm.10.x86_64 requires 'libvlc5 = 3.0.20-1699.11.pm.10', but this requirement cannot be provided
deleted providers: libvlc5-3.0.20-1699.11.pm.10.x86_64

Problem: 3: the installed vlc-noX-3.0.20-1699.11.pm.10.x86_64 requires 'libvlccore9 = 3.0.20-1699.11.pm.10', but this requirement cannot be provided
deleted providers: libvlccore9-3.0.20-1699.11.pm.10.x86_64


Problem: 1: the to be installed vlc-codecs-3.0.20-1699.11.pm.19.x86_64 requires 'vlc-noX = 3.0.20', but this requirement cannot be provided
deleted providers: vlc-noX-3.0.20-1699.11.pm.10.x86_64
not installable providers: vlc-noX-3.0.20-1699.11.pm.19.i586[packman]
                   vlc-noX-3.0.20-1699.11.pm.19.x86_64[packman]

 Solution 1: Following actions will be done:
  do not install vlc-noX-3.0.21-1.1.x86_64
  do not install vlc-qt-3.0.21-1.1.x86_64
 Solution 2: deinstallation of vlc-codecs-3.0.20-1699.11.pm.10.x86_64
 Solution 3: break vlc-codecs-3.0.20-1699.11.pm.19.x86_64 by ignoring some of its dependencies

…and no option sounds really good to me.

You need to chose the options which switch the packages to vendor openSUSE.
It may be easier for you to use YaST Software. Search for VLC and switch in the versions tab to openSUSE OSS. It is a little bit more convinient as the terminal way in such case…

Zypper performed the upgrade anyway:

3400g:~ # zypper if openSUSE-release
Loading repository data...
Reading installed packages...


Information for package openSUSE-release:
-----------------------------------------
Repository     : openSUSE-Tumbleweed-Oss
Name           : openSUSE-release
Version        : 20240613-2951.1
Arch           : x86_64
Vendor         : openSUSE
Installed Size : 223.9 KiB
Installed      : Yes
Status         : up-to-date
Source package : openSUSE-release-20240613-2951.1.src
Summary        : openSUSE Tumbleweed
Description    : 
    openSUSE Tumbleweed is the rolling distribution by the openSUSE.org project.

3400g:~ # 

More: Noninteractive System Upgrades

I still get:

sudo zypper dup
[sudo] password for root: 
Refreshing service 'NVIDIA'.
Refreshing service 'openSUSE'.
Retrieving repository 'KDE:Unstable:Extra' metadata ......................................................................[done]
Building repository 'KDE:Unstable:Extra' cache ...........................................................................[done]
Retrieving repository 'packman' metadata .................................................................................[done]
Building repository 'packman' cache ......................................................................................[done]
Loading repository data...
Reading installed packages...
Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
Computing distribution upgrade...
2 Problems:
Problem: 1: the to be installed phonon-vlc-qt5-0.12.0-2.3.x86_64 requires 'vlc = 3.0.21', but this requirement cannot be provided
not installable providers: vlc-3.0.21-1.1.x86_64[openSUSE:repo-oss]

Problem: 2: the to be installed phonon-vlc-qt6-0.12.0-2.3.x86_64 requires 'vlc-noX = 3.0.21', but this requirement cannot be provided
not installable providers: vlc-noX-3.0.21-1.1.x86_64[openSUSE:repo-oss]


Problem: 1: the to be installed phonon-vlc-qt5-0.12.0-2.3.x86_64 requires 'vlc = 3.0.21', but this requirement cannot be provided
not installable providers: vlc-3.0.21-1.1.x86_64[openSUSE:repo-oss]

 Solution 1: deinstallation of phonon-vlc-qt5-0.12.0-2.2.x86_64
 Solution 2: install vlc-3.0.21-1.1.x86_64 from vendor openSUSE
  replacing vlc-3.0.20-1699.11.pm.10.x86_64 from vendor http://packman.links2linux.de
 Solution 3: keep obsolete phonon-vlc-qt5-0.12.0-2.2.x86_64
 Solution 4: break phonon-vlc-qt5-0.12.0-2.3.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/4/s/r/c/d/?] (c): 

Presumably you don’t need phonon-vlc-qt5 and phonon-vlc-qt6. Host 3400g doesn’t need them. Select Solution 1.

I have updated the packages to 3.0.21 under Tumbleweed without any dependency conflicts with the phonon packages. However, I took the packages from the multimedia repository.

@karlmistelberger I followed your advice and everything went smooth: uninstalled phonon qt5/6 solution 1) and zypper dup --allow-vendor-change
Thanks!