You can't install from the live isos, Better use the installation iso.

**This is just to inform. **
First I tried to install from the live isos, but always had some problem installing. They are good to look how OpenSuse works, but if you want to install, best do that from the installer iso. And, if you have an ethernet connection, it is even better. WiFi can be enabled afterwards. Installed both KDE and Gnome.

Hmm, I think I should try that.

If I see the same problem, I’ll report a bug or add to an exist bug report if I can find one.

I downloaded the latest live KDE Tumbleweed (64-bit). Then I tried to install into a virtual machine.

The install went pretty well, though there was some weirdness. For example, it asked if I wanted to add online repos for the install. Since the live systems only use the NET installer, they have to use online repos. So it seems weird to ask.

And then, when it finished, it said that it was rebooting. But it did not reboot. It just exited and returned to the live session. That’s fine, except that the message saying it would reboot was wrong.

The big problem was when I attempted to boot the newly installed system. It would not boot into the GUI. Adding a “3” at the end of the boot line, it could at least boot to multi-user mode (command line login).

There were many failure messages during boot.

It looks as if some needed system users and system groups had not been added to “/etc/passwd” and “/etc/group”.

I may look into filing a bug report tomorrow.

When you do, please let’s know where it is. I’d like to know how to file a bug. Never did this before. Thanks! :slight_smile:

Yes, I’ll post the bug number and link here, and maybe a comment about filing bug reports.

Bug reported.

Bug 1155687 Bad install when using Tumbleweed live iso (20191030)

To report the bug, I used the link:

openSUSE:Submitting bug reports

That gives guided way of reporting bugs. I selected the option for Tumbleweed. If you are prompted for a login, use the same login as for the forums.

After describing the bug, I attached the Yast logs for the install. Any install bug or any bug relating to Yast, they will want the Yast logs. The command “save_y2logs” as root will save those logs to a file, and tell you where the file is.

I also attached a copy of “/etc/passwd” and “/etc/group”, since those files seem to have not been properly setup in the install. The people who examine bugs need any useful hints that you can provide as to what was going wrong.

Thanks for the report and the help! :slight_smile:

By the way, you can add a comment to that bug report, if you think that would be useful.

I do what the download page suggests:

  • Install from Network Image (or DVD Image if no network available during install)
  • Make sure you always use the latest NET-iso, older versions work too, but they will update before installing anyway.

The live systems are great for testing openSUSE on your hardware:

  • Updating Leap Live is working fine
  • Don’t update Tumbleweed Live, always fetch the current iso

One more difference between installation and live media is bootloader resolution - installation is using gfxmode=auto which means grub keeps whatever resolution firmware was using while live forces 800x600. So on a OVMF QEMU with preset resolution I get tiny window using Live unless video=WxH option is added.

I noticed that in LEAP 15.0 (and since), I didn’t pay attention earlier so don’t know how long this has existed…
And, I think I posted about this awhile back, too…

Looking closely, there seems to be a very big difference installing from a NET ISO with or without “configuring online repos.”
I strongly suspect that the NET ISO by default connects to an online version of the DVD packages, so is not extensive or likely up to date
With a NET ISO install, if you do not “configure online repositories” you should also “zypper up” after installing, whereas if you do configure online repositories a “zypper up” is not as important although I still recommend just to be certain you have latest installed.

AFAIK unless something has changed, since the Live ISOs have been made available again they have never been intended to be used as install media (or at least to initiate an install of any type). I’m not even sure how people would try to install… maybe dd the running image to the drive? That’s not exactly an install and would involve all kinds of potential pitfalls. In “the old days long ago” when Live ISOs were fully supported as a means for installation, there was a Desktop shortcut to kick off an install (maybe a NET install?).


Which is exactly what standard installer does as well. If you say “no” you will get default repositories - and yes, they will be online too. When you say “yes” you simply get chance to enable more than default set.

Today Live installer starts exactly the same program as NET installer. So any difference between both is due to different initial environment (one side effect was shown in your bug report) or different control.xml. The former is a bug (installer should not depend on how it was started); the latter - if this is really the case - should be straightforward to fix.

Bugs always provide some extra fun:
Fixing them may be trivial, but they tend to occur again:

“Expert partitioner failed on several occasions in the past. Current installer openSUSE-Tumbleweed-NET-x86_64-Snapshot20190307-Media.iso again has an issue: Deleting a partition will fail. Automatic testing of all options is recommended.”

Only thorough testing will prevent this and implementation can take some time:

I followed up my live install with a DVD install.

The DVD install used the repo “openSUSE-20191030-0” as install source. And that was just the DVD as repo. I did not configure online repos.

The NET install from the live media also used “openSUSE-20191030-0” as install source. But this was just the online oss repo. When finished, the oss repo was there twice in the repo list, once as “openSUSE-20191030-0” and once with the usual “oss” name. This is pretty much as described by arvidjaar in the post below yours.

There is a comprehensive Installation guide, step 5 explains:

“Click “Configure Online Repositories” to choose additional online repositories. Once you’ve chosen the repositories, click “Next” to continue. You will be returned to the original screen, click “Next” to continue”.

Would like to insert after first sentence: “If unsure skip for now, can be done after installation completed”.

What “comprehensive Installation guide” are you referring to, maybe that is the problem?
I don’t agree that your solution addresses the problem or properly explains the difference when running a NET install with or without online repositories.

The clearest and easiest example to see the difference is to first decline to “configure online repositories” and inspect the available patterns for installing various DE. You’ll find only the standard KDE/Plasma, Gnome and XFCE choices even if when clicking on “Software” in the Installation Summary to launch the YaST Software Manager.
Now, cancel and hit the “back” button until you’re presented with the offer to “configure online repositories” again, and this time accept.
When you reach the Installation Summary this time, click on “Software” and inspect your available DE patterns. Now, you will see the full array of possibilities including LXDE, LxQT, Mate, Enlightenment and more.

This is just the most obvious way to verify that depending on whether you accept “configure online repositories” or not even in a NET install, you will be pointing to a different online OSS during your install.

Note that anyone can run the above exercise with a NET install ISO without altering your existing system… Or run in a VM if you have virtualization set up.


The problem is with new or less experienced users. They have no idea what is going on. The following guide tries to address the problem:

“In this article, we are going to take a look at the new features available in OpenSUSE Leap 15 along with simple step-by-step guide to install OpenSuse Leap 15 in your system with screenshots.”

They have 11 steps only and concise text understandable for beginners. To my experience this kind of article works better than Installation Quick Start:

Wrong as usual.

Might be wrong, but need to know exactly what is different than what I described.
No details, can’t fix my problem.



Just to add my $.02 . . . I just spent a long weekend trying to get a TW install into a partition that previously had Leap 15 . . . possibly .2 install that the forum spent some time with me to try to work out some problems with nvidia drivers . . . and then a Debian based system seemed to snuff the life out of . . . .

Anyway, first I tried the NET installer . . . I did select “use or update online repos” . . . did “manual partitioner” . . . and it ran through the download and install and at some point, failed or crashed or something . . . . I tried a couple of times that way.

Then I went to


and tried about 3 times, failing for various reasons, the installer would ask certain question, but then not see other issues, could not find my previous user account over in a separate /home directory, but did find a ubuntu user in another HD . . . . Finally I thought I had figured out some various problems, installer doesn’t like the OSX created “200MB EFI directory” as far as the /efi/bootloader option goes, but since I multi-boot I have been able to use another system to get grub working . . . anyway, 4th time was the “charm” . . . system gave me choice of “reboot” or “return to live session” no “shut down” option from installer. System rebooted and found its way back to the new TW install . . . I followed “mrmazda” or “tsu2” advice to just set up a basic GUI and not accept nouveau . . . so it was an “ice weasel”?? DE . . . I used Yast to add MATE, which it did, I ran zypper to catch any upgrades, I logged out and back into the Mate DE . . . on reboot this time I used Grub list, scrolling to “sdb8 TW” . . . instantly loads the “efi missing” with black screen.

Numerous attempts to “update-grub” in other linux systems have not revived the system, all of the other 3 systems I have in that disk work, TW shows up in th elist, I tried “recovery” . . . I tried the install usb drive “boot linux from hard disk” . . . scrolls down to “starting locale services” if I go to a TTY from there I can “log in” to my user account, but so far “nothing to do” . . . choosing recovery from grub shows a “kernel panic” line . . . .

So, it’s fairly “messy” as far as I’m concerned, possibly the installer is part of the problem, but very curious how it initially rebooted to a basic GUI, then seemed to lose the plot when going via Grub?

Happy to add my issue into @nrickert’s bug report . . . not entirely clear how much is pilot error and how much is installer. I have run quite a number of installs and upgrades over the years, and over the same time frame I ran a Manjaro install that went . . . fine, no problems running it the way I generally do . . . . The Opensuse options comparatively were “rough” in NET and the other x86 option, which I guess is now the live??