You can't install from the live isos, Better use the installation iso.

You can get around that by using the expert partitioner. Assign that EFI partition to be mounted at “/boot/efi”. Provide other partitions as appropriate for your needs.

You will get a warning that the EFI partition is smaller than 256M. You can click “ignore” and continue with the install.

If you are not familiar with the expert partitioner, maybe you shouldn’t try this.


You picked that issue out of all of the issues I posted about?? : - )))) I have run hundreds of installs very likely, key point that seemed to be the main point of this thread is that there is some “problem” with the installer??? And in running a number of them this weekend, not one of them was what might be called successful . . . in spite of my 'expertise" in the area of running installs . . . there were problems. Problems that did not appear when running essentially the same kind of install with manjaro, which seems “similar” as far as the install and booting of opensuse goes, similar feel, etc. Manjaro went well, TW in two different installers, net and live . . . basically busted down . . .

I always preconfigure the device(s) to use, likewise I always use the expert partitioner and never had issues. If it’s windows, backup user stuff, then blow it all away for fresh installs… :wink:

inxi -GASz
System:    Host: gekkota-nagios Kernel: 4.12.14-lp150.12.76-default x86_64 bits: 64 Console: tty 0
           Distro: openSUSE Leap 15.0
Graphics:  Card: Intel Mobile GM965/GL960 Integrated Graphics Controller (primary)
           Display Server: 1.19.6 driver: i915 tty size: 191x26 Advanced Data: N/A for root out of X
Audio:     Card Intel 82801H (ICH8 Family) HD Audio Controller driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.12.14-lp150.12.76-default

/dev/sda2:SUSE Linux Enterprise Desktop 12 SP4:SLED:linux:btrfs:UUID=be4744f7-3091-4ed4-9b03-e84d042ea952:subvol=@
/dev/sda4:Mac OS X:MacOSX:macosx

sda      8:0    0 465.8G  0 disk 
├─sda1   8:1    0   200M  0 part /boot/efi
├─sda2   8:2    0    40G  0 part 
├─sda3   8:3    0     4G  0 part [SWAP]
├─sda4   8:4    0   100G  0 part 
├─sda5   8:5    0 619.9M  0 part 
├─sda6   8:6    0   200G  0 part /data
└─sda7   8:7    0    40G  0 part /

The key point for this thread was with the installer when using live media (live Gnome, live KDE or live XFCE. The live XFCE iso is usually called “live rescue”.) As far as I know, these problems do not show up if you use the DVD installer or the NET installer.

We’ve tried the 20191023 snapshot live (wired) entire disk and we did not encounter any issues. There were only 2 packages to deal with after dup. Live CD seems faster than zypper dup.

/boot at 256MB is pretty small these days. The partition needs attention, you must remove old Kernels.

The EFI boot partition is not mounted on /boot, but on /boot/efi and does not contain the kernels. These are in /boot.


Ah, this is referring to the online “live” systems??? I wasn’t messing with any of that . . . but as mentioned in the prior post it did seem to go sideways with TW DVD & NET installers over the weekend . . . thought others were suffering with me on it, but I guess it’s jes me . . . .

I was looking to see if there was a thread that could save me starting a new thread on it, might do that tomorrow or so . . . . In comparo I just ran another Manjaro install, done in ten minutes, rebooted and up and running . . . no kernel panics. I did as Malcolm does, pre-formatted the partitions . . . installer ran clean.

I did a test install on Saturday Nov, using the 20191030 DVD installer. The install went smoothly.


Was that a TW install or Leap daily??

That was a Tumbleweed install, using


All installers have their quirks. I’m used to the openSUSE installs, so they usually go well for me. I’m more likely to trip up with a fedora install or a debian install, since I only rarely do those.


Interesting that my iso file did not have a date, just an underscore and a number . . . .

So OK, let’s go with your view that somehow I botched the install . . . always possible when working with open source materials . . . . How do you explain the part where the installer rebooted the system in a multi-boot/multi-HD environment, found itself, I logged in to the basic IW GUI . . . fiddled around with it, sync’d FF . . . then used Yast to add the MATE pattern, logged out, logged back in to MATE . . . did something else, then shut down the computer . . . .

And then on cold boot Grub menu, selecting the TW option brings nothing but black screen, “kernel panic” . . . and trying the various “recovery” and “boot from HD” all basically end with a freeze in the dmesg or tty environment??? If I look in GParted in another OS I can see that the TW system is “there” . . . and it shows up in Grub as a line item with a kernel, but on basic launch from Grub it says something like “you have to load the kernel first” . . . ???

Yes, I noticed your mention of “openSUSE-Tumbleweed-DVD-x86_6417”

Where are you getting your iso files? I am getting them from

which, as far as I know, is the official download site.

Maybe you are using isos that have not passed openQA testing. And you should expect problems with those.

I should add that I normally use “ext4” rather than “btrfs”. And I don’t have “nvidia” graphics. I’m not trying to pick an argument. I was just describing my different experience.

. . . and it shows up in Grub as a line item with a kernel, but on basic launch from Grub it says something like “you have to load the kernel first” . . . ???

I cannot tell from your description. You will sometimes see that happen if secure-boot is enabled but you try to load the kernel with “linux” rather than with “linuxefi”.


I got mine from an official looking OpenSuse download page . . . .

But that doesn’t look like your “dailies” type page . . . the checksum numbers matched, live version booted up and ran fine . . . trying to boot from GUI Grub pages, not console command line . . . .

Also use ext4 . . . and followed mrmazda/tsu2 advice to not load nvidia or even nouveau with basic GUI install selected . . . all seemed to go well until cold boot, then multiple attempts to try to repair and or rescue have not revived what was a “working” install . . . .

That should be okay, as far as I know. But that’s an html web page. The links to iso all seem to have names ending in “Current.iso”. I didn’t see anything with the numbered links, though I do see those names in the sha256 files for live media.

I’m guessing that you are mainly having problems because of nvidia graphics. I have only Intel graphics, which seems to cause fewer issues.

A note on installing from a live iso.

I just had a good install with openSUSE-Tumbleweed-KDE-Live-x86_64-Snapshot20191104-Media.iso

Well, more correctly, I had a bad install. I then followed the suggestion of arvidjaar (in the bug report), and tried again. But this time I use the command

systemctl stop nscd.service

before starting the install. And that seemed to do the trick.

There is no such thing as a dailies page. If you look at the URLs for the download buttons, none of them refers to such an odd numbered iso. The links are pointing to exactly the same files as the direct ones. No other way than that you saved the file under some other name. Absolutely no other way.

If you have an NVIDIA card, it’s outright wrong to force unloading both NVIDIA and nouveau. A proper running system incl. desktop needs either one. Mind the word ‘proper’.

I have no idea what happens with your installs, but you have too many issues compared to my own experiences ( dozens of 15.0, dozens of 15.1, dozens of TW ), and those of others. With what you are reporting here, the isos would never have gotten through passing openQA and hence never have been released.

And re the filesystem: If you would follow the defaults for once, you’d end up with btrfs and have the option to rollback to a previous btrfs snapshot in case things go wrong.


OK, I figured that there wouldn’t be “dailies” in OpenSUSE . . . but I realize now that I got the file name from the usb flash drive installer that was mounted in another system desktop . . . and possibly it was the name created by mkusb . . . after the iso was cloned over to the flash drive. So that might explain the differences in the file names, I just haven’t rebooted back into the partition where I downloaded the TW dvd installer to see but like I said, it was from the opensuse page I linked, checksum checks out, etc.

So, obviously there is a “non-alignment” of views here in the forum about how to install a system . . . as previously in one of my Opensuse installs I was having problems with getting “suspend” to work, and at that time I was using nouveau, and the recommend was to add nvidia repos. Then in the recent perhaps 15.2 it was suggested that nvidia drivers weren’t up to date, in the move from 15.1 to .2 . . . so I tried to remove nvidia via Yast and it sort of didn’t go well . . . .

Then it was suggested that going with “nomodeset” would get around the problems of upgrading and nvidia . . . so I didn’t “force” anything, I just made the choice for “basic” GUI, and then I declined the “nouveau” option, as was suggested previously to try to get the default video driver set up, etc.

Point being, after the last attempt, it went “well” and it “worked” up until the cold boot . . . so my assessment is that at some point the install had gone fine, but quickly “disintegrated” . . . . I’m competent with running installs, but then figuring out how to diagnose the pathway to that disintegration . . . ???

That sounds more plausible.

When I look inside the sha256 checksum file


it reports the checksum as for:


Those names, with a “Build” number, are what I see elsewhere, such as at openQA.


The checksums matched from where I downloaded the file . . . .

I think, it is a simple matter. Just use the live isos to have a look how OpenSuse works, but use the installer iso to install. This is mentioned specifically. The installer iso installs what you want without fail.

(Ah, btw, Manjaro or Ubuntu or other live isos are of no interest here, as they won’t install OpenSuse. :wink: )