YaST Sound setting resets after reboot

I have an Intel HD Audio on motherboard (ICH9R driver). Sound outputs and inputs are not available in the system sound setting by default after fresh installation (I was using Kubuntu before for years).
It appears in the sound setting and works well after automatic configuration of Intel HD Audio in YaST-Sound.
But the sound outputs and inputs are not visible after each reboot again. It appears only after repeating of configuring procedure.
Any ideas what about it?

System

Operating System: openSUSE Leap 15.4
KDE Plasma Version: 5.24.4
Kernel Version: 5.14.21-150400.24.41-default (64-bit)

pacmd list-cards

index: 1
name: <alsa_card.pci-0000_00_1b.0>
driver: <module-alsa-card.c>
owner module: 21
properties:
alsa.card = “0”
alsa.card_name = “HDA Intel”
alsa.long_card_name = “HDA Intel at 0xfcff8000 irq 24”
alsa.driver_name = “snd_hda_intel”
device.bus_path = “pci-0000:00:1b.0”
sysfs.path = “/devices/pci0000:00/0000:00:1b.0/sound/card0”
device.bus = “pci”
device.vendor.id = “8086”
device.vendor.name = “Intel Corporation”
device.product.id = “293e”
device.product.name = “82801I (ICH9 Family) HD Audio Controller (P5K PRO Motherboard: 82801IR [ICH9R])”
device.form_factor = “internal”
device.string = “0”
device.description = “Built-in Audio”
module-udev-detect.discovered = “1”
device.icon_name = “audio-card-pci”
profiles:
input:analog-stereo: analog stereo input (priority 32833, available: unknown)
output:analog-stereo: analog stereo output (priority 39268, available: unknown)
output:analog-stereo+input:analog-stereo: analog stereo duplex (priority 39333, available: unknown)
output:iec958-stereo: digital output (IEC958) (priority 38268, available: unknown)
output:iec958-stereo+input:analog-stereo: digital output (IEC958) + analog stereo output (priority 38333, available: unknown)
off: Off (priority 0, available: unknown)
active profile: output:analog-stereo+input:analog-stereo
sinks:
alsa_output.pci-0000_00_1b.0.analog-stereo/#1: Built-in Audio analog stereo
sources:
alsa_output.pci-0000_00_1b.0.analog-stereo.monitor/#1: Monitor of Вбудоване Built-in Audio stereo
alsa_input.pci-0000_00_1b.0.analog-stereo/#2: Вбудоване аудіо Аналогове стерео
ports:
analog-input-front-mic: Front Microphone (priority 8500, latency offset 0 usec, available: unknown)
properties:
device.icon_name = “audio-input-microphone”
analog-input-rear-mic: Rear Microphone (priority 8200, latency offset 0 usec, available: no)
properties:
device.icon_name = “audio-input-microphone”
analog-input-linein: Line In (priority 8100, latency offset 0 usec, available: no)
properties:

analog-output-lineout: Line Out (priority 9000, latency offset 0 usec, available: no)
properties:

analog-output-headphones: Headphones (priority 9900, latency offset 0 usec, available: unknown)
properties:
device.icon_name = “audio-headphones”
iec958-stereo-output: Digital Output (S/PDIF) (priority 0, latency offset 0 usec, available: unknown)
properties:

Sounds like “my” issue Audio dead after kernel update 5.14.21-150400.24.38-default x86_64

Try if “pulseaudio -k” enables your sound again after it is dead when pausing sound for more than 5 seconds.

It doesn’t help. I have no problem with pausing sound but it was working until few last updates. I’ve installed fresh system nearly two month ago.

Also there is warning message on boot screen: snd_hda_intel: Cannot probe codecs, giving up!

The sound output appears in volume control and pavucontrol only after reconfiguring in YaST:
Screenshot_yast sound

Can you share the output from the following command?

sudo dmesg | egrep -i "snd|firmware"
sudo dmesg | egrep -i "snd|firmware"

[    0.462159] pci 0000:02:00.0: [Firmware Bug]: disabling VPD access (can't determine size of non-standard VPD format)
[    1.752792] snd_hda_intel 0000:01:00.1: Disabling MSI
[    1.752806] snd_hda_intel 0000:01:00.1: Handle vga_switcheroo audio client
[    1.766665] snd_hda_intel 0000:01:00.1: Cannot probe codecs, giving up
[    1.767341] snd_hda_intel 0000:00:1b.0: Cannot probe codecs, giving up
[    7.609269] usbcore: registered new interface driver snd-usb-audio
/etc/modprobe.d/50-sound.conf

options snd slots=snd-cmipci,snd-hda-intel
# Ikk3.leFtcOMtGx0:CMI8738/C3DX PCI Audio Device
alias snd-card-0 snd-cmipci
# u1Nb.c9J1KXzTGCE:P5K PRO Motherboard: 82801IR [ICH9R]
alias snd-card-1 snd-hda-intel

P.S. CMI8738 is my PCI sound card. I’m using it until solove motherboard sound problem.

I’m not sure about the underlying cause of these errors…

[    1.766665] snd_hda_intel 0000:01:00.1: Cannot probe codecs, giving up
[    1.767341] snd_hda_intel 0000:00:1b.0: Cannot probe codecs, giving up

…and it may take a bug report to help progress it. If you unload and reload the snd_hda_intel module via a terminal, does that then result in working sound? If so, a workaround to do this via a custom systemd unit may be helpful as a temporary measure.

Let’s see what others can recommend here.

BTW, please supply some chipset details…the complete output from

inxi -ASa

Thanks to all for help.

Here is it:

Summary

Did you try unloading and reloading the audio driver after booting as I mentioned already? Does that result in working sound?

BTW, when posting output, please use the ‘Preformatted text’ </> button. Quoting it as you have done makes it harder to read.

You have PulseAudio and PipeWire running at the same time. As far as I know only one of them can be used at a time.

This PipeWere server is part of Plasma Wayland desktop. Some Wayland libs are in dependency. But I don’t use it (because of glitches) and can delete Wayland and PipeWire completely if need.
pipewire-pulseaudio package is not installed.

Picture

pipewireinst

Do you mean reloading alsa and pulseaudio?

$ pulseaudio -k
# systemctl status sound.target

It changes nothing or I do something wrong.

I have never used Wayland so far and therefore it is not installed on my system and the installer insisted to remove PulseAudio when I decided to install PipeWire.

So I’m afraid that I cannot help any further …

Try (immediately after booting)…

sudo alsactl init

Does that result in the problem sound card working?

FWIW, I don’t think having PulseAudio and Pipewire active concurrently does cause issues, although I have pipewire-pulseaudio installed instead. I’ve encountered no real issues since using pipewire with openSUSE Leap 15.4 and KDE desktop.