Audio dead after kernel update 5.14.21-150400.24.38-default x86_64

Since the recent kernel update 5.14.21-150400.24.38-default x86_64 there is no sound anymore on my machine. Booting 5.14.21-150400.24.33-default x86_64 brings things back to normal.

In plasma everything looks OK, devices are shown, system is able to play mp3s without error messages, there is just no output at all.

Anyone got a hint what I can check?

Hi, I have the same.

A temp solution for me is to run as your user “pulseaudio -k”.

I could only find this: [SOLVED] PulseAudio stops speaker output after certain actions / Newbie Corner / Arch Linux Forums
Seems to be a kernel problem. Hope suse also solves this. Took me hours already.

Running on the same kernel, everything is working fine.
Did you check whether is the audio driver correctly loaded?

###:~> inxi -Axxx
Audio:     Device-1: Intel 5 Series/3400 Series High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
           bus-ID: 00:1b.0 chip-ID: 8086:3b56 class-ID: 0403
           Device-2: Advanced Micro Devices [AMD/ATI] RV710/730 HDMI Audio [Radeon HD 4000 series] vendor: ASUSTeK
           driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 1002:aa38 class-ID: 0403
           Sound Server-1: ALSA v: k5.14.21-150400.24.38-default running: yes
           Sound Server-2: PulseAudio v: 15.0 running: yes
           Sound Server-3: PipeWire v: 0.3.49 running: yes

No, at least not this. But it is detected. At least mow (when it is working). The basic issue is that after reboot, or sleep or even when doing something in firefox sound suddenly is gone, While the visual feedback is still there.

Before my quicker workaround I was able to get it to work in Yast (Edit and Quick setup the soundcard). Strangeley enough then Yast says the soundcard is not set up.

inxi -Axxx
Audio: Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Hewlett-Packard driver: sof-audio-pci-intel-tgl
bus-ID: 00:1f.3 chip-ID: 8086:a0c8 class-ID: 0401
Device-2: GN Netcom Jabra SPEAK 410 type: USB driver: jabra,snd-usb-audio,usbhid bus-ID: 3-6:8 chip-ID: 0b0e:0410
class-ID: 0300 serial: 70BF9265716Fx011200
Sound Server-1: ALSA v: k5.14.21-150400.24.38-default running: yes
Sound Server-2: PulseAudio v: 15.0 running: yes
Sound Server-3: PipeWire v: 0.3.49 running: yes

Also I have a lot of this in my dmsg output:

journalctl -k | grep -Ei “ALSA|HDA|sof|HDMI|snd[_-]|sound|hda.codec|”

dec 27 13:27:50 jerry kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: Firmware info: version 2:0:0-b678a
dec 27 13:27:50 jerry kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: Firmware: ABI 3:20:0 Kernel ABI 3:18:0
dec 27 13:27:50 jerry kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: warn: FW ABI is more recent than kernel

sof-firmware has been installed at install and has never been updated.

The entry “FW ABI is more recent than kernel” can (but not always) mean that the sof_firmware is too new for your kernel. This having sof_firmware too new may have also been true for your older kernel, but you were simply ‘lucky’ then that it worked, but now with the newer kernel it doesn’t work (as it is still too new for a newer kernel). … or it could be another issue. This is something thou you could check (trying an older sof_firmware version).

A speculative possibility (it try, and if it fails remove) … I note an arch linux user had similar behaviour and messages to what you report: [SOLVED] built-in audio doesn't work / Newbie Corner / Arch Linux Forums

Their solution was to add to grub :
and reboot …

You could try that, and if it doesn’t work, then remove that entry, so that it does not cause further problems in the future.

Hi oldcpu,

Thanks. The work-around solution to add a command to grub at least did help me (i am not the original poster). At least for now - I only did one restart. I cannot bounce computers I work on continuously :face_with_peeking_eye:

But I still feels there is an issue on the side of Opensuse.

  • This laptop is new and I installed a fresh version of Opensuse leap 15.4 with KDE
  • Sound has been working without issues until recently. I think since I installed the latest kernel (i did not take notice enough to be sure). I worked for some days using the “yast” work-around until I had the time to invest into problem-solving.
  • There is only one version of sof-firmware that was installed some weeks ago. There is no older version. If I search there is a newer version only (2.2). So the ABI being incompatible with the default kernel is not me. My kernel is 5.14.21-150400.24.38-default now.

Hope it helps other people. Being able to use pulsaudio -k was already an improvement, but this is better.


Hi oldcpu and Vollebak,

thanks from my side also, as I am the OP. I added the parameters to grub and now the sound output works again, even with the latest kernel 5.14.21-150400.24.38-default x86_64.

I can confirm the situation being very similar here:

  • After upgrading to 15.4 end of October I had no sound problems at all so far.
  • Last update of sof-firmware was version 2.2.2-lp154.41.1 from Nov 15th, again, no sound issues with that
  • As I said in my first posting I can exactly spot the first appearance of the sound problems with the installation of kernel 5.14.21-150400.24.38-default x86_64 on Dec 21st

So yes, the grub workaround is an improvement - but no, this cannot be the final solution, as the timeline clearly shows the dependency to the kernel update.

What can we do from our side to support looking for the root cause?

Kind regards

The kernel developers are aware of this and are working on a fix. All kernels below 5.17 are effected.

1 Like

Also this bug:

Does it works if you copy the ko from the 33 kernel to the update directory in 38 kernel as suggested?

Thanks, good to hear.

For the time being I use the work-around. I was curious what “snd-intel-dspcfg.dsp_driver=1” does, but it seems to switch off the sof firmware. The most noticeable effect is that my internal microphone no longer works (found that effect also somewhere). But my external jabra microphone does, so I have a work-around.

I have no time to play around with the kernel modules, unless really required. It seems the developers know and I hope for a quick resolution. Or do we need to create a bug at Opensuse?

Regards (to Sauerland also),