YaST GUI not working in fresh install - XFCE

Hi,

I installed Tumblweed on a laptop this morning and the YaST GUI isn’t working, i.e. I get this error message with all modules:

Failed to execute command "xdg-su -c "/sbin/yast2...

It works in the console.

Here are my repos:

# | Alias                            | Name      | Enabled | GPG Check | Refresh
--+----------------------------------+-----------+---------+-----------+--------
1 | code                             | Visual -> | Yes     | (r ) Yes  | Yes
2 | download.opensuse.org-non-oss    | Main Re-> | Yes     | (r ) Yes  | Yes
3 | download.opensuse.org-oss        | Main Re-> | Yes     | (r ) Yes  | Yes
4 | download.opensuse.org-tumbleweed | Main Up-> | Yes     | (r ) Yes  | Yes
5 | packman                          | packman   | Yes     | (r ) Yes  | Yes
6 | repo-debug                       | openSUS-> | No      | ----      | ----
7 | repo-openh264                    | Open H.-> | Yes     | (r ) Yes  | Yes
8 | repo-source                      | openSUS-> | No      | ----      | ----
9 | skype-stable                     | skype (-> | Yes     | (r ) Yes  | Yes

I have yet to do anything with the computer other than install my usual apps.

Thanks.

You seem to have broken your shortcuts then when it is working in the terminal. Your command looks borked… wrong use of "…
It should be:

/usr/bin/xdg-su -c /sbin/yast2

I reinstalled but kept all of the defaults this time. Same issue without me doing anything at all.

I don’t think “I” broke them because I haven’t done anything on this reinstall yet.

Any idea what I should do (other than go into all of the shortcuts and edit them)?

Edit:

I looked at my main machine and the shortcut xdg-su -c "/sbin/yast2 firewall" for example, works. On the laptop, it doesn’t. All the shortcuts look identical.

I forget to mention that I’m also getting the error message:

Failed to execute child process "xdg-su" (no such file or directory)

Thanks again.

Show the complete content of the desktop file with non-working command line and its full path.

cat /path/to/something.desktop

This issue is not reproducible. Did a quick Virtualbox test install of XFCE only (actual image openSUSE-Tumbleweed-NET-x86_64-Snapshot20240502-Media.iso). No issues at all to start any YaST module via the application starter in the menu…

  • what image was used for installation?
  • checksum of iso checked prior burning/dumping?
  • which tools where used for burning/dumping? Smth like Ventoy?

I just reproduced it by reinstalling again, this time with KDE. Same issue.

The image I used was the current offline one from: Tumbleweed

ISO checksum affirmative.

imagewriter from openSUSE for burning.

Something like this:

zod:~ # cat /usr/share/applications/YaST2/org.opensuse.yast.Firewall.desktop
[Desktop Entry]
X-SuSE-DocTeamID=ycc_org.opensuse.yast.Firewall
Type=Application
Categories=Settings;System;Qt;X-SuSE-YaST;X-SuSE-YaST-Security;

X-KDE-ModuleType=Library
X-KDE-HasReadOnlyMode=true
X-SuSE-YaST-Call=firewall

X-SuSE-YaST-Group=Security
X-SuSE-YaST-Argument=
X-SuSE-YaST-RootOnly=true
X-SuSE-YaST-AutoInst=all
X-SuSE-YaST-Geometry=
X-SuSE-YaST-SortKey=
X-SuSE-YaST-AutoInstClonable=true
X-SuSE-YaST-AutoInstRequires=lan
X-SuSE-YaST-AutoInstSchema=firewall.rnc
X-SuSE-YaST-AutoInstResource=firewall
X-SuSE-YaST-Keywords=security,network

Icon=yast-firewall
Exec=xdg-su -c "/sbin/yast2 firewall"

Name=YaST Firewall
GenericName=Firewall
Comment=Configure a firewall
StartupNotify=true

On KDE it says:


Could not find the program 'xdg-su'

also.

I cannot install xdg-utils. I get this error:

Problem 1: the to be installed xdg-utils.1.2.1-1.1.noarch requires 'which', but this requirement cannot be provided...

Well, if you do not have xdg-utils, you do not have xdg-su.

Show complete command line and its output.

zod:~ # zypper in xdg-utils
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: 1: the to be installed xdg-utils-1.2.1-1.1.noarch requires 'which', but this requirement cannot be provided
not installable providers: which-2.21-5.14.x86_64[download.opensuse.org-oss]

 Solution 1: deinstallation of busybox-which-1.36.1-32.2.noarch
 Solution 2: do not install xdg-utils-1.2.1-1.1.noarch
 Solution 3: break xdg-utils-1.2.1-1.1.noarch by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/3/c/d/?] (c):

Solution 1

Really? Then what? So the installer isn’t working properly then.

And to add - if you can reproduce it with new clean install, open bug report.

It is not installer, but yes, something does not work correctly. Open bug report, provide detailed step by step description of how you installed it.

This seems not to be a bug but caused by individual package selection whilst installation…individual package selection needs more attention from the user.

What package selection? I used the defaults.

As usual you blame user without understanding the real root cause.

This is problem of package selection caused by

  • multiple packages providing the same feature
  • zypper using the first package in alphabetical order
  • busybox-* usually sorts before anything else

To break the tie distribution needs to prefer some other package that provides the same feature (in this case /usr/bin/which). Or - if busybox which is guaranteed to be 100% compatible - all packages must Require the same feature, not explicitly which. Or - if busybox which is not compatible - all packages must explicitly require which instead of /usr/bin/which.

1 Like

Seems not so easy as you believe. A standard XFCE installation without any changes to the package selection (system role: desktop with XFCE) does not show the described behaviour…at least with the NET installer…

Yes it does. A fourth fresh install with GNOME this time confirmed it once and for all for me. No changes to the defaults in XFCE x2 , KDE or GNOME and xdg-utils is not installed. And cannot be installed without resolving the aforementioned error.

Install it on bare metal and you’ll need not bother with the issue any further.

Edit:

Missed that you’re using the NET installer. I’m using the offline installer. I haven’t the time to do a NET install right now.

We still do not know either what image you used nor what settings you changed during installation. It cannot be “default” with three different desktops.