Windows partition appears empty

I installed Suse 11 rc1 today on a new and empty hdd. However I also got a second hdd that got windows vista on it. By default it is mounted to “/windows/c” but this folder appears empty!

Is there a way to fix it?

If /windows/c is empty, I guess the partition is not mounted at all. Open a terminal and execute “mount” as root. Then you’ll see the currently mounted partitions. If your windows partition is not mounted at all, assuming it’s /dev/sdb1, try “mount -t ntfs /dev/sdb1 /windows/c”

Okay Thanks. This worked. I assumed that since installer created the folder and all that it is also mounted. I’m a beginner in linux…

Anyway I can access the folder now but only via console with root privileges. How can I allow access from normal user?

Edit this line into fstab:
/dev/sdb1 /windows/c ntfs-3g defaults 0 0

This assumption is absolutely right. I already wondered a bit why it don’t get automounted.
But thanks to swerdna, the solution is already available as well!


I have the same problem of empty /windows/C and D folders. I had a look at “expert partitioner” in Yast. I can see the 2 Windows partitions. In “mount” column, there are /windows/C* and /windows/D*.
What does the “*” mean?

So I tried “mount -t ntfs /dev/sda3 /windows/D” in the terminal. It returned nothing (don’t know if it’s normal), and then, when I wanted to access the folder /windows/D, a popup window told me I havn’t the right to access.
So for now, it looks like albeva’s problem.

Allright: in my fstab file, there this line:
/dev/disk/by-id/scsi-SATA_Hitachi_HTS5425071024BB0200WBGNBBEC-part3 /windows/D ntfs-3g

I added defaults 0 0 at the end of the line.

Nothing happened, so I rebooted, and the folder is still empty.
Any idea? thanks in advance!

Which version of Suse are you running?

sorry, I’m running openSUSE 11, with gnome.

And the oddest is that the first time I installed openSUSE 11, I could access this partition. :confused:

install ntfs-config
then as root run


Set read/write access to windows partition with this tool and set automount as well.That way u have read/write acess and automount by default

I get this window (the 1st time I ran it, all the boxes were not ticked):

They appear empty, though they aren’t.
And if I double click on sda3 (the partition where my documents are), it gives that:

Mounting /media/DATA failed because of the following error:

$LogFile indicates unclean shutdown (0, 0)
Failed to mount ‘/dev/sda3’: Operation not supported
Mount is denied because NTFS is marked to be in use. Choose one action:

Choice 1: If you have Windows then disconnect the external devices by
clicking on the ‘Safely Remove Hardware’ icon in the Windows
taskbar then shutdown Windows cleanly.

Choice 2: If you don’t have Windows then you can use the ‘force’ option for
your own responsibility. For example type on the command line:

        mount -t ntfs-3g /dev/sda3 /media/DATA -o force

Or add the option to the relevant row in the /etc/fstab file:

        /dev/sda3 /media/DATA ntfs-3g force 0 0

Is the force option safe?

Actually, when write support for internal device is disabled, I can mount the partition and access my files.
But I would like to modify the files.

You can boot the computer into windows and windows will “clean” the drive so it mounts in Suse. Or you can use “force”, which so far as I know is safe – I haven’t seen a report of “force” bombing the file system.

This indicates errors in your ntfs partitions.Log into windwz and perfom an “error check” with both options checked.U should be fine then

with the line

mount -t ntfs-3g /dev/sda3 /windows/D -o force

, I could mount my partition. Otherwise, with ntfs-config, I’m only able to mount it in /media.

Even after a scandisk in MSwindows, I have to force the mounting.

I don’t know the exact reason, since I’ve tried a lot of setting in order to use my data NTFS partition in both OS (windows and openSUSE). But now, I cannot access my files at all, even in Windows! When I open the D: drive, I can see the “Users” folder. In “Users”, instead of my “baobob” folder, there is a file of 0 octets named “baobob”. But according to the properties of the partition, there are still datas in it.

If I delete openSUSE, will I recover access to this partition from windows? And if not, have you an idea of what I can do?

I’ve tried to restore the initial settings into openSUSE, but I may have forgot something :^/
I’ve also performed another scandisk, it didn’t find errors.

Thanks in advance!

I’m thinking it might be a good idea to activate your data backup routine. Can you get a faithful backup from windows? If you can’t do that from windows ATM you can take a backup from Linux, over to, say, another partition, or to a USB drive, or some other media.

Might be good to check the mount for NTFS. What settings are currently in fstab? – do this:

cat /etc/fstab

and you will see the settings in a console. Post them here.

I’ve tried the restoration with windows, it hasn’t changed anything. I’m not surprised, since I hadn’t modified anything in Windows.

I would have love to backup my partition, but I haven’t any media of enought capacity to do so. :frowning:

here it is my fstab:

baobob@linux-ar4k:~> cat /etc/fstab
# /etc/fstab: static file system information.
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

proc	/proc	proc	defaults	0	0
sysfs	/sys	sysfs	noauto	0	0
usbfs	/proc/bus/usb	usbfs	noauto	0	0
devpts	/dev/pts	devpts	mode=0620,gid=5	0	0
/dev/disk/by-id/scsi-SATA_Hitachi_HTS5425071024BB0200WBGNBBEC-part6	/	ext3	acl,user_xattr	1	1
/dev/disk/by-id/scsi-SATA_Hitachi_HTS5425071024BB0200WBGNBBEC-part1	/home	ext3	acl,user_xattr	1	2
/dev/disk/by-id/scsi-SATA_Hitachi_HTS5425071024BB0200WBGNBBEC-part2	/windows/C	ntfs
/dev/disk/by-id/scsi-SATA_Hitachi_HTS5425071024BB0200WBGNBBEC-part3	/windows/D	ntfs
/dev/disk/by-id/scsi-SATA_Hitachi_HTS5425071024BB0200WBGNBBEC-part5	swap	swap	defaults	0	0
debugfs	/sys/kernel/debug	debugfs	noauto	0	0

/dev/disk/by-id/scsi-SATA_Hitachi_HTS5425071024BB0200WBGNBBEC-part2 /windows/C ntfs-3g defaults 0 0
/dev/disk/by-id/scsi-SATA_Hitachi_HTS5425071024BB0200WBGNBBEC-part3 /windows/D ntfs-3g defaults 0 0

Needs a reboot to set it.

IMHO it’s not enough to simply collect and store data. If I don’t backup my data, I know I will surely lose it.

unfortunately, it hasn’t fixed my problem.

I really don’t understand why a setting made in linux has an effect on windows!?