Windows partition appears empty

Did you select as advised by gdelta9:
fix file system errors + recover bad sectors

Following this thread I thought I’d add some thoughts;

One thing that stood out is that you mention using scandisk to check the partition. You might be able to run it, but it’s not the correct tool to run on a NTFS partition (AFAIK).
I suggest you have another run using chkdisk.
Quickest options to get this done are chkdisk’ing from within Windows, while booting XP with the check flag set or using the rescue mode on a XP cd.
It might fix some indexing issues and get some data back. At any extent it should give some more clues of errors on your partition.

Another thing would be in finding out what and when it actually went wrong here. You say you could access the disk the first time when booting into Linux?
What happened after that?

At any rate, if it where me, I would remove the mounting options from fstab and use one of the mentioned Windows methods to try and get access back to the data on the NTFS partitions and make sure it’s all in working order.
Once you’ve done that have another look from within Linux.

Changing the relevant lines in fstab to ;
/dev/disk/by-id/scsi-SATA_Hitachi_HTS5425071024BB0200WBGNBBEC-part2 /windows/C ntfs-3g defaults 0 0
/dev/disk/by-id/scsi-SATA_Hitachi_HTS5425071024BB0200WBGNBBEC-part3 /windows/D ntfs-3g defaults 0 0

should give write access (also for normal users).

I would take care in using the force option. It can lead to data loss if there is some other reason than a dirty shutdown preventing it from mounting.

Hope that helps,

OK, according to some forum, the tool I used is actually chkdsk. I thought it was scandisk. And yes, with fix file system errors + recover bad sectors ! :slight_smile:

I could access my windows partitions both in windows and Linux the first time I installed openSUSE. Then I had some troubles with my multimedia, so I decided to restart from a blanck sheet by reinstalling openSUSE on the linux partitions already created of course.
Since that, I still could access my data D: partition from windows. But not anymore from SUSE. So I asked for help on this thread.
The results were not very satisfying, sometimes, I used to get data partition mounted in /windows (like the 1st time), other times in /media… I had some permission issues, so I tried to modified the rights of access.

Finally, I lose access to D:\Users\baobob\ from both the two OS.

One thing: I’m not sure the full lost occured at this moment, but, when I was somewhat able to access my files, I had tried to change my home directory in the users parameters. I wanted to “merge” my documents from linux with those from windows in the same directory, that is “D:\Users\baobob”. Well, on first reboot, openSUSE has let me know that it doesn’t appreciate that, so I quickly forgave this idea and restored the default settings.
And now, in both the 2 OS, I can browse “users” folder, but the “baobob” folder appears like a 0 octet file.
Perhaps the two events are linked, because they happened in the same range of time.

What do you mean, by removing mounting options? Deleting ntfs-3g defaults 0 0 at each end of line of widows partitions?

By this I mean remove or remark the entires in fstab for the /windows/C and /windows/D so it does not get mounted in Linux at the moment.

Then focus on getting back the data (if possible) using Windows. Start out with chkdisk again and also see if recovery tools can bring back files :
PCI File Recovery & PCinspector Data Recovery

Important is to not copy or move files on your NTFS partitions before you have tried your recovery. Every change you make on the partition reduces the chance of recovery.

Wishing you luck!

remove or remark the entires **lines **in fstab for the /windows/C and /windows/D?

And you have any idea about the possible cause(s) of this? Why is just one folder corrupted? I just would like to understand, in order to not do the same next time!

Suggesting to remove the mount entires (temporary measure) for your NTFS partitions from fstab does not have to do with the cause. I meant this as ’ get your NTFS issue sorted from within a Windows environment and leave Linux access out of this until you have fixed things ’ .

Finding the cause is not that easy and I think the answer lies in retracing your exact actions and maybe even trying to replicate the issue with a test partition.
I’ve been using the ntfs-3g driver starting openSUSE 10.1 & have not had any issues like this or any data loss whatsoever with it.
I suspect something probably went wrong when moving files around?

Yep yep, I fully understand the philosophy, although it seems odd to fix in windows an issue created in linux.
But I do not understand “remove the mount entires from fstab”. My english and my knownledge of IT are not perfect, so sometimes it’s tough to understand.:smiley:

(I’m not with my PC right now, I’ll try this evening ;))

Ok, I’ll spell it out :slight_smile:

If this is you fstab now :

# /etc/fstab: static file system information.
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

proc	/proc	proc	defaults	0	0
sysfs	/sys	sysfs	noauto	0	0
usbfs	/proc/bus/usb	usbfs	noauto	0	0
devpts	/dev/pts	devpts	mode=0620,gid=5	0	0
/dev/disk/by-id/scsi-SATA_Hitachi_HTS5425071024BB0200WBGNBBEC-part6	/	ext3	acl,user_xattr	1	1
/dev/disk/by-id/scsi-SATA_Hitachi_HTS5425071024BB0200WBGNBBEC-part1	/home	ext3	acl,user_xattr	1	2
/dev/disk/by-id/scsi-SATA_Hitachi_HTS5425071024BB0200WBGNBBEC-part2	/windows/C	ntfs
/dev/disk/by-id/scsi-SATA_Hitachi_HTS5425071024BB0200WBGNBBEC-part3	/windows/D	ntfs
/dev/disk/by-id/scsi-SATA_Hitachi_HTS5425071024BB0200WBGNBBEC-part5	swap	swap	defaults	0	0
debugfs	/sys/kernel/debug	debugfs	noauto	0	0

change it to this (you will need root rights for this):

# /etc/fstab: static file system information.
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

proc	/proc	proc	defaults	0	0
sysfs	/sys	sysfs	noauto	0	0
usbfs	/proc/bus/usb	usbfs	noauto	0	0
devpts	/dev/pts	devpts	mode=0620,gid=5	0	0
/dev/disk/by-id/scsi-SATA_Hitachi_HTS5425071024BB0200WBGNBBEC-part6	/	ext3	acl,user_xattr	1	1
/dev/disk/by-id/scsi-SATA_Hitachi_HTS5425071024BB0200WBGNBBEC-part1	/home	ext3	acl,user_xattr	1	2
#-remarkedfornow-/dev/disk/by-id/scsi-SATA_Hitachi_HTS5425071024BB0200WBGNBBEC-part2	/windows/C	ntfs
#-remarkedfornow/dev/disk/by-id/scsi-SATA_Hitachi_HTS5425071024BB0200WBGNBBEC-part3	/windows/D	ntfs
/dev/disk/by-id/scsi-SATA_Hitachi_HTS5425071024BB0200WBGNBBEC-part5	swap	swap	defaults	0	0
debugfs	/sys/kernel/debug	debugfs	noauto	0	0

Now when you boot to Linux (to work in it or test and play…) the NTFS partitions won’t be touched…
You can boot into Windows and try fixing recovering… when you’ve done that you can get back to trying to get it mounted in Linux.
Do note the differences in you current fstab and the mount entries I mentioned in post #22.
If you need to fix or recover from a NTFS partition use Windows to do so… seeing NTFS is a Windows format. NTFS is not native to other OS’es, so you have a better chance getting your data back looking and repairing from a Windows system. Linux does have basic tools for NTFS… but not more than that. That is the reasoning behind my remark.


OK, thanks, perfectly clear now

I remember to had added -3g defaults 0 0. I don’t know why it’s removed know…
Anyway, the main problem is to access my datas in windows (for now, it’s my main OS, I’m afraid

OK, PCI File Recovery is not compatible with vista So I used another one: recuva. I told it to look into D:\users\ but it didn’t find anything. But those software seem to recover deleted files. My files are not deleted: I can see on the pie in D: properties that it is still almost full.
The problem is that the folder D:\users\baobob\ doesn’t exist anymore. In place of the “baobob” folder, there is a baobob file, without extention.
And, before to remark the 2 lines in fstab, I could see in linux exactly the same file in place of my folder.

I’m thinking about the fact that only “baobob” folder is corupted, and not all the partition. That makes me think that my problem comes from my bad idea of set my linux “home” directory to the windows user directory.

Hmmm… you might get lucky if you use a tool (some type of disk/HEX editor) to change the type back from a file to a folder. Maybe other tools are a better solution.
I’ve played with this many years ago, but this is something to do with care & I can’t give any good directions here…

I’m thinking about the fact that only “baobob” folder is corupted, and not all the partition. That makes me think that my problem comes from my bad idea of set my linux “home” directory to the windows user directory.

Could be something went wrong creating some a symbolic link or in a double mount… Haven’t run into an issue like this so it’s guessing… But it does sound like the cause could be somewhere in that action.
Although not recommended, and some issues will arise, you can use an NTFS partition as home folder. So it’s not such a strange idea to have :wink:
If you would want to try this again at a later point I would suggest to only share portions of you home directory by using symbolic links for specific files and/or directories (useful to redirect your mail folders, firefox bookmars.html for example).

Hope you find the right angle to get your user data visible!

Wishing you luck,


I finally managed to recover my files.

I asked for help in a french forum, one of the guy there suggested to use this soft : DMDE. I downloaded it, tried to use it but I understood anything, so I emailed the editor of the software. After 18 emails, we found my files in a folder, called “found.000”, created by the utility that check drives in windows. This folder was not visible in Windows though, so then I came back in openSUSE and moved my files in the right place.

I can sleep now :^)

Thank you a lot for you help!


Hi Bob,

Glad you’ve been able to retrieve the data. Must be a relief!
Also thanks for posting your solution & the tool you’ve used… I’ll be storing it amongst my recovery tools. :slight_smile:


Thanks a ton guys!!! I was able to fix my problem however I am having to input the line: mount -t ntfs-3g /dev/sda2 /windowsC
into konsole every time that I login to access my windows files. How can I make this permanent? I thought that would do it but I have missed something! Thanks!!

There are two ways to do this:

  1. Open YaST > Partitioner and set the mount point for /dev/sda2 to /windowsC. Do this by editing the /dev/sda2 entry and set the mount point at the bottom left (be careful not to select format!) and apply.

  2. With root rights open /etc/fstab and place the entry for /dev/sda2 in there. At the next boot it should be automatically mounted. See post #18 & #22 for some more info.
    Your added line should look something like this:

/dev/sda2 /windowsC ntfs-3g defaults 0 0

Instead of /dev/sda2 you could also use the disk by ID.

If you are having problems writing to the NTFS partition as normal user check /etc/fstab and replace any set mount options with the ‘ntfs-3g defaults 0 0’ bit.

Thanks a bunch!!! I have done what you suggested and it worked like a champ!! Thanks!