VLC Codecs "mpga"


Ive recently started using linux again, and I have come across another problem. The vlc for some reason does not play mgpa files. I have the media codecs (all of them) downloaded and installed, however, it still does not work. Ive spent hours on trying to solve this problem…
In this case, I have no idea what I should say (for information) besides the name of the laptop: Lenovo Yoga 2.

Best Regards;

Did you get all including the vlc program from packman?

Hi gogalthorp,

Yes I have packman installed as well.


It could be that you did it allright, but you can not “install packman”. You can add the Packman repository. After that you can install packages from it. And to be sure that your multimedia and thus VLC functions. you must check that everything that you have installed and that is available on both the standard OSS repo and on Packman you have the Packman version.

Best is to start YaST > Software > Sofftware Management. Then from the View menu click Repositories. Then in the list click Packman. Then at right, above the list of packages there is a line saying: Switch system packages to the … Click on it and go for installation. When there are any packages installing now, your switch to Packman was not complete. But now it is. Please try playing your file again.

I have VLC iinstalled apparently with everything from Packman but VLC complains of a missing codec which does not appear to be in Packman. However, mplayer has a codec that will play them; so I use that instead.

And what kind of file would that be?

If you install “vlc-codecs” (which is in Packman), you should be able to play all restricted formats, including mpga (MPG Audio).

Maybe “apparently” to you, but not to us.
What did you do with the action I advised?


hcvv I have tried as you said. I also have tried looking for packman in the software repositories, and I have downloaded and installed them again. I`ve done the instructions exactly as you said, but for some reason I have the same problem, with the mpga format.

Codec not supported:
VLC could not decode the format "mpga" (MPEG Audio layer 1/2)

That problem comes up every time I try to use VLC.

Thank you for your help,

That is fine. But I had to ask, because you did not tell us that earlier. And because we can not know what you do, all must be told with some detail so that we know for sure what happened.

When they are installed, re-installing from the same repository does not change anything. :wink:

And did you install the package “vlc-codecs”?

This will not be installed automatically if you do a full switch to Packman.

You should check


Yes, that is the first thing I have done when I had this problem. When I first seen the problem I have checked for updates (cannot install them because of a problem: “Failed to initialize packaging backend. This may occur if other packaging tools are being used simultaneously”.
Then I had checked for the vlc codecs at this website: http://opensuse-guide.org/codecs.php
Then I installed the packman repository (which you guys told me to).

That is the order which I had done it in.

So now I tried to install the vlc codecs from the website which I mentioned before. But it still does not work.

Now I have checked caf4926`s offer, using the website: https://forums.opensuse.org/entry.php/160-openSUSE-13-2-Multimedia-Guide

And it has fixed the problem. The mpga error no longer comes up. BUT, the video itself is not playing, only the sound (I`ve tried both mp3 and mp4 videos…).

Best Regards;

Uninstall libvdpau_va_gl1 and vdpau-video if they are installed.


wolfie, the 2 repostitories you told me to delete, had fixed the problem! Now the vlc can play videos (both mp3 and mp4) without any problems :).

Thanks in advance,

Best Regards;