Update from 42.2 to 42.3 failed, Grub error

I changed in yast all repositories (42.2 to 42.3 ) , and disabled the extra ones.

Then did

zypper ref


zypper dup

When it was done, I rebooted and I got the following error:

Error: symbol grub_tmp_measure not found

Entering rescue mode.

Thank god my mobo has an boot option menu. I am typing this post with an old 42.1 install of opensuse.

Pc has three harddisk., two 500 gig and a terrabyte one

Booting form one of the 500 gig ones lead to above error.
Booting from the other 500 gig one, gives me the option to boot Leap 42.1 or win 7, this is normal.

I can’t reach leap 42.2(42.3 ) the normal way, the one were the update went wrong, which is on the 1 terrabyte disk.
From leap 42.1, I do have acces to the file system of the failed update.

There is a separate thread on this:

Thread: error: symbol “grub_tmp_measure” not found

Thank you.

Now I need to find out what files should be located were.

I also downloaded the 43.3 iso, for plan B. :stuck_out_tongue:

Problem solved, but I am totally lost on how I fixed it.

Yesterday made an install usb.

Today wanted to try the usb, so started pc with the usb stick in an usb slot, I think the usb does not work, but I was greeted with a grubscreen.

I did not get a desktop, but logged in through the comandline.

Then did again zypper ref and zypper dup.

The message I got was:
Nothing to do.

I then enabled the nvidia repository again, took the usb stick out, and rebooted.

Totally confused, but I am typing this with leap 42.3, with desktop.