Trying to set static IP opensuse 42.1

Good Day,

I’m kinda stuck following several guides on setting-up a static IP on my Vbox, i tried several guides but to no avail it doesn’t solve my problem.
I followed guides where in i have inputted IPv4 / default gateway etc and stuff but i still get eth0 device-not-running problem and still can’t do a test ping. Anyone had the same problem too?

Thanks in Advance

Your mentioning of VBox is relevant here. Is openSUSE running as a guest? You have a choice to make as to how you configure the network adapater. FWIW, I prefer to use bridge mode (configured via VBox… Settings > Network) so that my guest appears as just another host on my LAN. Your situation might be different. You need to understand the choices before you can proceed with configuring your guest

For configuring the network settings manually, the openSUSE guide is relevant here…

Yup, I already did yast > yast lan configuration also adding manual configuration on /etc/udev/rules.d/70-persistent-net.rules upon seeing some guides and applied it but still to no avail eth0 doesn’t work and still at eth0 device-not-running whenever i ifconfig, also… i tried ifup eth0 but it doesn’t give me result ctrl+C also gives the same problem device-not-running but i can ping my static IP back. not sure if it runs as guest, but i use the root to log-in.

I’m going to take apart your reply…

not sure if it runs as guest,

You mentioned VBox. Are we referring to a guest OS running in VBox? Or the host?

but i use the root to log-in.

Don’t do that! Bad practice, and not necessary.

There should have been no need to create any udev rules for your network device. Please run the following command

/sbin/ifconfig -a

and report back with the ethernet device node reported.

Apologies for my dull answer good sire,

I walk 2-3 yards away to get my things done, since i cannot research on stuff to get through my issue since i can’t get myself connected through the internet due to my problem.
I am following a set-up guide on installing this stuff, but it seems the problem is beyond the installation guide i’m reading, so i will manually write down the ethernet device node to get my problem solve and type it back in here
give me a couple. and it is a guest OS.


Always provide complete details.
So, for instance if you’re following a guide, then post a link to that guide or describe where it can be found.

For starters,
That udev rule you wrote should be removed.
Don’t even want to know what is in it, I’m sure it’s irrelevant at best and harmful at worst.
The reason why is because when you install a Virtualbox Guest, your install will automatically create a <virtualbox virtual network adapter> by default which is not dependent on any kind of hardware recognition (which udev might do for you). The virtual network network adapter will exist, and be the same on all systems regardless of the hardware… That’s one of the beneficial features of virtualization, you don’t have to worry so much about working hardware… The general principle is that if the hardware works for the HostOS, then it will work for the Guests.

You should also get used to good practices, particularly a Standard Operating Procedure when troubleshooting your networking.
Such as…

ip addr - not ifconfig which is being deprecated. And ip addr displays some things ifconfig doesn’t.
ip route - displays your default gateway and any other routing.
cat /etc/resolv.conf - For hostname resolution using DNS
ping - verify network connectivity between hosts
telnet - probe network connectivity to specific services on remote hosts

You should take care how and what you write in your post.
A run-on streaming statement isn’t going to be well understood by people willing to help you.
You should be as detailed as possible <providing specifics> like your actual “ip addr” result so people don’t have to guess.


Good Day,

Here is what i’ve got from /sbin/ifconfig -a

eth0  Link encap:Ethernet HWaddr 84:2b:2b:8D:A7:43
                   inet addr: Bcast mask
                   UP Broadcast Running Multicast MTU: 1500 Metric: 1
                   RX Packet:16 Errors:0 Dropped:16 Overruns:0 Frame:0
                   TX Packet:4 Errors:1 Dropped:0 Overruns:0 Carriers:0
                   Collsion:0 txqueuelen: 1000
                   RX bytes 1664(1.6kb) Tx bytes:256 (256.0b)
lo     Link Encap: local loopback
                  inet addr: mask:
                  UP loopback Running MTU:65536  Metric:1
                  RX Packet:0 Errors:0 Dropped:0 Overruns:0 Frame:0
                  TX Packet:0 Errors:0 Dropped:0 Overruns:0 Carriers:0
                  Collsion:0 txqueuelen: 0

please pardon me if i have wrote wrong codes i have to write it manually and type it back apologies

heres the result of my ip addr

lo<loopback,UP,Lower,UP> mtu: 65536 qdisc noqueue State UNKNOWN group default
                link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
                inet scote host lo
                Valit_lft Forever preferred_lft Forever

           eth0   <BROADCAST,MULTICAST,UP,LOWER,UP> mut:1500 qdisc mq state UP group default qlen: 1000
                    link letter 84:2b:2b:8d:a7:43 brd: ff:ff:ff:ff:ff:ff
                    inet scope global rth0
                    valid_lft forever preferred_lft forever

Why do you insist on running ifconfig?
It’s not providing all the info that’s necessary, but the info that is provided looks OK.

[EDIT] I see you posted the ip addr after I posted this response. Note the difference, how the netmask is provided.
Proceed as I describe below.

Missing are…
netmask, default gateway info, and optionally name resolution.

Compare your Guest address to your HostOS, if you configured your NetworkID the same and have a unique Host IP address, you should be able to at least ping other machines on the network by IP address.

If you can’t ping, then I’d suggest you verify that your virtualbox Guest networking properties is property set to bridging mode.

If this is all new to you,
I recommend to all new Users to set up their machines with DHCP and NAT first just to get their machines working because all virtualization technologies make it drop-dead easy to setup with a NAT DHCP server. After the machine is verified working, the machine can easily be re-configured with a static address connecting to the physical network using a bridging mode connection.


apologies good sire,

the other response was for the guy who asked for /sbin/ifconfig -a

Good Day Sir Tsu2,

I’ve tried running ip addr but still wasn’t able to locate
netmask, default gateway was, and for the optionally name resolution also with no luck.
I may have confused quite a lot using the term vbox, its actually a vicibox i am trying to configure. and also trying to ping another PC i only have 1 lan port on my router which is ported to the PC i am trying to configure alone. tell me if i can make things less vague for you, i’ll run some commands and forward output.


Thx for the explanation.

But, unless working on an ancient kernel(kernel > 4 years old?), or dependent apps that still invoke ifconfig (yes, they’re still around and unmaintained may never update), I don’t know if there is a good reason to use ifconfig.


That was specifically to get the name of the network device node and configured IP address. You could also do

ip address

That is a public IP address. Is your machine is directly connected to the internet? I assume you’re connecting via a DSL service of some sort, but you appear to have no router/firewall between your service provider and the machine your connecting with.

Thanks for the clarification about “vbox”
So, Vicibox is a “call suite” application and can run on LEAP 42.3

This now means that although not as certain, it’s still <very> likely that you should still remove that udev rule.

Don’t know why you specified running on openSUSE “other” but you will need to specify what version of openSUSE you’re running on, then people can provide relevant help.


Yes sir, i am connecting directly from a modem that is provided by my ISP, will it be possible to enable eth0 if i plug and configure a router between connection? Yes sir DSL/Fibr optics and it was a static IP line i have here

Good Day,

I am using 42.1 openSUSE. i tried to drag the prefix down but sadly only 42.2 / 42.3

Well, that’s what would be normal practice. There should definitely be a firewall in between the internet connection and any client machine(s).

Just wanted to ask if its possible not to have a firewall? and having a router between would fix the issue of my eth0?

No, a firewall is an essential part of security. At the very easy a router with NAT and firewalling implemented.