totem-gstreamer and totem-plugin woes

I’m weird I guess, but I prefer the totem-plugin to the mplayer one. I just seem to get less buggy results when playing back all sorts of different files on firefox with the totem setup.

On OpenSUSE, this used to necessitate the installation of the totem stuff from packman because he provided totem-xine rather than the default OpenSUSE totem-gstreamer packages. From 11.0 on, this xine version was apparently in a Gnome stable repo on the Build Service rather than in Packman. Whatever, I’ve been on Debian so I just observed this and took note.

I don’t think this process should be necessary anymore with either the fluendo megapackage of gstreamer codecs I have or instead installing the gstreamer packages from Packman.

But Totem from the oss repo does not take note of the installed and registered (checked with gst-inspect | grep flu for the fluendo stuff at least) plugins. I had installed the libstdc33 stuff to get the fluendo stuff to register.

The files do not play either downloaded and played through Totem or played through the plugin. The plugin does nothing but grey box, and Totem offers the website asking me to either go to Fluendo or to access the community repos (with the packman one-click codec things).

After removing the fluendo stuff and just keeping their mp3 (switched over to the packman version) and installing the traditional way with gstreamer0.10 good, bad, ugly, extras, etc, the libffmpeg0, the mplayer and w32codecs, etc, the totem-plugin still is a gray box. Totem itself would then open wmv files, but quicktime did not work. The plugin does nothing. I upgraded all the packages on the system with the packman versions, which brought in their libxine1, etc, etc.

Having no satisfactory results with totem, I installed mplayer-mozilla and uninstalled the totem-plugin package. I did the task of deleting the ~/.mozilla/firefox/pluginreg.dat, and proceeded to test the mplayer-plugin.

It works as well as it ever has, with the occasional crashing and not being able to access some files. Stuff that the totem-gstreamer plugin setup does not suffer from (based on my Debian experience anyway). It still couldn’t play QuickTime stuff. Unlike the totem plugin the “click here to play” appeared, but when I did so it crashed firefox. So I installed libquicktime0 from packman, replacing the opensuse libquicktime package. I usually didn’t need to do this since just an all in this list upgrade used to bring in all the packman replacements, but for at least the libquicktime I guess there’s a file name difference. Then again, since it’s the mplayer plugin using the w32 codecs this installation shouldn’t matter. Still no quicktime mov file playback.

So there’s 2 problems. Totem as packaged by OpenSUSE is not a full totem-gstreamer. Apparently it is crippled enough not to be able to use gstreamer plugins even after they have been installed.

And second, what’s with QuickTime files? I didn’t try them with Kaffeine but at least with both Totem and mplayer they are unplayable. Perhaps the libxine1 stuff would have played them through Kaffeine.

This was on KDE 3.5.10 and Gnome OpenSUSE 11.1 RC1 installed on VirtualBox.

On a side note, hopefully the k3b-codecs package will get into Packman as well. I have the libmad stuff installed but K3B doesn’t recognize it without that extra package. I attempted to have YaST install the older downloaded version but it claimed not to have access to the k3b-codecs package. Shouldn’t be mixing packages from the older distribution anyway so I’m not surprised it didn’t install.

Hmm, well this newfangled gecko-media-player plugin thingy looks promising. I removed the totem plugin and installed this (also installs gnome-mplayer).

All the files work with this. It didn’t resize the image when I went full screen like totem does, but at least it’s playing the stuff. QuickTime too. The mplayer-plugin only crashed Firefox on QuickTime so this is better.

I’ve installed RealPlayer 11. The thing doesn’t make a KMenu shortcut but opens with realplay. I installed it into /usr/local instead of where it wanted to. I’ve done what I used to do with mplayer and totem. Meaning I rename the gecko plugin rm stuff to This way RealPlayer plays all the real stuff.

Still, Totem’s plugin is completely broken and useless from what I’ve seen. Works perfectly on other distros so I don’t know what’s going on with it here.

Multi-media and Restricted Format Installation Guide - openSUSE Forums

Check your multimedia problem in ten steps - openSUSE Forums

May be some help here

Thanks for that! Been doing this stuff since 10.2 days and have read and checked those posts for stuff I might need. I’ve got it all as far as matching up with the suggested software. Don’t think I’ve missed much excepting the K3B codec package which we don’t have yet for 11.1.

I think it’s working as well as possible. After getting the stuff working in Firefox (not with Totem, but with that new gecko-media-player), I checked out how Kaffeine is working with Konqueror.

Well, some stuff works and others crash, whereas on Debian Kaffeine really doesn’t crash Konqueror hardly ever and nearly everything plays. Perhaps it’s some PulseAudio related thing since I don’t have that installed on Debian.

I browse mostly in Firefox anyway and see that gecko-media-player is nearly as good (but not quite) as the totem plugin experience (on distros where it works).

I had gone ahead and upgraded all in the packman repo unconditionally in YaST (mainly because the update to newer if available leaves a bunch of crippled newer OpenSUSE OSS versions on the system) but that had no effect while I was trying to get totem to handle the browser stuff, so I’m quite sure it’s just fully crippled on OpenSUSE. It just is setup not to hook into any gstreamer plugins that may be patented in the USA. Makes it a useless program in my view. And Totem-gstreamer is being heavily developed and is probably one of the best Linux video players available.

Totem won’t use ffmpeg, the w32codecs, the fluendo full codecs, the gstreamer bad, ugly, ffmpeg codecs, none of it. This is just a SUSE thing for sure. Mandriva (same Totem version) and Debian (slightly older) both package a totem-gstreamer that will play anything that the system has the gstreamer codecs installed to play. Not so here. Broken by design.

Since the gecko thing mostly satisfies it’s sort of okay.

But my point is that we shouldn’t even need Packman stuff if we have a purchased pack of those Fluendo codecs. I’m forced to switch stuff to xine based or dependent upon mplayer based when it really shouldn’t be necessary.

Not that I would stick to Fluendo. They’re buggy and incomplete plugins in comparison to the full xine, mplayer, gstreamer, ffmpeg, w32codec combination of things. But the player (totem) itself being crippled is really a step taken too far in my view.

Well I use kde only. Never Totem player and only Packman vers. With xine, ffmpeg, libffmpeg0 etc…
Never any probs really.

Yeah, understood. That’s how I’ve always run OpenSUSE too. Mostly using KDE and going with the program as far as xine framework, Packman versions, etc.

I recall similar frustration briefly while attempting to use the Fluendo stuff when I first bought the pack. On SUSE it was pointless, and on Debian, though it worked, it wasn’t as fully featured as the ffmpeg, w32codec stuff.

But the gstreamer with totem (or anything else) isn’t broken over there like OpenSUSE breaks it seemingly on purpose. The way I got the totem web stuff to work on SUSE was using the totem-xine packman versions which I guess aren’t available yet for 11.1.

It’s not necessary to get that totem-xine anymore since the gecko-media-player plugin (which hooks into gnome-mplayer better, from what I’ve seen, than the mplayer plugin hooks into mplayer itself) looks pretty good!

Sure is a non-standard setup though. Totem’s supposed to be the official Gnome media player and Gstreamer is being hyped up as the future of Linux multimedia. But OpenSUSE is still crippling both. Kind of going against the grain, eh?

It’s depressing to hear that 11.1 doesn’t have this working.
I was about to break down and buy fluendo to tide me over until 11.1 . Now I think that just won’t do. I require mms and find the strategy of merging these deficiencies a disservice.

Can’t mms be streamed through mplayer? Kaffeine (since we get full Packman coverage for the libxine1 stuff) in KDE I believe can do it, and I could have sworn I once saw a forum post on how to setup mms streaming through mplayer.

Installing Packman’s gecko-media-player plugin (bringing in gnome-mplayer), libffmpeg0, w32codecs, may just be all you need to get it working right through Firefox without copying and pasting the link (which is how I think the suggesting was regarding mplayer).

I do find it a bit crazy to include that codec interceptor that links to a website suggesting to either click a link to Fluendo or to the opensuse-community website if the purchase of Fluendo stuff does not work once installed.

Folks are sort of forced to use the patent ignoring Packman stuff rather than making a purchase that’ll be actually patent law abiding in the US. Thank goodness for maintainers of repos like Packman, RPMFusion, Medibuntu, and the ffmpeg and mplayer folks too.

I mean, I’d like for the option of full compliance to work but even at best it is only partially adequate. On SUSE it is hampered additionally by the default players crippled so they won’t hook into these certain codecs at all. That’s the reason Packman repackages the players, but they’ve been passing on totem-xine since 11.0 I think.

Gnome is pushing gstreamer and even KDE4 by default now hooks into gstreamer, which is fine if the codecs will actually be used by the players. Ours only work with free and non-patent encumbered codecs. Even Fedora doesn’t cripple the players this way. Install the codecs, from either Fluendo or RPMFusion, and boom, the players use them.

They have their reasons, but it’s really against the tide.

The Fluendo mp3 playback works fine with Banshee. No idea why the rest of the Fluendo stuff and/or the Packman gstreamer, libffmpeg0 stuff doesn’t work with Totem or the totem-plugin. They do on Mandriva and Debian. I’m not using the Fluendo on Debian because I want full support for all those crazy codecs, but when I tested them they worked.

To make matters worse I’m using a powerpc and I haven’t had much luck finding/getting packages that work.

i’m doing fedora 9, both 32 and 64 bit. i have yet to see totem perform, except for the audio part of a movie. sad to see same results here.