Suse 11.3: No KDE/X11 start on ATI Radeon RV280 5960

I have problems getting Suse 11.3 (32 Bit) running on my old computer.
On startup the screen turns black and the monitor goes to suspend, that’s it - no KDE.
Suse 11.2 is running fine on the system. (but see below)

Details of the system:
graphics card: ATI Radeon 9200, listed by Suse 11.2 as “RV 280 5960”
Monitor: Iiyama Vision Master 450 (CRT !)
OS: Suse 11.3 32 Bit installed from downloaded DVD (md5 sum checked) on a freshly formatted partition (no update)
(Suse 11.2 is still present (on another partition) and working)

Details of problem:
On installing the problem appeared after the (asked for) reboot of the system.
The reboot starts (/etc/init.d scripts seem to start executing), but then very early the monitor turns black and goes to suspend or standby. There were still HD accesses, probably due to install system running.
I tried to switch to a console (using Alt-F1…F10 and Ctrl-Alt-F1…F10) but there was no reaction at all. Also Ctrl-Alt-Del didn’t show any reaction.

I tried the complete install a second time, this time just with minimal changes to the suggested configuration: same effect. This time I let the computer run for a loooong time, in hope that the install system finishes whatever it has started. I then “rebooted” by power off/on.
(There was no reaction to trying to switch to console or Ctrl-Alt-Del)

On the next start I added “nomodeset” to the kernel options. With this X11/KDE still didn’t start, but I got to a console. (Monitor didn’t go to suspend)
There I tried to start ‘sax2’ in hope of being able to configure X11 by hand - but I couldn’t find it. (Not even in the sax2-tools package) Is it gone ? What is the replacement ?

I searched the net but so far only found:
SDB:Radeon - openSUSE
Which is for 11.2 and talks about sax2 - which I didn’t find.

and in the forum the thread No Graphical Output after Install which doesn’t offer a solution.

I dimly remember somewhat similar problems with 11.2 on that system. There I could start sax2 and get X11/KDE working.

This is my old computer (at my mothers place, to write some letters , show photos …), so

  • I’m only there sometimes - it will take quite a time, until I can come back with feedback on your suggestions - sorry.
  • My internet connection there is limited to a 28.8 KBit/s Modem. So big downloads aren’t possibly. (I can download on my main machine and carry them on stick)

I already rsynced the relevant (32 bit Intel) part of the Suse 11.3 patch repository and brought it by DVD. But I failed to apply the patches from yast at the console. How is this done in yast2 in curses-mode ?

Any ideas how to proceed ?

Regards and TIA


I have 32-bit openSUSE-11.3 w/KDE running on an old pc with a Radeon 9200 PRO. There were no problems with the install nor subsequent boots using the radeon driver.

Did you test first with a liveCD before the boot ? What are the hardware specs of this PC ? How much RAM ? CPU ?

How much age different between the DVD burner (on the PC where the DVD was burned) and the older PC where you are trying to install ? I have found a big age difference can mean the respective DVD drivers are not calibrated sufficiently close for a DVD burned on one to work on an older PC. Please also confirm this DVD is burned to a +R or -R and not an RW. In particular i have found that an OS burned to an RW on a new PC won’t work well on an old PC (and visa versa). Also confirm you burned the DVD at the slowest speed your burner will allow (that also is important when there are large age differences).

Reference sax2, its no longer included with openSUSE-11.3. There is a guide here: SDB:Configuring graphics cards - openSUSE

I am sorry, but the SuSE development team REALLY REALLY dropped the ball here.

How can I configure x? There appears to be no tool at all to do this.

I have a Wacom tablet that I always had to use SAX to configure.

Please bring back SAX (or SAX2)

It should be SELF-EVIDENT that when you recommend to go back and get an old xorg.config file, and even admit that the tool in the present edition (11.3) “is less capable” than the 5th option you are giving something IS REALLY REALLY MESSED UP. I have been using SuSE since version 5.3, and the decision to eliminate SAX2 is the most inexplicable, and irrational acts yet. Why was SAX2 eliminated? Is there ever going to be a replacement?

<blockquote>The 5th thing to try is to try to create your own version of the “classic/legacy” xorg.conf custom configuration file for the graphics. This is more precisely known as the /etc/X11/xorg.conf file. In fact this step does in part what the old sax2 configuration wizard used to do for openSUSE (but this is less capable). Some users may even have a copy of their old xorg.conf from a previous Linux install that they might try (although it may not work with openSUSE-11.3). Again, if you have not read the practical theory guide referenced above, PLEASE do so now, else this step will be difficult to understand. </blockquote>

Hi erichbf,

Please start a new thread with a proper title (Need help configuring Wacom tablet), and you will have a better chance getting help. Users who know how to configure a wacom tablet are NOT likely to read a thread with a subject on the ATI Radeon RV280 5960 looking to help a Wacom tablet user.

Good luck.

If I’m not mistaken, sax has been remouved as there was many issue with the tool and there was no one that want to maintain it, so they deside to not provide it with opensuse 11.3 over providing a buggy tool.

Well to configure the X server have you try (provide by Xorg):

Xorg -configure


I have the same problem with the black screen. It’s not an X11 error though, because in failsafe mode it works OK for me. Maybe something with the boot parameters…

Did you follow the guidance here:
SDB:Configuring graphics cards - openSUSE

… if it is a boot parameter, you can try them one at a time until you figure out which boot parameter allows the boot to succeed.

“nomodeset” it is. For me.

After specifying nomodeset as a boot code, what video driver is loading?

lsmod lists nouveau. I thought I was going to need nvidia for 3D support but according to glxgears it is actually working… :slight_smile:

No, I didn’t deem this necessary, because 11.2 is running fine. So 11.3 should just get better :wink:
I will check this.

Athlon 2400 XP CPU with 1.5 GByte of RAM, bought 2003 - what other info is needed ?

The age difference is hard to tell, because I swapped the burner on the old PC some time ago. (no pure reader available, I use the burner for reading)
I didn’t use the slowest speed for writing, but 8* for the 16 * DVD+R used. (Verbatim)
I checked the MD5 checksum form the Web against the one shown by K3B before burning (they matched :slight_smile:
I got no error messages on install, pointing to problems.
(Burned myself with Suse 11.2 on the new computer but using a reeeaally old DVD drive - so I’m warned…)

Note: I use both drives involved regularly for transporting backups (dar) on DVD-RW (yes RW, some reused many times) between the two PCs. I first write the dar to hard disc, create MD5 sums of them on hard disc and write those on the DVD along with the backup itself. On restore I first write everything to harddisc, check the MD5 sums then restore. (and dar has its own checksums.) I had never problems with that, so the drives should do fine.
(And yes there are additional backups on an external hard drive, a USB stick and from time to time on Verbatim Archival Grade + DVDistaster checksums.)

Thanks for the info - I will have a try next time I’m there.



Sorry for the long delay to answer - I relied on the notification email - which somehow failed…

As already mentioned: A new thread will surely help…
But: I have a Wacom Bamboo (marked “Model MTE450-A” on the bottom)
I had this connected (USB) to my “new” computer when installing 11.3 - it just worked afterwards. (Just checked: Even pressure sensitivity in gimp is working without any further setup)


So this is another kettle of fish:

  • I have a ATI card, no NVIDIA
  • “nomodeset” just made it boot to a console login - no chance to get to X11/KDE

I didn’t try “failsafe” - maybe also an idea…



Not getting errors on install is a good indication, but a problem with burning at a high speed is one never knows if that was the problem. One can waste dozens of hours when that is the problem and never know. Hence IMHO its not worth taking the chance. Just burn at low speed when one need to burn.

One MUST always test that. Its a vital piece of information. Please let us know how that works out.

I will try that one. The first install isn’t working anyway and the setup (thanks to the SW images) is real fast.

I just missed this one, because I was so hooked up to the nomodeset-thing mentioned in the release note…

Thanks for all the info and pointers !


As mentioned in the original post, getting back with the result of the checks will take some time. (Probably several weeks)

sax2 was dropped because it could not be maintained, and Novell/SuSE-GmbH back in 11.2 development noted its days were limited. They asked for volunteers to take over its maintenance from the community (making it clear at the start of 11.3 development) that they SuSE-GmbH were dropping it because they did not have the resources to maintain it). No one from the community took over its maintenance. No volunteers to speak of.

Now having typed that, I also do not think sax2 offers any magical solution. Before being discontinued, maintenance of it basically stopped because the resources were not there to maintain it at it worked less and less and less.

Still, at the risk of triple posting on this, it is available in the build service, and my now having seen a number of the users complaining about its demise, I ask myself, have any of those complaining installed the version on the build service, to prove or disprove their views that sax2 would provide the help they think it would ? I don’t think it will work all that great (as I know sax2 in its last support incarnation had problems) but it IS available on the build service for 11.3.

For example:

Again, I do NOT think sax2 will help (but I really do not know) but at least check the build service before saying too much on this …

Just a further note to this thread, bringing it up to date with some investigations I’ve been doing into the ATI Radeon 9200 PRO (RV280).

My wife has openSUSE-11.3 running on a PC fitted with this graphics, but up until today, 3D (special desktop effects, the cube, … etc … ) did not work on openSUSE-11.3 (nor 11.2 before it).

I previously wrote a bug report on this here:

The big report I raised on openSUSE-11.3 was eventually closed with a note that the problem is “upstream” and SuSE-GmbH does not have the resources to solve this. But a couple of excellent links were provided with that closure note xorg-driver-ati Info Page and , as areas to search for the solution.

Clearly both Ubuntu (in their latest release) and Fedora (in their latest release) both of which are ‘older’ than the openSUSE release have applied a setting for this 3D to work on those two distros - hence I was not quite ready to give up yet with openSUSE

I eventually discovered that specifying ‘nomodest’ as a boot code, together with the following edit to the 50-device.conf file provides 3D (but not without some artifacts, such as the occasional full screen pink flash) :

Section "Device"
  Identifier "Default Device"

  Driver "radeon"

  ## Required magic for radeon/radeonhd drivers; output name
  ## (here: "DVI-0") can be figured out via 'xrandr -q'
  #Option "monitor-DVI-0" "Default Monitor"

  #oldcpu added following 2 lines
  Option "BusType" "PCI"
  Option "AGPSize" "64"


Hence I put ‘nomodeset’ in the /boot/grub/menu.lst file in addition to those 50-device.conf edits.

I still do not know what Fedora and Ubuntu applied for this to work on those distros, but at least there is a ‘partial’ ( ?? ) solution for openSUSE. I say partial, as there are still some occasional minor artifacts with the 3D.

I hope that helps a bit on this thread.


in the meantime I tried the “failsafe” boot option.
Unfortunately this also doesn’t give me a starting X11/KDE.

I will test the other suggestions and report the outcome.



I now did another couple of tries. The net result is, that I have KDE running, but only with
So I really would like improvements on that.

Here are the gory details:

At first, I tried to apply all the available patches for 11.2/32 Bit (as of 22. Oct.)
The tricky part was, to get this working, when only a ncurses yast is available.
This is how I did it:
Fetched all the patches using rsync on my well-connected machine.
Packed it using ‘dar’ (now it also has checksums)
Burned this on DVD and carried it to the old PC
Unpacked (using the running 11.2) and then started 11.3 (using failsafe mode to at least get a konsole login)
Started yast2 (ncurses mode)
Started "Configure SW repositories’
Disabled all network repositories (because they will fail later on and make the whole thing fail)
Added the directory containing the patches
Started "“Online-Update” - that applied all the patches.
Rebooted in hope that now KDE might start - got disappointed…

So I tried to do the steps recommended in
SDB:Configuring graphics cards - openSUSE
The numbering here refers to that one. So I only give a short heading on what I did.

1st thing to try (nomodeset)

=> didn’t help (no X11, only console login)
(Ok, already tried that one)

2nd thing to try (failsafe/safe-settings boot)

=> didn’t help (as above)

3rd thing to try (use installation config file)

works (KDE starts) - when used with nomodeset + x11failsafe, but leads to

4th thing to try (edit /etc/X11/xorg.conf.d/ directory)

Failed at that.
I couldn’t find the output name as explained:

output name (here: “DVI-0”) can be figured out via ‘xrandr -q’

Just adding
‘Driver “radeon”’ (which is used on 11.2 on that machine) didn’t change anything as it seems.

I didn’t try the other steps so far.

What I did try in addition is:
Trying to install: (These are the drivers from the AMD page)
Both failed first because of a missing linux-version.h (or somesuch)
(I had installed the kernel sources)
I created a symlink a existing file similar named file. This made the first error disappear on next try.
Unfortunately a second error (missing lib…so) remained.
Didn’t change anything.

What I would like to know is, how I can tell the system to use the ‘radeon’ driver, as is used on 11.2
My understanding is, that the driver is included in (the installed) xorg-x11-driver-video.rpm.

Thanks for the info so far - at least I have a running 11.3 now !


I had this problem with my initial installation of 11.3 when I added a different video card. Whenever I used a DVI connection, it would boot and work for about 10 to 30 seconds and then my screen would blank. Plugged in an old VGA monitor (hopefully, you happen to have one…) and had no problems getting in. Updated the drivers, and then plugged the DVI monitor back in and the problem was resolved.