Speed: Windows vs Opensuse

Hello all :slight_smile:
I’m a newbie new to linux, but I’m must say I like my experience so far. I’ve installed (dualboot with win7) opensuse and first thing that I’ve noticed that compares to win7 it’s a bit slower ar somehow lags a bit more (for example flash player). From what I’ve heard linux should run much smother and faster than windows but from where I’m sitting it’s not the case… I know that you cant call my laptop very powerful but it’s not that bad… I’m using toshiba l300 amd athlon dual core 1.9ghz, 3gb ram ati radeon x1200.
To be short is it my hardware that linux is having a hard time or maybe some configuration might help?

Hello mate

I’ve got a similar configuration to you on my desktop. Dual-boot Win 7 & OpenSuSE 12.1 AMD Athlon FX62 (dual core 2.8GHz) & ATI Radeon 4870. Personally I find OpenSuSE boots faster than Win 7, but in all other respects it’s about the same. Are you using the AMD supplied drivers for your Radeon vid card? Available here: AMD Support & Drivers
It made a huge difference on my system graphics wise.

Welcome to the wacky world of Linux! :slight_smile:

I’ve tried to install, but had problems :wink: Error: ./default_policy.sh does not support version
I hope I will get over this tricky yet interesting OS called linux :smiley:

When comparing multimedia for speed, make sure you have fully updated your system and make sure to follow the multimedia guide we provide here:


If you are running Windows 7 and a good anti-virus program, Windows will automatically be hamstrung compared to Linux because you are not slowing down every read and write memory or disk space operation looking for a virus in openSUSE. Further, with the proper multimedia setup, nothing beats an openSUSE Linux system. Do consider that you are paying real money for Windows while openSUSE is free. While Windows can contain codecs for Multimedia, for which you paid to use, openSUSE requires you go and fetch those Multimedia codecs as they can’t be included for free. So, if you think your Multimedia is up to snuff, check it out here:

MMCHECK - Version 2.45 - Check Your Multimedia in 16 Steps - Bash Script File - Blogs - openSUSE Forums

Make sure you have Totem installed and that you have stuck with the default Gnome if you are a Gnome user. That is, don’t load Gnome 3.6 as it breaks Totem it would appear. Now go to the iTunes web site and play any movies trailer you want, in full screen:

iTunes Movie Trailers

Then, after you have seen it work in openSUSE, and with the very same link, give that a try in Windows and see what you get. You will come to realize that when Linux is properly configured, it is faster than a speeding bullet and Windows is a slow dog. You can trust me on that one.

Thank You for using openSUSE.

That’s a new one on me. The install needs to be run as root i.e
sudo ./(name of install program)

Also good advice and links from jdmcdaniel3.

Good luck :slight_smile:

I still have the problem with video playback in linux… If I play video on linux (not very high resolution) its very laggy, where in windows its fluent… I installed all the things mentioned earlier in here and the only difference that there’s no more vlc player. Any idea why that happened? I even installed it once more…

My weak old laptop can even play hd video running in software mode. So it must not be an issue of performance but a driver bug.

but I can’t find video drivers suitable for opensuse 12.2 and my old lap top… I’ve tried installing drivers from ati page, tried http://forums.opensuse.org/content/115-ati-driver-atiupgrade-new-version.html just hot some errors and process stopped…

What architecture do you run? Are both OSs running 64 bit? You never mentioned that.
If you hadn’t already read, ATI no longer supports the “X” series cards in laptops under Linux. They had a legacy driver, but I"m not sure of it would work for you under a newer kernel. I believe your problems may lie somewhere else anyway. The only times I felt the need for a proprietary driver was for high res games. I have an old X-1650 Pro that I use as a spare at times and I can play 720p movies at full screen with vlc on a 1920 x 1080 monitor. I can do the same on my old single core laptop with an old X700 card and 1680 x 1050 resolution. The driver I have installed is the native Linux radeon driver, not fglrx. If you open Yast update or software management, you can do a search for “radeon” and see if you have the packages installed. If you have been trying to install proprietary drivers, it might not hurt to look for /usr/share/ati If it is there, open a terminal as root in that directory and either run “./amd-uninstall.sh” or “./ati-uninstall.sh” to make sure your system is clean. If it complains about problems with the uninstall, you can add the switch “–force” to the end of the command to force it to uninstall. Even if the install failed, there may be files left over. If neither amd-uninstall or ati-uninstall can be found, then I would go ahead and delete the entire “ati” directory since the uninstaller would delete it anyway. Then in Yast, I would choose “update unconditionally” for the radeon drivers to make sure they are installed correctly. After that is done, run mkinitrd in a terminal as root. It should have already run when you installed radeon, but you are doing it again just to verify that radeon is being set up in the initrd. As it runs, you should see something like “KMS driver=radeon”. If you see “driver=fglrx”, or don’t see any reference to a video driver in the output, then something is wrong. Some people like to disable KMS, but I have never had problems with it.
When you are trying to play flash video, is it from a file or over the internet? If you open “system monitor” or “gkrellm”, what does the cpu and memory usage look like? Is your system being strained? I wouldn’t think so if runs ok in Win 7, but it doesn’t hurt to check. If there is high cpu usage, open a terminal and type “top” to see what is using the most resources.
To verify that you have vlc installed, th easiest way would be to open a terminal and type “vlc”. If vlc opens, then it’s installed. If there are errors, it might give you a clue as to what’s wrong. vlc must be opened as a regular user. It will not open as “su” or “root”. So if you are clicking a video file from a “su” file manager, there is no way to make VLC start.
If you are new and used to Windows, then I assume you are clicking a file from a file manager to open it? Dolphin, Nautilus, Konqueror, and others, are similar to Windows Explorer. You “right click” the file; choose “open with”, and choose your program. There is a checkbox in the dialog of you want the system to remember your choice. Again, you can’t run vlc as root, or open it from a super user file manager.
Other than that, I would play with the vlc settings a bit. If you accidentally mess things up, there is an option to return to the default settings.
I know I gave you a lot of things to check, but it seems to me that your problem is something other than the driver.

G’day! :wink:

A few comments:

  • Your hardware is perfectly fine. (With 3Gb of RAM & that CPU probably best to have installed the 64Bit version of the OS).
  • If you are talking about viewing Flash in web browser then i would strongly advise you to download & install Google Chrome because it contains the latest secure & bugfixed version of Flash BUILT IN to the browser. Chrome Release Channels - The Chromium Projects Choose the 32bit or 64bit RPM.
  • Linux video drivers are under heavy development & always lag the Windows version a little due to vendor non co-operation BUT for your use as described, *should work fine, don’t sweat it.

*I’m guessing you have Intel integrated video chip as many mainstream laptops do.

You made a good choice installing OpenSUSE, there are hundreds of versions of Linux ‘distros’.
OpenSUSE is arguably the best all round.

Have fun!

The only one I can compare is Vista vs Opensuse on my Amilo Li1705 (Intel Pentium Duo Core T2060 1Gb RAM) laptop. Opensuse wins hands down on that one except for the display. I haven’t got round to playing with my new 12.2 install which is currently using openchrome to see if there any improvements but I don’t think that its Via Chrome9 HC is the best thing to have for Linux.


Hi James, I am plying with 12.2 and as usual your help and general guruhood is invaluable. I have installed and updated, and switched to KDE 4.9.3 and all is well. I then followed Caf’s excellent restricted formats tutorial PAckman repo is in in and switched to. I then used you 16 step MMCheck utility script, and all passed and checked out. The to test I went as you suggest, to the iTunes movies site, but!.. This :

Is this a browser problem?


Hi James, I am playing with 12.2 and as usual your help and general guruhood is invaluable. I have installed and updated, and switched to KDE 4.9.3 and all is well. I then followed Caf’s excellent restricted formats tutorial and Packman repo is in in and switched to. I then used your 16 step MMCheck utility script, and all passed and checked out. Then to test I went as you suggest, to the iTunes movies site, but!.. This :

Is this a browser problem?

I just checked with FF and it plays OK, (quality a bit ropey, but I guess that is my graphics card…)

I’d say so. The 8600GT is not exactly a high-end card.


and I have not updated my sig since the 8600GT blew up (OK I exaggerate, but it just stoped working) so I am back to using the 6150SE on-board IGP… So I suppose I should not expect super HD!

It does not look like you have totem loaded. Here is YaST:

And Here is Firefox Addons:


You need to follow this guide: http://forums.opensuse.org/content/127-multimedia-restricted-formats-installation-guide-12-2.html

And you can check out your setup with this: MMCHECK - Version 2.45 - Check Your Multimedia in 16 Steps - Bash Script File - Blogs - openSUSE Forums

Thank You,


Linux is free, free and open to all, as stated jdmcdaniel3, I pass the salvation and I thank him again for his assistance in the past.

Linux a lot can be done with command lines. Windows is flanged to use apps (often paid) to do the same things.

Linux does not attempt to create a monopoly, or to impose anything to users.


Google Traduction

Linux does not behave like a tyrant, a dictator, who seek to make you more dependent on him.


Google Traduction

Linux does not threaten other companies procces for patent infringement in the hope of earning more money. Linux offers its expertise for free for the good of all.


Google Traduction

The Linux Foundation does not seek to build nuclear power plants and pollute the world to sell more PC and make more money.


Google Traduction

Linux allows you to create and offer their creations for the good of all. Linux is open to individuals, scientists and companies.

Linux is a charitable foundation. Linux is open and customizable. It installs easily and rapidness.

All softwares which may be needed are present and easily accecibles in Opensuse. Opensuse to great tools for system administration and distribution of high quality.

That’s why I chose Linux and that I am away more of microsoft and co …

My only regret is that the manufacturers do not provide enough drivers for linux and that they, when they exist, are not sufficiently optimized.

It is unfortunate that the manufacturers do not provide drivers for linux open to the community, it will permit to achieve together a work of high quality. It would be a marriage of love and reason :slight_smile:

Good day to you and excuse my for my bad English…

I have moved your post to Soapbox as it is not a request for help.

Thank You,

Thanks for expressing your being happy with openSUSE :). At least, that’s how I read it, not as a rant as said in the title.