Plasma trashed after upgrade to 4.0.84 packages

since upgrading to the “4.0.84” packages & rebooting, plasma has been been crashing upon login leaving me without a desktop & only a cursor. (i’m using icewm now).

i tried deleting ~/.kde4/share/config/plasmarc & plasma-appletsrc but that didn’t make a difference.

i can’t get a useful traceback either cuz i apparently don’t have the required debug package installed. is there actually a debug package for plasma? i can’t seem to find it.

is anyone else experiencing this problem?

well for me 4.0.84 has been a lot more stable then 4.0.83.[1-3] so far. I do like the new wallpaper too.

plasma doesn’t crash anymore when downloading new widgets although some “old” widgets that worked before now only show a little “tube” on the desktop (like logon/logoff). and newly added widgets do not get added to the widget-list for some reason.

the tray icons have even further degraded in a barely legible mess.

did you try removing ~/.kde and ~/.kde4? I had issues with an upgrade in the past where starting fresh resolved those.


Yes, exactly the same prob. Was running OK on 4.0.83, and I was half liking it.

Have since done a complete KDE4 delete and reinstall but still no luck.

Spare us, first the BSOD, now the GSOD!

Oh well, back to the drawing board.

Can somebody point me to the minimum hardware reqd for KDE4 please? Will in run in vesa mode?

I’m back to 4.0.4
Just tried factory repos for 11 and my plasma crashed too

Im not particularly surprised that some things aren’t working this week. As its the week after the beta release anything they didn’t want to commit would have been done now. Give it a bit to stabilize again is it isn’t working for you and try again.

Updated last night and got the same thing. Just did an update about half hour ago and now plasma starts up fine and everything seems stable. KDE 4.1 with suse theming is nice. no loss of functionality. One complaint though…FIX THE TASKBAR theme style…it’s ugly.

Same here - I updated yesterday, but thankfully didn’t restart X till really late at night. When I did, plasma threw up all over the place, so I just went to sleep. Updated this morning and everything is back to normal.

Yeah I got that same problem here as well. I think I upgraded when not all of the packages have been updated to 4.0.84, which obviously trashed plasma. I was afraid I had to reinstall everything. But thank god Alt-F2 still worked. I was able to get Yast up and running the next morning and install all of the 4.0.84 packages. After I removed my .kde4 folder for good measure, everything started up fine and I am digging it. Knotify doesn’t crash either!

Everything cool again here too. Now where was I…

yeah, update here. after updating kde this morning, things are in working order again.

Not for me though, my plasma crashes.
I have a policykit package I can’t update as it would cause a roll back to 4.0.4

I see the plasma version in Factory is 4.0.4 though!

I managed to update the policykit, it just decided it was OK.

My errors from the plasma crash show loads of errors from:

just upgraded to 4.0.84-2 and you can see that everything is steadily improving.

  • i can add widgets now without crashing plasma
  • messing around with the panel actually works
  • less plasma flickering with gtk apps
  • screensaver works without making a mess of the desktop
  • more stable kwin effects


  • i still cannot turn off the yellow turd
  • cannot move around panel items
  • tray icons are improved and working but do not pick up the plasma theme at all
  • removing/add a panel works but you have no influence where widgets are added on it.


i never had any of the problems you used to have.

but regarding the ones i quoted…

  1. removal of the yellow “turd” was supposedly implemented, but i never could get rid of it using the appropriate instructions either.
  2. i don’t think this has been implemented yet.
  3. this has been an issue for a long time
  4. i don’t think control of this has been implemented either.

so these aren’t “problems”, but they simply haven’t been implemented yet.

sure they are problems. those are features I would expect from any half decent WM. the fact that they are not implemented yet or not yet working or not working anymore or whatever does not change that. Some of the things on the list were set for 4.0 then 4.1 and now are not even in 4.1 since I believe it is feature frozen already meaning KDE4 will not “be ready” for prime time until at least 4.2 end of the year / beginning 2009. This is a rather bold move, I know it is reworked from he ground up and things have to get worse before they get better, but for now they are leaving us with a half finished product.

you never had any of the issues I mentioned. Well you are lucky then. Do you not have a flickering taskbar when running OpenOffice write for instance? for me especially the clock would flicker like crazy. and until 4.0.84 dowloading and installing widgets through he plasma interface itself always gave me horrendous crashes.

I do still like KDE4 though and have it as my main WM currently.


I find that if you switch away from the OpenSuSE Aya Plasma theme, the tray icons take the background of the panel, so no more icons with opaque squares around them.

A workaround would be to re-add the widget after applying the new theme. It won’t give you a white background any more but it will give you a slight visible black square background (say if you’re using default theme) or something similar. Basically, transparency hasn’t seemed to be implemented yet.

nope. i’ve experienced none of these.

The only thing I’m having is a screensaver freeze. I picked slide show. So far the only way to get out of the frozen screensaver is ctrl+alt+backspace. Anyone else have this?

There’s no slightly visible black square for me after I switched to the default theme and rebooted.