oS-11.4: How to make a video DVD?


I think I’ve tried every single program to make a video DVD and nothing worked so far. I haven’t done this since version 11.2 where I used ManDVD to make a DVD image from files and then burn it with K3B.

Now I’ve tried ManDVD - the video is fine, but the sound is absolute *** with AC3, but without AC3 I don’t have sound on a DVD player. I tried ManDVD2, but it hangs. Tried DVDStyler, Kdenlive, DeVeDe, Handbrake - not a single one can make a a proper DVD.

I can encode any video file into anything, no problem - that is, ffmpeg and all work fine. But when it comes to a video DVD playable on a DVD player (I read it has to be an MPEG2 video with AC3 audio), I ran out of options. I also tried to encode a video file into MPEG2/AC3 and then play it on the player - No luck. Is it something to do with version 11.4?

Please suggest what else to use I can try. Thank you.

Oh, and I’ve just found out SMplayer doesn’t play anything (this explains why DeVeDe doesn’t work)). Only VLC and Kaffeine do. I’ve got all the codecs installed.

Have you tried with K3b?

I’ve never had a problem making a video dvd.

But I don’t use an ‘all in one program’.

Rather I use ‘tovid’ to create the DVD compliant mpeg files.

Then I create my own xml files (with a text editor) such that I can use dvdauthor to create the video_ts directory (using the xml file I created).

Then its a simple launch k3b, drag and drop into k3b, and burn. I think I’ve made upwards of over 100 video DVDs with that technique.

On 03/26/2011 05:06 AM, linuxoidoz wrote:
> Hi,
> I think I’ve tried every single program to make a video DVD and nothing
> worked so far. I haven’t done this since version 11.2 where I used
> ManDVD to make a DVD image from files and then burn it with K3B.

I’ve used kdenlive with good success. They have some good tutorials on
their web site on do it. I just took notes as I watched, then went
through the same steps and viola…

Kevin Miller - http://www.alaska.net/~atftb
Juneau, Alaska
In a recent survey, 7 out of 10 hard drives preferred Linux
Registered Linux User No: 307357, http://counter.li.org

I’d try to troubleshoot MPlayer/SMPlayer first. Once it works you’ll probably find ManDVD does too.

Check the stickies (multimedia how-to’s) and posts in the multimidia forum for audio issues - like correct device selection (AC analog/HD/HDMI/etc.), pulseaudio issues, phonon x alsa, etc. Computer audio is a moving target, every new hardware/framework/drivers bring new capabilities and a lot of issues…

stamostolias, yes, I’ve tried K3B - it says it can’t determine video file duration. I tried 10-15 different formats. It burns data DVDs alright. What’s the trick to make a video DVD in K3B?

oldcpu, I’ll try the ‘tovid’. Would K3B take it?

atftb, ManDVD works fine, it’s just that the sound is *** if forced AC3. But without AC3 there’s no sound at all. But Kdenlive simply fails to render to DVD. It can render to a file but then I’ve got the same *** sound as with ManDVD.

I don’t have any sound issues on the computer, everything (except for SMplayer) works fine with all sound with phonon and all. I remember in version 11.3 I had multiple video output options in SMplayer, now I’ve only got ‘xv’. And I’ve got all the codecs installed (as I’ve always done for the past 5 years or so).

Thank you all.

Forgot to mention, I’ve got this error in SMplayer:

"/usr/bin/mplayer -noquiet -nofs -nomouseinput -sub-fuzziness 1 -identify -slave -vo xv -ao alsa -nokeepaspect -framedrop -nodr -double -input nodefault-bindings:conf=/dev/null -stop-xscreensaver -wid 102760865 -monitorpixelaspect 1 -ass -embeddedfonts -ass-line-spacing 0 -ass-font-scale 1 -ass-styles /home/linuxoid/.config/smplayer/styles.ass -fontconfig -font Arial -subfont-autoscale 0 -subfont-osd-scale 20 -subfont-text-scale 20 -subcp ISO-8859-1 -subpos 100 -volume 50 -nocache -osdlevel 0 -vf-add screenshot -slices -channels 2 -af scaletempo,equalizer=0:0:0:0:0:0:0:0:0:0 -softvol -softvol-max 110 /mnt/Desktop/Movies/video.avi

Option ,alsa needs a parameter at line 77"

I jumped 1 minute too soon. I’ve just found this post: Confirmation on HDA intel sound problem for 11.4rc1 64 bits and it turns out it’s a bug in the Mplayer config. This fixed my SMplayer, it plays fine, I’ve got all video and audio output options back:

just edit /etc/mplayer/mplayer.conf, search for the line
and change it to

Now I’ll see if ManDVD and Kdenlive work. Fingers crossed…

That should fix it
We still can’t track down why this is happing to some users, including me.

And I’ve just checked on my Intel netbook, SMplayer plays fine, I didn’t have to change the config file or do anything.

Yes. My main box had the problem but my laptop didn’t.
Identical installs of 11.4 and packman multimedia


I’m currently encoding a video DVD with DeVeDe. It was definitely the Mplayer’s config bug. I’ll see how the sound appears in half an hour.

Does anyone know how to make video DVDs with K3B? What kind of video/audio container/format/codec does it need to work? As I said before, I tried reincoding videos with ffmpeg manually with AVI/MPG/MP4/MPEG-TS containers, DVD/AVI/MPEG-2/Raw MPEG-2/MPEG-4/Raw MPEG-4/MPEG-TS formats and Xvid/MPEG-2/MPEG-4 codecs - none worked with K3B saying it couldn’t determine the video length. Any ideas?

Thank you.

Well, it made the DVD but sound is *** again, no, there is no sound, just cracking.

I use devede all the time it’s fantastic, never had a failure yet.

I suspect now it may be something to do with the AC3 encoder because sound in the DVD player is the only problem, everything else seems fine.

I’ve reinstalled all multimedia stuff again from the openSUSE-Community, made 3 DVDs with DeVeDe, ManDVD and Kdenlive - all make cracking audio. I don’t know why. Any ideas? Do I need to install anything else? Never had these problems in 11.2 or maybe even in 11.3 (definitely made a lot of DVDs in 11.2 but don’t remember if made any in 11.3). Thank you.

In the devede settings, are you using copy for the audio. So that is should use the same as the source file?
And are you saying the source is AC3?

I’ve tried both: forcing AC3 and just copying without reincoding. In the 1st case I get cracking sound, in the second - dead silence.

I was using DVD styler in 11.3, but in 11.4 it crashes when creating menus, there is some ffmpeg message about some wrong parameter. Generally ffmpeg is now in somehow bad condition. When I try to just copy video with ‘ffmpeg -acodec copy -vcodec copy -i video1.mpg video2.mpg’ and sound is in ac2, then the resulting video is without sound. I hope this will be fixed soon. Life without ffmpeg and DVD Styler is much harder. :slight_smile:

Well, I’ve tried making a DVD again in 3 programs and the result is the same - it’s crackling noise with AC3 forced on both the DVD player and computer and there’s no sound at all without AC3 on a DVD player, however the sound is fine on the computer. What else cold I try?

Oh, and I’ve just reincoded a few videos with ffmpeg forcing AC3 audio codec and the sound is fine. So it’s not ffmpeg/AC3 after all I guess. Are all those DVD programs using something else?