oS-11.4: How to make a video DVD?

Anyone tried burning a video DVD with AC3 in openSUSE 11.4?

It’s been a long time since I encoded anything, so I’m not sure about this, but I’d start looking at what is the audio decoder that the apps use. It probably is broken somehow and sending garbage/noise/silence to the encoder.

Sometimes you can change the decoder in the app preferences, otherwise track it down and reinstall/upgrade. As there seem to be no other people with this problem it may be a conflict/config issue (perhaps an old config file from a previous version?).

I’ll see if I can find anything in the settings.

I’d start looking at what is the audio decoder

Decoder? I thought it would be an Encoder. I can play any original video/audio file in any format and any file re-encoded with ffmpeg on my computer with any player (Kaffeine, VLC, MPlayer, SMplayer, Amarok). Only video DVDs made with all those DVD making programs have corrupted sound. So it must be an Encoder in ALL those programs… unless they all use the same don’t-know-what-thing, don’t think it’s ffmpeg as it works just fine even with AC3.

But why can’t K3B determine duration of any video file? It would have been so much easier if I re-encode with ffmpeg and then burn with K3B.

perhaps an old config file from a previous version?

No, I’ve got a fresh install.

Again, has anyone tried burning a video DVD with AC3 in openSUSE 11.4 yet?

I have just had this exact problem with devede, the solution turned out to be to set the option to Not compress audio in the file.avi -> properties -> advanced options -> audio and check the bottom of the two options "This file already has AC3 sound (copy audio data instead of recomressing it)

Did I say something about copy earlier?

As I said earlier, if I re-encode the sound in AC3 - it turns out to be just cracking noise on both computer and DVD player. If I do NOT re-encode audio (that is leave the sound as it is, the settings you’re talking about) - it’s dead silence on the DVD player but I have normal sound on the computer.

And, yes, my DVD player can play all proper (shop) DVDs fine.

I got so annoyed with this problem so I went and bought a WD HD TV Live box, connected to my network and a Seagate Blackarmor NAS. Now it’s the best way to play all my videos, music and photos on the TV. It plays everything! I mount the NAS as NFS with autofs and the media player connects to the NAS box through SMB(CIFS). Plus more comfort knowing both the media player and NAS run some sort of either Linux or BSD.

But, I would still like to burn DVDs for my parents which don’t have that kind of setup or even a computer. I would like to know what else I can try to fix the sound problem on that plain dumb DVD player.

I may have reproduced this problem this am, but I’m out of time. May not be able to look at it again for some time.

I tried to create a DVD with 11.4 and ran into some errors (no time to post now). But there could be ac3 problems as noted. A very quick surf gave these links:

In particular the last URL looks it could be relevant.

I recommend this issue be reported on the Packman packager mailing list.

well, good it’s not just me then. Why are they all using mencoder? Is there a DVD making program which uses ffmpeg?

I tried one with devede today and have this issue too
Has anyone reported it to packman?

Yes, just sent an email to the Packman mail list.

Given how common AC3 is for creating DVDs, until the problem is addressed, one’s options are limited. Videohelp has this page on DVDs: How to Create a DVD - VideoLAN Wiki

where I note the audio formats for DVDs are AC3, PCM (.wav or AIFF), mp2a, and DTS. Further reading on different web sites suggested DTS is proprietary and its unlikely (?) to find a Linux encoder of it. I’ve also read mp2a does not work in many NTSC DVD players as some sites suggested mp2a is not actually part of the NTSC DVD spec (I don’t know that for certain).

That pretty much leaves only PCM or AC3, and if AC3 is not functioning, one is forced to use PCM. But how to force encoding to PCM into a DVD ? Most Linux programs assume one wants AC3 and automatically encode to AC3 audio.

hey, I’m having the same thing. I tried tovid-mpeg2enc &mp2enc core elements not installed ( I can’t seem to find theese codecs), and Devede either gives me the bs audio, or , when I force the ac3 audio copy I get a mencoder error. I can recreate these easily, If you tell me how to make an error log, then maybe that might help.