opensuse 11.3 and nvidia metamode failure

Hi, everybody!
I installed 11.3 on my Samsung R55 Cavan laptop (GeForce Go 7400) and I am experiencing persistent TwinView/display extension failure.
Procedure: I installed the latest driver from the nvidia page (256.35) with the nomodeset kernel boot option. Nvidia-xconfig wrote a generic xorg.conf, to which I only added a BoardName line for the graphics card (didn’t affect my problem). my xorg.conf on pastebin
Trying to set up TwinView with the NVIDIA X server Settings dialog got me the following error:
“Failed to set MetaMode (1) ‘CRT-0: nvidia-auto-select @1280x1024 +1280+0, DFP-0: nvidia-auto-select @1280x800 +0+0’ (Mode 2560x1024, id: 59) on X screen 0.”
Disper, with its nVidia backend, also failed, except for disper -c (desktop clone 1024x768).
TwinView and disper worked nicely on 11.2 with the driver from nVidia’s opensuse repo.
Any ideas?

Have a look at this:
SDB:Configuring graphics cards - openSUSE
and
oS 11.3 : monitor settings ?

You may get some pointers.

I’m having the exact same problem.
Those links don’t have anything useful in them.
I’ve tried manually editing xorg.conf to enable TwinView but that just crashed my X server on boot.
I’m out of any other ideas.

Did you try using ‘nvidia-settings’ utility to configure twinview?

These might also help:

SDB:NVIDIA troubleshooting - openSUSE

X.Org/Dual Monitors/Nvidia - Gentoo Linux Wiki

Yes. The first thing I tried was configuring with nvidia-settings and that’s when the "“Failed to set MetaMode” error dialogue popped up.

I managed to fix this problem in the meantime.

I ran ‘nvidia-xconfig --dynamic-twinview’ from run level 3. This enabled TwinView and also I can manipulate the settings from nvidia-settings without the MetaMode error.

Good result. This will be helpful to others in similar situations.

Brilliant! I was having problems with twinview and this solved it for me. Now I can manipulate my monitors by using krandr. (Previously I couldn’t)

Thanks for the tip!!! I think this should be added to some sticky somewhere!

Cromulent

I tried the nvidia-xconfig idea - it adds
Option “DynamicTwinView” “True”
to the xorg.conf Screen section. Sadly, no luck - I was able to choose TwinView as before, but got the metamode error messages again.
What somehow worked in the end was to hardcode metamodes into the xorg.conf - this is my new Screen section, inspired by deano_ferrari’s Gentoo wiki tip:

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView"
    Option         "MetaModes" "DFP-0: 1280x800,CRT-0: 1280x1024; DFP-0: 1280x800; DFP-0: 1024x768, CRT-0: 1024x768; CRT-0: NULL"
    Option         "DynamicTwinView" "True"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

I also added a specific Monitor section for the external Dell 1708FP with explicit refresh rates (not sure this is necessary, I’ll try removing it some other time)
There is still the issue of nvidia using the external monitor as the main one and the fact that I can completely crash the X Server and tty switcher by unplugging the monitor and restarting X, but for now, it’s workable, though not very flexible.
Thanks, everybody!

Have you got a working xorg.conf file from 11.2?
If you do, perhaps try using the monitor settings from that until someone documents exactly what the contents of the new xorg.conf.d files should be.

OK here’s what I did. I installed the older repo downloads.nvidia.com/opensuse/11.2/ I then ran the yast and removed the nevo junk. I installed the older kernel for my card and it gave a warning about not having the right stuff. I broke it and installed it anyway. I now had the ability to set the resolution the correct setting. I use 1920x1080. It still did not have any 3d acceleration. I then downloaded the latest version of the nvidia driver from their site, you know the NVIDIA-Linux-256.35.run file. I complied it as root with the x server not running, told nvidia to re-write the xorg.conf file and rebooted. I now have full 3d and everything works. I ran the nvidia configuration as root and set my displays to separate x screens One thing. If you decrease the resolution you will not be able to get back to the higher one, you will get that nasty error message again and will have to start all over again, so once you get the resolution you want, and the screen configurations. KEEP IT!!! openSUSE really needs to work on this one… Ya think? Just a thought… Bring back SaX2!

Here’s my file.

nvidia-xconfig: X configuration file generated by nvidia-xconfig

nvidia-xconfig: version 256.35 (buildmeister@builder101) Wed Jun 16 19:25:59 PDT 2010

nvidia-settings: X configuration file generated by nvidia-settings

nvidia-settings: version 256.35 (buildmeister@builder101) Wed Jun 16 19:25:39 PDT 2010

################

/…/

SaX generated X11 config file

Created on: 2010-07-15T15:08:04-0400.

Version: 8.1

Contact: Marcus Schaefer <sax@suse.de>, 2005

Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>

Automatically generated by [ISaX] (8.1)

PLEASE DO NOT EDIT THIS FILE!

########################

Section “ServerLayout”

Removed Option “Xinerama” “off”

Identifier     "Layout[all]"
Screen      0  "Screen0" 1360 0
Screen      1  "Screen1" LeftOf "Screen0"
InputDevice    "Keyboard[0]" "CoreKeyboard"
InputDevice    "Mouse[1]" "CorePointer"
Option         "Clone" "off"
Option         "Xinerama" "0"

EndSection

Section “ServerLayout”
Identifier “Layout0”
Screen 0 “Screen0” 1360 0
Screen 1 “Screen1” LeftOf “Screen0”
InputDevice “Keyboard0” “CoreKeyboard”
InputDevice “Mouse0” “CorePointer”
Option “Xinerama” “0”
EndSection

Section “Files”
EndSection

Section “Module”
Load “dbe”
Load “extmod”
Load “glx”
EndSection

Section “ServerFlags”
Option “AllowMouseOpenFail” “on”
Option “ZapWarning” “on”
EndSection

Section “InputDevice”

Driver “kbd” will be disabled unless ‘Option “AutoAddDevices” “off”’

is set in “ServerFlags” section.

Identifier     "Keyboard[0]"
Driver         "kbd"
Option         "Protocol" "Standard"
Option         "XkbLayout" "us"
Option         "XkbModel" "microsoftpro"
Option         "XkbRules" "xfree86"

EndSection

Section “InputDevice”

Driver “mouse” will be disabled unless ‘Option “AutoAddDevices” “off”’

is set in “ServerFlags” section.

Identifier     "Mouse[1]"
Driver         "mouse"
Option         "Device" "/dev/input/mice"
Option         "Name" "EzKEY USB-compliant keyboard"
Option         "Protocol" "explorerps/2"
Option         "Vendor" "Sysp"
Option         "ZAxisMapping" "4 5"

EndSection

Section “InputDevice”

# generated from default
Identifier     "Mouse0"
Driver         "mouse"
Option         "Protocol" "auto"
Option         "Device" "/dev/psaux"
Option         "Emulate3Buttons" "no"
Option         "ZAxisMapping" "4 5"

EndSection

Section “InputDevice”

# generated from default
Identifier     "Keyboard0"
Driver         "kbd"

EndSection

Section “Modes”
Identifier “Modes[0]”
ModeLine “1360x768” 85 1360 1424 1536 1792 768 771 777 795 +hsync +vsync
EndSection

Section “Monitor”
Identifier “Monitor[0]”
VendorName “XH@”
ModelName “MONITOR”
UseModes “Modes[0]”
DisplaySize 256 274
HorizSync 30.0 - 69.0
VertRefresh 43.0 - 85.0
Option “CalcAlgorithm” “XServerPool”
Option “DPMS”
Option “PreferredMode” “1024x768”
EndSection

Section “Monitor”
Identifier “Monitor0”
VendorName “Unknown”
ModelName “Acer H233H”
HorizSync 30.0 - 83.0
VertRefresh 56.0 - 75.0
Option “DPMS”
EndSection

Section “Monitor”
Identifier “Monitor1”
VendorName “Unknown”
ModelName “XH@”
HorizSync 30.0 - 69.0
VertRefresh 48.0 - 85.0
EndSection

Section “Device”
Identifier “Device[0]”
Driver “nv”
VendorName “NVidia”
BoardName “GeForce 7600 GS”
EndSection

Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”
BoardName “GeForce 7600 GS”
BusID “PCI:2:0:0”
Screen 0
EndSection

Section “Device”
Identifier “Device1”
Driver “nvidia”
VendorName “NVIDIA Corporation”
BoardName “GeForce 7600 GS”
BusID “PCI:2:0:0”
Screen 1
EndSection

Section “Screen”
Identifier “Screen[0]”
Device “Device[0]”
Monitor “Monitor[0]”
DefaultDepth 24
SubSection “Display”
Depth 15
Modes “1024x768” “800x600”
EndSubSection
SubSection “Display”
Depth 16
Modes “1024x768” “800x600”
EndSubSection
SubSection “Display”
Depth 24
Modes “1024x768” “800x600”
EndSubSection
SubSection “Display”
Depth 8
Modes “1024x768” “800x600”
EndSubSection
EndSection

Section “Screen”

Removed Option “metamodes” “CRT: nvidia-auto-select +0+0”

Identifier     "Screen0"
Device         "Device0"
Monitor        "Monitor0"
DefaultDepth    24
Option         "TwinViewXineramaInfoOrder" "CRT-0"
Option         "TwinView" "0"
Option         "metamodes" "DFP: nvidia-auto-select +0+0"
SubSection     "Display"
    Depth       24
EndSubSection

EndSection

Section “Screen”

Removed Option “metamodes” “DFP: nvidia-auto-select +0+0”

Identifier     "Screen1"
Device         "Device1"
Monitor        "Monitor1"
DefaultDepth    24
Option         "TwinView" "0"
Option         "metamodes" "CRT: nvidia-auto-select +0+0"
SubSection     "Display"
    Depth       24
EndSubSection

EndSection

Section “Extensions”
Option “Composite” “off”
EndSection

@whych: My 11.2 xorg.conf was pretty much autogenerated, if I remember right - I’d have unpacked my old root image to find it if I hadn’t got rid of the problem otherwise.

@all: The official NVIDIA repo is back at ftp://download.nvidia.com/opensuse/11.3 - it’s also listed in YaST. I uninstalled version 256 and took the repo’s 173 instead, removed all tweaks apart from the DynamicTwinView option from my xorg.conf and everything works fine now.

How do you get the 173 version? I have only the choice for the 256, which is not working. All previous suggestions did not help either.

@serengeti: Regarding my driver I find I actually installed the 195 series (G02), sorry :wink: However, checking the nvidia repo I confirm that G02 sports a 256 version number now - did they do a driver update? I wasn’t too happy with the manual 256 install either (see above), so I’ll keep that driver for now. I still have the RPMs, so I could probably drop them off somewhere for you, if the problem persists.
There is a series 173 G01 driver in the repo and quite a number of chips seem to work with both drivers, have you tried the G01 version?

I hit the same issue. Twinview is only working on a resolution of 1024x768 on each monitor. Any higher resolution causes failure to set the metamodes.
I believe this is a bug in the updated nvidia driver (256.35). I also switched back to the old 173 driver which is working fine so far for my 7600GS. However, I believe there may be a performance issue with this old driver.
Does anyone can provide me the latest driver prior the 256 version?
That would be great. Thx. :slight_smile:

I do have x11-video-nvidiaG02-195.36.31-12.1.i586.rpm and nvidia-gfxG02-kmp-default-195.36.31_k2.6.34.0_12-11.1.i586.rpm lying around, although I don’t know whether I’d be allowed to publish them online. If you need them, just send me a message and I’ll e-mail them.

You can also download the older drivers from nvidia if you search for them.
I think the problem comes not with the video card, but the momitor - there is nowhere without sax2 that you can enter the monitor resolution. This means that if you have an older unrecognised monitor, you won’t get the correct display setting.

I don’t think so. Even without sax, you can fully configure your monitor directly in the xorg.conf file. It’s just not that convenient. :wink:
My monitors are both recognized correctly by the nvidia-settings tools and the correct refresh rates are being set up in xorg.conf. Beside of that, there is no problem with the previous versions of the nvidia driver. So, I still think of a driver issue.

Btw, did anyone tried the newly available driver 256.44? There are unfortunately no packages available, yet. So you must compile it yourself.

quick comment on whych’s last post: Nvidia’s archive search can be found here NVIDIA Driver Downloads - Advanced Search, but they only offer the shell scripted installers (.run, “the hard way”) - they have no archive for their openSuSE repository.

I experience the same problem: external monitor can’t be set to a higher resolution than 1024x768 (both monitors). The integrated display works on 1200x800 (when just this is enabled).

I tried with the latetst driver 254.44 but still it is not working.

Any other clues?

greetz,
Matt

hi Matt - did you try older drivers on 11.3? 195 worked for me while 256 didn’t. See the rest of this thread for where to get them.