Open Source NMS on Leap 15.x

Hi All,

My employer wants a low cost Network Management System so I thought OpenSuse might be the ideal platform - However I cannot find anything for OpenSuse that actually works. Does anybody have pointers ?



From a DuckDuckGo search, I found a list which pointed to the following applications available from the openSUSE repositories –

From all the above listed, in the past I’ve taken a look at Nagios – it ran quite happily a while ago …

We run Zabbix in a multi-hundred server system (and other devices on top of it, including firewalls, switches etc) on SUSE with no issues, just need some beefy servers if you collect a lot of information.

Hi Im guessing you dont use Leap/Tumbleweed though as when you try and install Zabbix you get an error message as below

SUSEConnect -p sle-module-web-scripting/15/x86_64
Registering system to SUSE Customer Center

Announcing system to
Error: Registration server returned ‘Please provide Registration Code.’ (401)

This is an Enterprise only module from what I can tell

zabbix is in the OSS Repo, here in Leap 15.3:

linux64:/home/stephan # LANG=C zypper se -s zabbix
Loading repository data...
Reading installed packages...

S | Name                     | Type    | Version           | Arch   | Repository
  | pcp-export-pcp2zabbix    | package | 5.2.2-1.4         | x86_64 | OSS
  | pcp-export-zabbix-agent  | package | 4.3.1-3.11.1      | x86_64 | OSS
  | zabbix-agent             | package | 3.0.31-bp153.1.25 | x86_64 | OSS
  | zabbix-bash-completion   | package | 3.0.31-bp153.1.25 | noarch | OSS
  | zabbix-java-gateway      | package | 3.0.31-bp153.1.25 | x86_64 | OSS
  | zabbix-phpfrontend       | package | 3.0.31-bp153.1.25 | x86_64 | OSS
  | zabbix-proxy             | package | 3.0.31-bp153.1.25 | x86_64 | OSS
  | zabbix-proxy-mysql       | package | 3.0.31-bp153.1.25 | x86_64 | OSS
  | zabbix-proxy-postgresql  | package | 3.0.31-bp153.1.25 | x86_64 | OSS
  | zabbix-proxy-sqlite      | package | 3.0.31-bp153.1.25 | x86_64 | OSS
  | zabbix-server            | package | 3.0.31-bp153.1.25 | x86_64 | OSS
  | zabbix-server-mysql      | package | 3.0.31-bp153.1.25 | x86_64 | OSS
  | zabbix-server-postgresql | package | 3.0.31-bp153.1.25 | x86_64 | OSS
  | zabbix-server-sqlite     | package | 3.0.31-bp153.1.25 | x86_64 | OSS

Also in Tumbleweed and Leap 15.2

Please use Code-Tags for Terminal output.
Also please post the whole commandline, so that everyone can see, which command you execute in which directory as which user…

I use Leap 15.2 and my own Zabbix packages but Zabbix is available in the oss repo or via Open Build Service (if you want newer versions).

Has 4.0.31 (Old Stable)

Has 5.0.9 - I’ll send a request to have it updated to 5.0.14.

Still doesn’t get around the SuseCONNECT issue, I have tried following their install guide but it doesnt work at the point where they say

b. Install Zabbix server, frontend, agent

Activate Web and Scripting Module.

SUSEConnect -p sle-module-web-scripting/15/x86_64The actual URL for web scripting module may be different depending on particular service pack. Use the following command to determine the right one.

SUSEConnect --list-extensions


lsb-release -id

Leap does not use SUSEConnect, so unless you are installing this on SLES it won’t work.

If Sauerlands command does not work, try

cat /etc/os-release

to verify what OS version you are installing this on and then we can go from there.

So I am running Leap 15.2

"NAME=“openSUSE Leap”
ID_LIKE=“suse opensuse”
PRETTY_NAME=“openSUSE Leap 15.2”

So it looks like I either have to find hardware to run server or rebuild this machine as a server - I think I know what direction I need to head in.

Thanks All.

So it looks like I either have to find hardware to run server or rebuild this machine as a server

It is already a server, you don’t have to run SLES - it’s simply the commercial offering. Leap can do everything SLE can do, the only difference in practice is the paid support.

You are simply following instructions made for a different distribution version instead of installing it the way it should be for Leap.

A simple guide is available here for 15.1, simply replace all references to 15.1 with 15.2 or 15.3 depending what system you are installing on;

Well useless is as useless does and I am pretty **** useless

Seems like I cannot start Apache because of some config issue or other

httpd-prefork: Syntax error on line 210 of /etc/apache2/httpd.conf: Syntax error on line 119 of /etc/apache2/default-server.conf: Syntax error on line 30 of /etc/apache2/con>

I have no idea what i am looking at or for and after 6 hours of trying to get this to work well I just give up.

Chance of Success 0
Chance of Failure 100

Can you show the complete output from…

sudo journalctl -u apache2

If it is lengthy, consider uploading to and share the link to it here.

Install that and try again:

**erlangen:~ #** zypper in --type pattern lamp_server 
Loading repository data... 
Reading installed packages... 
'pattern:lamp_server' is already installed. 
No update candidate for 'pattern:lamp_server-20210330-1.2.x86_64'. The highest available version is already installed. 
Resolving package dependencies... 
Nothing to do. 
**erlangen:~ #**

Hi All,

Well have to say and I am totally not sure how but with your help I managed to get it all working (except its not).

I can log into Zabbix no issues , I have set a discovery to run and manually added a couple of nodes, but they dont collect any data.

So as far as OpenSuse is concerned its working now to join the Zabbix community to see if they will help.

The Forum has come through again :slight_smile:

Are you certain that, the other hosts on the network have Zabbix Agents installed and running?

So after all this its a no go - Zabbix wont/cant help as they dont support OpenSuse Leap/Tumbleweed 15.2/15.3 also this version 4.0 is as buggy as hell and will not support “!” in our snmp strings (corporate standard).

The recommendation from the forum “Go Ubuntu” - It’s officially supported.

I don’t understand how this is such a big problem. It took me literally 5 minutes to setup Zabbix on 15.x with zero issues and running 5.x.

Perhaps you should stop following some random guides on their forums/website and use the ones we give you instead of hitting your head on a brick wall or alternatively hire someone who knows how to do this in literally no time at all.

That’s folklore!

SUSE Linux Enterprise Server

If you’re not willing to follow Miuku’s pertinent advice, then go where the official support exists.