nvidia drivers 11.3

Can someone post the url to the nividia drivers for 11.3. They are not yet in the community repos.

I’m not sure that the official Nvidia drivers are ready. However, I searched and found an Nvidia driver “nvidia-gfxG02” under Get Software.

It supports the newer cards GeForce 6x and higher. My card is an GeForce 8600 GTS. BTW I didn’t have to blacklist the nouveau driver before installing the rpm.

Add the following link to Yast Software Repositories:

Index of /repositories/home:/Yareg/openSUSE_11.3



Thanks, that worked! Ill use this until they get the official nvidia repo up.

Just make sure you have backed up your old xorg.conf file from your previous install. The new nvidia drivers don’t work too well at creating a working xorg.conf.
You can also use the ‘hard way’ install as detaield in the how-tos and download the drivers from nvidia’s site.
Make sure you run the install in a run level 3 terminal.

Just for information: To enable 3D acceleration you have to edit your /etc/X11/xorg.conf. Add the option “direct rendering” “yes”, i.e.:

Section “Device”
BoardName “GeForce 8200”
Driver “nvidia”
Identifier “Device[0]”
VendorName “NVIDIA”
** Option “direct rendering” “yes”**

Thanks for pointing me to Yareg’s repo’s, works a treat!

I’ve tried this driver and it sorta works

I can open up the nvidia-settings program, usually when I’ve not had a properly working nvidia driver in the past when opening this I’ve got a message saying I’m not using the nvidia driver

The problem being I only get two resolution choices: 640x480 and 320x240

If I rename the created xorg.conf to something else to trying forcing auto-detection of the card it gets a little better, in nvidia-settings I then get some higher resolutions … up to a whopping 1024x768

It’s a 32bit system and the card is a GeForce GTS250, on 11.2 I could use resolutions up to 1680x1050

Any ideas what I need to do so I can use higher resolutions?

Incidentally I get exactly the same behaviour if I do a ‘hard way’ driver install from the binary

That worked well here. I just added ‘nomodeset’ to kernel line in menu.lst and installed it ‘the hard way’ as normal and rebooted. I have saved ‘xorg.conf’ from previous install as well as current 11.3 install in a secure location.

yes, me too, thanks! just can’t get compositing back, was all fine in 11.2 :frowning:

For compositing you have to enable 3D acceleration. See my posting in this thread.

I think I’ll do a new thread on the resolution issue

This one seems to be about ‘yeah that worked for me thanks’

The newest certified nvidia drivers work just fine without an /etc/X11/xorg.conf file. All you have to do (after disabling KMS) is add the right driver to /etc/X11/xorg.conf.d/50-device.conf:

Section "Device"
  Identifier "Default Device"

  #Driver "radeon"
 ** Driver "nvidia"**

  ## Required magic for radeon/radeonhd drivers; output name
  ## (here: "DVI-0") can be figured out via 'xrandr -q'
  #Option "monitor-DVI-0" "Default Monitor"


No further configuration necessary. Composite & direct rendering are enabled by default.

Do you mean the drivers downloaded directly from nvidia, or some other repository ?

I tried that option out, but nothing changed. The KDE4 desktop settings say “Compositing is not supported on your system.
Required X extensions (XComposite and XDamage) are not available.” Any hints of what’s missing here? My card is a Quadro NVS 160.
Before and after adding the direct rendering option I was getting 2700 fps on glxgears, so I suppose 3d was on already (with nouveau it’s 10x slower).
Needless to say I hate when “final” releases show up with such mess, as well as release versions ending with 3(!) come with such brand new experimental features like KMS (which I welcome in general, but would love to have it better polished, e.g. on my old ATI card it worked fine).

Downloaded from Nvidia. I guess I do it the “hard” way.

Can’t speak to your KDE problem. Gnome/compiz picked it up just fine.

@dich: do you still have an /etc/X11/xorg.conf hanging around? If so, rename that. I took a look around, your card is supported, it should work. But…I don’t know what you have done already to get it running. In KDE, do you get the same message for a newly created user?

I just downloaded the latest and greatest from the nvidia website and intalled that… needed to modify grub to nomodeset first though.

All of us had to d/load the latest drivers from nvidia and do it the ‘hard way’
The problem seems that whether it works or not depends on what video card and monitor you have.

I tried, and got it working with the 32 bit 11.3, but on the same pc running 64-bit 11.3, the 64 bit version refuses to work!

I guess this problem is because - the correct xorg.conf file doesn’t get created… I luckily didnt have problem on my laptop with Geforce 8600M GT…

Is it good to install the Nvidia drivers?
The ones that come with the installation, should be cutting edge. Well, it does work in some sense.
But i do have some issues of gfx mess with thumbs and at switching betweens accounts.
Since i only have once PC (ugg) i don’t want to mess up the configuration. Are there any updates for the one that come with the installation?