Nvidia driver installation question

I installed OpenSUSE 13.1 last night, having finally seen that the Nvidia drivers are ready to be installed along with the repository or one-click.

My hardware is an I5 cpu, Nvidia GTX 550 ti graphics card and 8 GiB’s memory. I installed with the btrfs file system for root. I note that the install preserved my home directory that had been on the computer previously but, quite properly, the OpenSUSE settings for the appearance of the desktop were all normal. The prior installation was an ubuntu based Distro.

I ended up installing OpenSUSE twice. I hope to avoid what happened the first time, so I am posting that event. The first time, I had the software update during installation. Thereafter, I installed the Nvidia driver via one-click. I chose the correct one-click for my graphics card (i.e., for GeForce 8 and later - the correct driver is the 331.20 driver) and installed it but when I went to restart using restart via Kickoff, nothing happened. After waiting a bit, I restarted the computer manually. After KDE’s splash page, the computer did not load a desktop but only a blank screen.

I restarted manually and booted via the low graphics version, which brought me to a desktop but one that did not properly recognize my screen resolution. In any event, I rebooted normally but without doing anything else. This time, I reached a terminal. I tried - but was not sure what to do - to start X, which is what I would have done in Arch. That got me nowhere. I decided, because this was a fresh install, that it made sense merely to reinstall OpenSUSE.

This time around, I did not update during installation but waited until the system was installed. Again, my home directory was preserved and, like before, the OpenSUSE’s settings for the appearance of the desktop loaded properly. I hope this time not to run into problems installing the Nvidia drivers. I was able to reboot normally, via the Kickoff launcher. This evening, I plan to add the repository, this time, “The Repository Way.” If, after doing so, the driver does not install correctly, how does one go about correcting things via terminal?

One point. I note, looking in the autostart programs via KDE’s system settings program that Nvidia is set to load. Should I untick this setting, given that the Nvidia driver is not installed yet? Also, is there a possibility that such setting or something else in my home partition - which was based on a ubuntu style system - interfered or will interfere with correctly loading the Nvidia driver, once I again install it. I note that I had, prior to OpenSUSE, saved a Nvidia (and I am not sure of the correct name for it) profile. Perhaps, that profile was loaded and is inconsistent with something in OpenSUSE.

Please note that I am following up on a pre-installation post here. I hope I have not run afoul of the posting rules.

Just one more point. I was using the 331.20 driver before installing OpenSUSE, so I know it can work, at least with Ubuntu.

I have now installed the nvidia drivers again. After reaching the desktop normally, the desktop crashed and a black screen came up with the following words:

  OK   ] Started Authorization Manager.
  OK   ] Started Modem Manager
  OK   ] Created slice system-network.slice.
                                                                    Starting ifup managed network interface en4s0. . .

Please note that, before installing the nvidia drivers, I removed the pre-existing nvidia setting from from the autostart.

Please also note that I installed, as applicable, the three packages x11-video-nvidiaG03, nvidia-gfxG03-kmp-desktop and nvidia-computeG03.

I tried rebooting again, to see what happens. This time, I booted to a terminal.

Before I waste anyone’s time here, I am reinstalling OpenSUSE, this time reformatting my root and home partitions, so that it wipes out everything on it before installing OpenSUSE.

I reinstalled, updated, rebooted, installed the repository for Nvidia, installed the three Nvidia packages, plus those others recommended by the system. I rebooted again, and the system loads through the end of KDE’s splash screen, then I get a blank screen (other than a blinking cursor). So, I consider this a complete disaster.

Which package 01,02,03?

I think you may want the 02 for 8 series

The automated stuff want to put 03 in but that is only for newer cards.

Note you can boot to a terminal and use the command line yast to install driver yo don’t have to reinstall

at grub boot press e then find the line starting linux and press end key to go to end of line enter a space and a 3

log as root and run yast

Don’t know why I thought you had 8 series but you can still try the 02 version

I used the 03 series because it has the driver that relates to my system, the 331.20 driver. Thank you for the information regarding how to change the driver.

You are right that is the driver recommended. You might still try the 02

Or just remove the NVIDIA stuff which should take you back to default nouveau

BTW it should install 3 package including the kmp and compute

just search in yast for nvidia

If you’re using the proprietary nvidia driver (doesn’t matter if it’s G02 or G03), you should add your user to the “video” group.

The bug from 12.3 that you don’t have sufficient rights for direct rendering otherwise, reappeared in 13.1 unfortunately (apparently they added the wrong patch to the systemd package, which didn’t work on many systems).
I’ve just reopened it:

See also the 12.3 release notes:

Thank you. I am trying your suggestion now. I shall report back on the results.

Thanks, I had, before starting, inquired about what to install and had installed all three packages. I shall, this time, also make sure I am able to be a user, as per Wolfi323’s suggestion

I note that, subsequent to my already described unsuccessful installation of the Nvidia drivers, I reinstalled OpenSUSE. Notwithstanding, I started the process to install the drivers but the repository cannot be added. Perhaps the bug is being fixed so the 13.1 repository has been removed for repairs.

That’s what it appears to be

If you mean the “bug” that you have to add your user to the “video” group manually, then no.
That’s just the way the nvidia driver works since ages.

Prior to 12.3 this was done automatically by the openSUSE installation, but since 12.3 not anymore.
For 12.3 systemd/logind was patched to grant the logged in user access to the gfx card’s device files, this was released as online update later on.
Unfortunately only an earlier version of that patch, that didn’t work properly on some (many?) systems, got submitted to Factory and ended up in 13.1. For more information about this, see the bugreport I linked to.

The next systemd update for 13.1 (already in preparation) should fix this again though.

But I don’t know the reasons why the nvidia repo has been reverted to the previous state (no 13.1 drivers, only 319.32 for 12.2 and 12.3).

A quick question. Once I install the repository and 3 packages/drivers, do I add my user to the video group before or after rebooting? I assume that the answer is before, but, before I mess anything else up here, I want to be sure.

Yes, you should do it before rebooting.
Otherwise you could have problems logging in, although “recovery mode” should still work of course.

And btw, the nvidia repo is back up again for 13.1… :wink:
What they fixed apparently was a wrong dependency in the packages:

Mon Dec 16 13:48:34 UTC 2013 - sndirsch suse com

  • no longer hardrequire nvidia-glG03 (by x11-video-nvidiaG03), just
    recommend it when installing the KMP, since there are users who
    want the driver stack except for the GL components

Thanks. I really appreciate all the assistance you have provided. I shall install the Nvidia drviers, etc., later this morning and let you know the results.

OpenSUSE is really quite different, with respect to installing things, than Mint and Ubuntu, the Distros with which I am most familiar. In some ways, it is far more automated than either of them. In other ways, less so. I am not adverse to or scared of using command line and, for one rather old computer I have, my son and I installed Arch, where command line and reading the instruction manual go hand in hand for what, in OpenSUSE, Mint or Ubuntu (or most every other Distro), would be a fairly simple thing. But as they say about Arch, “correctness over convenience” - which, I think, translates in reality to “it will take you 2 hours to do what ought take you no time at all.”

I am very pleased to report that the Nvidia drivers, etc., are now installed and appear to be working normally. How do I mark the thread “Solved”?

Just a word of caution for this topic:

  1. The G03 driver package installs for my Nvidia GTX 550 ti graphics card, I can add the user to the video group and, the first time around, I can boot in. The second time, I go nowhere!!! In order to use the Nvidia drivers for my graphics card, I must use the G02 package. This, notwithstanding the fact that the G03 package points to the driver that is recommended for my graphics card.

  2. If you use the G02 package, then you have to also tell the computer, so that it does not upgrade you to the G03 package, not to install the G03 packages under any circumstances. Otherwise, you will, at some point soon, wipe out your ability to log in.

I cannot confirm this.
The G03 driver works fine here on a system with a GTX 550 Ti card with openSUSE 13.1.

What do you mean exactly with “I go nowhere”?
Since it only happens on second boot, it could be some user setting (maybe kscreen) that’s at fault here…

But well, if the G02 driver is working for you, just using that is OK I guess. :wink: