NVIDIA can't lower resolution


My nvidia options don’t allow me to lower (or change) the resolution. It only offers me the options “auto” and “1920x1200”. When i give a presentation i want to lower it down to whatever the projector is capable of.
I have a Dell Precision M6300 with a Quadro FX1600M

My xorg config is as follows:

Section “ServerLayout”
Identifier “Layout[all]”
Screen “Screen[0]” 0 0
InputDevice “Keyboard[0]” “CoreKeyboard”
InputDevice “Mouse[1]” “CorePointer”
InputDevice “Mouse[3]” “SendCoreEvents”
Option “Clone” “off”
Option “Xinerama” “off”
Section “Files”
InputDevices “/dev/gpmdata”
InputDevices “/dev/input/mice”
FontPath “/usr/share/fonts/misc:unscaled”


Section “Module”
Load “dbe”
Load “freetype”
Load “extmod”
Load “glx”

Section “ServerFlags”
Option “AllowMouseOpenFail” “on”
Option “ZapWarning” “on”

Section “InputDevice”
Identifier “Keyboard[0]”
Driver “kbd”
Option “Protocol” “Standard”
Option “XkbLayout” “nl”
Option “XkbModel” “precision_m”
Option “XkbRules” “xfree86”

Section “InputDevice”
Identifier “Mouse[1]”
Driver “mouse”
Option “Buttons” “5”
Option “Device” “/dev/input/mice”
Option “InputFashion” “Mouse”
Option “Name” “MX310”
Option “Protocol” “ExplorerPS/2”
Option “Vendor” “Logitech”
Option “ZAxisMapping” “4 5”

Section “InputDevice”
Identifier “Mouse[3]”
Driver “synaptics”
Option “Buttons” “7”
Option “Device” “/dev/input/mice”
Option “Emulate3Buttons” “on”
Option “InputFashion” “Mouse”
Option “Name” “Touchpad”
Option “Protocol” “explorerps/2”
Option “SHMConfig” “on”
Option “Vendor” “Synaptics”
Option “ZAxisMapping” “4 5”

Section “Modes”
Identifier “Modes[0]”

Section “Monitor”
Identifier “Monitor[0]”
VendorName “SEC”
ModelName “KH164 LCD MONITOR”
UseModes “Modes[0]”
DisplaySize 367 230
HorizSync 30.0 - 94.0
VertRefresh 43.0 - 60.0
Option “CalcAlgorithm” “XServerPool”
Option “DPMS”
Option “PreferredMode” “1900x1200”

Section “Device”
Identifier “Device[0]”
Driver “nvidia”
VendorName “NVidia”
BoardName “Quadro FX 2500M”
Screen 0

Section “Screen”
Identifier “Screen[0]”
Device “Device[0]”
Monitor “Monitor[0]”
DefaultDepth 24
SubSection “Display”
Depth 15
Modes “1900x1200” “1600x1200” “1680x1050” “1600x1024” “1600x1000” “1400x1050” “1600x900” “1280x1024” “1440x900” “1280x960” “1366x768” “1360x768” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
SubSection “Display”
Depth 16
Modes “1900x1200” “1600x1200” “1680x1050” “1600x1024” “1600x1000” “1400x1050” “1600x900” “1280x1024” “1440x900” “1280x960” “1366x768” “1360x768” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
SubSection “Display”
Depth 24
Modes “1900x1200” “1600x1200” “1680x1050” “1600x1024” “1600x1000” “1400x1050” “1600x900” “1280x1024” “1440x900” “1280x960” “1366x768” “1360x768” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
SubSection “Display”
Depth 8
Modes “1900x1200” “1600x1200” “1680x1050” “1600x1024” “1600x1000” “1400x1050” “1600x900” “1280x1024” “1440x900” “1280x960” “1366x768” “1360x768” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”

Section “Extensions”
Option “Composite” “on”

Try using xrandr command to set the display resolution of your projector.

List detected display devices and current/available modes with

xrandr -q

Hopefully you will see all connected displays. (Sometimes they’re not correctly reported).

This Xrandr with External Displays HOW TO should give you the basic idea on setting modes.

Hope it is of help. :slight_smile:

Thanks for your response, i will most certainly check this out. However i am not connected to the project at this time.
I should be able to just lower my resolution of my laptop display panel, but there are no resultions in the dropdown box of the nividea settings, just the two i mention: auto and 1900x1200.

Any clues?


Same tool applies. You can do

xrandr -q

to see current/available modes.

For example, I get

dean@linux:~> xrandr -q
Screen 0: minimum 320 x 200, current 1280 x 800, maximum 1280 x 800
default connected 1280x800+0+0 0mm x 0mm
1280x800 60.0*
1024x768 60.0
800x600 60.0
640x480 60.0
960x600 60.0
768x480 60.0
640x400 60.0
640x350 60.0
512x384 60.0
400x300 60.0
320x240 60.0
320x200 60.0

You can see the default (and native) resolution for my display is 1280x800. To set a lower display mode, I can do

xrandr -s 1024x768

The change is immediate.


Hmmm, with me it only displays:
Screen 0: minimum 1920 x 1200, current 1920 x 1200, maximum 1920 x 1200
default connected 1920x1200+0+0 0mm x 0mm
1920x1200 50.0*

That’s it, the problem is somewhere deeper, do you have any clues?



That’s it, the problem is somewhere deeper, do you have any clues?

The X-server relies on EDID information from the display devices (monitors, LCD screens etc) for their available modes. It doesn’t always work properly. You can use xrandr to add new modes for a given display, then set the desired display mode.

If you need these modes to be persistent, your xorg.conf file will need the required modelines added (to your modes section).

For example, if you know your display can do 1024x768@60Hz, then you can use gtf to get modeline

gtf 1024 768 60

1024x768 @ 60.00 Hz (GTF) hsync: 47.70 kHz; pclk: 64.11 MHz

Modeline “1024x768_60.00” 64.11 1024 1080 1184 1344 768 769 772 795 -HSync +Vsync

These can be tested via xrandr as follows. (Note these will not be persistent).

xrandr --newmode 1024x768 64.11 1024 1080 1184 1344 768 769 772 795 -HSync +Vsync

xrandr --addmode LVDS 1024 768

From there, if all went well it should be listed via ‘xrandr -q’. You can then set it with

xrandr -s 1024x768

Have a look at this Ubuntu-based xrandr guide.

Thanks for the comprehensive response. A first try gave me an error stating there was an error changing the configuration. I will dive deeper into the documentation.


I am having the same problem re resolution - it is only offering me the native lcd display.

I have been following the above, but, being a noob to linux, got as far as

xrandr --addmode LVDS 1024 768

when xrandr complained that it didnt know what device LVDS was.

What are the other options for the device name, or where do I get it from? My display appears to be a standard seiko LCD.

Sorry to hijack this thread!


Hi hogg101. Are you using (proprietary) nvidia or (open source) nv driver.

xrandr -q

will list available display device names and modes AFAIK. Sometimes xorg.conf needs adjusting manually, with manual modelines, and they will still get ignored, unless you disable EDID. You may need to google for more info.

Some useful references to get you started

Modify xorg.conf for better performance | TuxRadar

Modeline Database - MythTV


creen 0: minimum 1680 x 1050, current 1680 x 1050, maximum 1680 x 1050
default connected 1680x1050+0+0 0mm x 0mm
1680x1050 50.0*
1280x800_60.00 (0x232) 83.5MHz
h: width 1280 start 1352 end 1480 total 1680 skew 0 clock 49.7KHz
v: height 800 start 803 end 809 total 831 clock 59.8Hz
1024x768_60.00 (0x244) 64.1MHz
h: width 1024 start 1080 end 1184 total 1344 skew 0 clock 47.7KHz
v: height 768 start 769 end 772 total 795 clock 60.0Hz

As you can see, I have managed to follow the above guide so far, and got the 1280x800 line written in, but then got stuck with trying to access it and make it permanent, as detailed in my previous post!


Am still struggling with this.

This is the current output from xrandr -q

Screen 0: minimum 1680 x 1050, current 1680 x 1050, maximum 1680 x 1050
default connected 1680x1050+0+0 0mm x 0mm
1680x1050 50.0*

Is the problem that the info from the EDID shows that min, max and default size is 1680x1050? Can a modeline work if it is outside the min/max range? If so, how do I do it???

I’m not sure how you can set multiple modes with Xorg. I have more experience with laptop displays where it makes sense only to operate at the native resolution. I can only give you basic tips on this. You can disable EDID probes with these options in your xorg.conf “Device” section:

Option “NoDDC” “true”
Option “IgnoreEDID” “true”

Modlines can be generated with the gtf commandline tool. For example, 1280x800 @ 60Hz:

dean@linux:~> gtf 1280 800 60

1280x800 @ 60.00 Hz (GTF) hsync: 49.68 kHz; pclk: 83.46 MHz

Modeline “1280x800_60.00” 83.46 1280 1344 1480 1680 800 801 804 828 -HSync +Vsync

You can put any valid modelines in the “Modes” section like this. (Make sure the “1280x800” identifier appears in your “Screen” section as one of the display modes):

Section “Modes”
Identifier “Modes[0]”
Modeline “1280x800” 83.46 1280 1344 1480 1680 800 801 804 828 -HSync +Vsync

You may also need to set the “PreferredMode” (in “Monitor” section) to the desired mode as well.


This is a laptop and this is my monitors native resolution (1680x) but this makes everything so ****ed small on the screen, and the taskbar at the bottom of the screen only extends halfway across the screen!!!

It can run in any resolution it wants, I just want to be able to run my display at 1280 or 1024 to a) make things bigger and b) not waste half the screen!

Am I talking about the right thing here - under windoze, by right clicking on the desktop, going to properties, I could set the display on the monitor to whatever I wanted. Is this the same function?

Excuse my lack of experience with Suse!


Ok. I don’t think this is a resolution issue, so much as a desktop configuration issue. Can you tell us which desktop (KDE or Gnome)? Which version of openSUSE do you have installed? More info about which driver you’re using might be helpful as well. This terminal command can help with latter:

/usr/sbin/hwinfo --gfxcard

It should be possible to set default font and icon sizes, as well as making sure task bar spans entire desktop.

As requested - I am using 11.1 with KDE.

25: PCI 100.0: 0300 VGA compatible controller (VGA)
[Created at pci.318]
UDI: /org/freedesktop/Hal/devices/pci_10de_407
Unique ID: VCu0.x9ZOvMlpz35
Parent ID: vSkL.GplIvOMTy34
SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
SysFS BusID: 0000:01:00.0
Hardware Class: graphics card
Model: “nVidia GeForce 8600M GT”
Vendor: pci 0x10de “nVidia Corporation”
Device: pci 0x0407 “GeForce 8600M GT”
SubVendor: pci 0x1462 “Micro-Star International Co., Ltd.”
SubDevice: pci 0x3fad
Revision: 0xa1
Driver: “nvidia”
Driver Modules: “nvidia”
Memory Range: 0x92000000-0x92ffffff (rw,non-prefetchable)
Memory Range: 0x80000000-0x8fffffff (rw,prefetchable)
Memory Range: 0x90000000-0x91ffffff (rw,non-prefetchable)
I/O Ports: 0x5000-0x5fff (rw)
Memory Range: 0x93000000-0x9301ffff (ro,prefetchable,disabled)
IRQ: 16 (77038 events)
I/O Ports: 0x3c0-0x3df (rw)
Module Alias: “pci:v000010DEd00000407sv00001462sd00003FADbc03sc00i00”
Driver Info #0:
XFree86 v4 Server Module: nvidia
Driver Info #1:
XFree86 v4 Server Module: nvidia
3D Support: yes
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #8 (PCI bridge)

Primary display adapter: #25

I must admit, the more I fiddle with this, the more I also don’t think it is a resolution issue. Too much windoze - my screen works fine, I just want to make text and things bigger on the screen.

Having fiddled, I have just worked out to set/change the size of my taskbar (if that is the right name!) so that is fixed. Just the font size and things.

Do you know which version of KDE4.x you’re running? This command will give you an idea on this:

kde4-config -v

If KDE4.1.3, then you might want to upgrade. Numerous how to’s if you search (within forums).

Have you tried setting font and icon sizes from

Menu > Configure Desktop > Appearance

As for the task bar, if you right-click on the task bar, then select ‘Unlock Widgets’ then right-click on the task bar again, you will get an option called ‘Panel Options’. You can then select ‘Panel Settings’ and alter the task bar as required. Don’t forget to ‘Lock Widgets’ when done.

Qt: 4.4.3
KDE: 4.1.3 (KDE 4.1.3) “release 4.10.4”
kde4-config: 1.0

This is the KDE I am runnning. I, too, think this is a desktop configuration problem, not a monitor resolution problem. Too much time wasted with windoze and their terminology.

Any guidance would be appreciated!!


Did you see my info regarding font and icon sizes and adjusting task bar length in my previous post?

Read this guide re upgrading to KDE 4.3:

KDE 4.3.2 HowTo for 11.1 - openSUSE Forums

Some more upgrade info here:

KDE/Upgrade - openSUSE


Yes, my friend, I think I have got it now.

Thank you for all your help!


Good result. Thanks for the update. :slight_smile: