Monitor Problems?

I have an older computer, msi board w/ amd phenom2 4600, pny 9400 gt 1gb, and pc 6400 1gb ram. Now I know I could have another gb of ram but I don’t think it matters. I’ve installed OpenSuse 12.2 64 bit Gnome on this. The problem is I can not see about an inch of the left side of the screen. Any Ideas? I’ve tried to adjust screen with monitors settings but it does not work.


You should tell us more about the monitor, graphics card, and driver. Is it a tv/monitor? Connection type (eg VGA)?

For the graphics, run this command from a terminal:

/usr/sbin/hwinfo --gfxcard

PNY 9400 GT 1gb Pcie
Monitor is unknow

/usr/sbin/hwinfo --gfxcard
28: PCI 200.0: 0300 VGA compatible controller (VGA)             
  [Created at pci.319]
  Unique ID: B35A.BR+C9WaPck8
  Parent ID: WL76.hxgMt5VT3m4
  SysFS ID: /devices/pci0000:00/0000:00:09.0/0000:02:00.0
  SysFS BusID: 0000:02:00.0
  Hardware Class: graphics card
  Model: "nVidia G96 [GeForce 9400 GT]"
  Vendor: pci 0x10de "nVidia Corporation"
  Device: pci 0x0641 "G96 [GeForce 9400 GT]"
  SubVendor: pci 0x196e 
  SubDevice: pci 0x0562 
  Revision: 0xa1
  Driver: "nouveau"
  Driver Modules: "drm"
  Memory Range: 0xdf000000-0xdfffffff (rw,non-prefetchable)
  Memory Range: 0xc0000000-0xcfffffff (ro,non-prefetchable)
  Memory Range: 0xdc000000-0xddffffff (rw,non-prefetchable)
  I/O Ports: 0xec00-0xec7f (rw)
  Memory Range: 0xdef80000-0xdeffffff (ro,non-prefetchable,disabled)
  IRQ: 19 (3822 events)
  I/O Ports: 0x3c0-0x3df (rw)
  Module Alias: "pci:v000010DEd00000641sv0000196Esd00000562bc03sc00i00"
  Driver Info #0:
    Driver Status: nvidiafb is not active
    Driver Activation Cmd: "modprobe nvidiafb"
  Driver Info #1:
    Driver Status: nouveau is active
    Driver Activation Cmd: "modprobe nouveau"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #20 (PCI bridge)

Primary display adapter: #28

Does this help you?

Why not tell us about this unknown monitor of yours. What is its make, model, highest resolution and input types supported.

Thank You,

I don’t know the name. It doesn’t say. Only vga and i believe 1024 by 768. I could be wrong though, might be a little higher. I could only get those two to come up on display settings in Suse

Have you ever considered installing the nVIDIA driver using the repository method? I guess if this video card has ever worked with your vidoe card or does work properly with Windows, I would consider loading the nVIDIA proprietary video driver using the repository method. Open up terminal, and execute these three commands.

su -

zypper ar -f nvidia

zypper install x11-video-nvidiaG02

You must restart your PC after the video driver install is done. Very often the proprietary video driver works better with such equipment as this monitor. You can search for and install the package nvidia-settings from YaST if the video driver installs OK for you. There is always a risk that the video driver will not work for you, but it works for most people, but be aware of this potential problem. As always, back up any critical data and I always keep an openSUSE 12.2 LiveCD ( Download openSUSE 12.2) all ready downloaded and tested to boot properly on your PC before you do anything else.

Thank You,

Ya nothing. No change.

I had a similar problem displaying to a secondary monitor also with an nVidia card. Does your monitor have an “autodetect” feature to re-synchronize its settings? You may want to investigate that to see if that is the source of the problem. I was beating my head against the wall for quite some time trying to tweak the X settings when all I had to do was push a button.

Hope that helps,

Do you mean that you installed the proprietary nvidia driver, and that you still have an offset display?

If you examine /var/log/Xorg.0.log, you’ll get a good idea about what display modes are detected by the X-server, and any issues that exist. If you want to share the contents of this file, then please cut and paste, then upload to SUSE Paste

It is possible to manually configure the desired resolution and refresh rates, but you do need to know what your monitor is capable of. If it’s a ‘no-name’ brand this might take some experimentation. I assume it’s an LCD display, and not a CRT type? (Please tell us if it is.)

Yes I installed the proprietary nvidia driver and still have an offset screen. My monitor is an LCD. Will examine the file you said and upload shortly.


Uploaded to link.

But there was another log file there as well.


Need to see this one?

Make sure that you post the link to it here. (I forgot to mention that step in my last post.)

On 2013-02-16 19:06, dooglo wrote:
> Uploaded to link.

And you keep the link secret? :-o

Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

No, but share the URL here so that we can view it.

The content of the /var/log/Xorg.0.log file will tell us what X is using to configure the monitor. ie is it being treated as a specific monitor ? or some generic monitor.

I keep on getting database error when creating.

Packet too big

I have just cut and pasted my Xorg.0.log without issue. Once created with name and title, it generated the URL for me with no issue, so I don’t know what you’re misunderstanding or doing wrong.

FWIW, there is a susepaste app written by Michal Hrušecký which can simplify the whole process by pasting from the CLI:

susepaste in openSUSE Factory » Michal Hrušecký

So, when I copy and paste into it and click create I get this

Error Number: 1153
Got a packet bigger than 'max_allowed_packet' bytes

I’ve never experienced that error, nor aware of anyone else reporting that error. Are you sure that you’re only cutting and pasting the contents of that file? Did you get that output from

cat /var/log/Xorg.0.log

Be careful about what you cut and paste.

Try another pastebin eg - #1 paste tool since 2002!

Maybe if there are numerous errors being reported, perhaps your Xorg log could get lengthy. In that case truncate the output, so we only get the first section, dealing with inintial EDID detection and monitor configuration. The next section deals with input devices typically. Leave all that out.