Linux 6.6 doesn't boot on my workstation

Hi, I have a workstation with Tumbleweed on it. Linux 6.5 works perfectly on it, but 6.6.1 just won’t boot. Grub shows the “Loading vmlinuz” and “Loading initial ramdisk” messages, and then the whole thing hangs on that screen.
The workstation is old: Dell T5600 with two Xeon E5-2680 CPUs and an Nvidia NVS 510 GPU.
I’ve checked the release notes of Linux 6.6 to see if support for some hardware was dropped, but didn’t find anything relevant.
I’ve found this bug report 1217282 – kernel-default-6.6.1 fails to boot
But it is about a regression of the i915 driver, I shouldn’t be affected by that because I have got no Intel GPU, right? Also, adding the nomodeset kernel cmdline parameter, as suggested in the bug report comments, does not help in my case.
Was something changed openSUSE-side with the release of 6.6?
EDIT: I’m using the nouveau driver for the GPU.

NVIDIA driver fails to build against kernel 6.6.1 currently…

Did you actually read the initial post?

And please don’t spread wrong informations about the NVIDIA drivers. Only the G04 series (390.x.x) does not build at the moment at kernel 6.6 series (as the 390 series is EOL and no longer supported upstream). But the Nvidia NVS 510 which is used by the TO uses the G05 (470.x.x) series which builds properly on kernel 6.6 series. Please do a basic research before posting stuff…

There might be a relation to this topic:

@Tomoms Hi, your hardware should be fine (there are a number of Xeon users here including myself).

So if you boot to the previous kernel, can you show the output from;

cat /proc/cmdline
cat /etc/os-release | grep VERSION_ID
zypper lr -dE

And what is the command your using to update this system?


t5600:~ # cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-6.5.3-zen-Tom root=UUID=5136bb35-acaa-4796-b463-8c9ef307025d splash=silent quiet nvme_core.default_ps_max_latency_us=0 intel_iommu=on mitigations=auto
t5600:~ # cat /etc/os-release | grep VERSION_ID
t5600:~ # zypper lr -dE
#  | Alias                            | Name                                         | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                    | Service
 1 |    | Repository principale (NON-OSS)              | Sì      | (r ) Sì   | Sì      |   98     | rpm-md |                                  | 
 2 |        | Repository principale (OSS)                  | Sì      | (r ) Sì   | Sì      |   98     | rpm-md |                                      | 
 3 | | Repository principale degli aggiornamenti    | Sì      | (r ) Sì   | Sì      |   98     | rpm-md |                                        | 
 4 | hardware                         | Hardware tools (openSUSE_Tumbleweed)         | Sì      | (r ) Sì   | Sì      |   99     | rpm-md |               | 
 5 | home_phoenix.os_main             | Package for OpenSuse  (openSUSE_Tumbleweed)  | Sì      | (r ) Sì   | Sì      |   99     | rpm-md | | 
 7 | packman                          | packman                                      | Sì      | (r ) Sì   | Sì      |   90     | rpm-md |                   | 
10 | security_forensics               | Forensics Tools and Libraries (openSUSE_Tu-> | Sì      | (r ) Sì   | Sì      |   99     | rpm-md |    | 

Sorry for the mixed localisation of my system. “Sì” means “Yes”. As you can see, the 6.5 kernel I am using right now is my custom kernel, but the official 6.5.x kernels work fine. The problem arises when booting official 6.6.1.
Repository 4 is enabled only for the scrcpy package, #5 only for Stacer. #10 only for Ghidra. All other packages come from either the default repos, or from Packman.
EDIT: I update my system using zypper dup.

@Tomoms So you have a funky controller in your NVMe device? Did you try at grub editing out that option to see if the system would boot?

Hi, no, that option in my kernel command line is not there because I have a funky controller, but simply because I use this computer to compile the Android OS (huge project with dozens of GBs of source code) on that drive, and someone in the Android community stated that to optimize the building speed, setting that nvme option is beneficial. I am however unsure it is actually needed, I just trusted this person without doing much research. Anyway, removing it does not help. Linux 6.6.1 still doesn’t boot.
I forgot to mention that when GRUB hangs on “Loading initial ramdisk”, my workstation’s diagnostic LEDs turn on with a pattern that, according to the service manual, means “Other generic failure”.
Thank you for your help!

@Tomoms OK, you can see what parameter options are via /sbin/modinfo nvme_core :wink:

And in grub if you select rescue mode, does it boot?

Can you show the output of the command lsblk as well.

This what happened to me as well but not only that it brick my system lol. Now I don’t have PC . The 6.6.1 Kernel is really something though :smiling_face_with_tear:

@projectmirai39 No issues here with 6.6.1 kernel (I’d watch out for 6.6.6 one though) :wink: with MicroOS and Tumbleweed.


Ah yes, the sign of the beast … best to avoid that version.

And yea, no issues here with current TW, on four different machines: two AMD specific and two Intel specific.

Rescue mode does not help, the computer keeps hanging at the same point.

sda           8:0    0 232,9G  0 disk 
└─sda1        8:1    0 187,2G  0 part /mnt/ssd
sdb           8:16   0 931,5G  0 disk 
├─sdb1        8:17   0 637,2G  0 part /mnt/ssd/21/prebuilts
│                                     /mnt/ssd/20/prebuilts
│                                     /mnt/ssd/18.1/prebuilts
│                                     /mnt/data
└─sdb2        8:18   0 294,4G  0 part 
sdc           8:32   0 447,1G  0 disk 
├─sdc1        8:33   0   100M  0 part /boot/efi
├─sdc2        8:34   0    16M  0 part 
├─sdc3        8:35   0 124,4G  0 part 
├─sdc4        8:36   0   505M  0 part 
├─sdc5        8:37   0  24,4G  0 part [SWAP]
├─sdc6        8:38   0    60G  0 part /var
│                                     /root
│                                     /usr/local
│                                     /srv
│                                     /opt
│                                     /boot/grub2/x86_64-efi
│                                     /boot/grub2/i386-pc
│                                     /.snapshots
│                                     /
└─sdc7        8:39   0 143,1G  0 part /home
nvme0n1     259:0    0 465,8G  0 disk 
└─nvme0n1p1 259:1    0 399,6G  0 part /mnt/nvme

/dev/sdb1 is involved in some bind-mounts, and I have free unallocated space at the end of my SSDs because I’m paranoid with overprovisioning :slight_smile:

@Tomoms If you disconnect sda and sdb, does it get further?

@malcolmlewis No, it does not.

@Tomoms Bug report time… :frowning_face: openSUSE:Submitting bug reports - openSUSE Wiki

@malcolmlewis Filing the bug report right now. Removing the intel_iommu cmdline parameter did not help either, FYI. Thank you for your help.

1 Like

Please share a link to your bug report.

There is a similar case in the german forum. So its author might wish to join in.

Thank you.

@susejunky Here it is: 1217344 – Linux 6.6.1 fails to boot

@Tomoms have you tried 6.6.2 in the latest snapshot?

@Tomoms : Thank you !