Libre-Office bug and Nvidia graphics problem

Hello
I am using openSUSE Tumbleweed KDE plasma 5 right now, very happy (Dell Inspiron 5558 quad core i5 with intel and nvidia graphics)
But O have an issue with libre office… These black boxes on some toolbar icons are very annoying and since 99% of my work is in libre office is an annoying bug for me so I tried to fix it :slight_smile:

Here is a screenshot of what I’m talkin’ about:
http://s27.postimg.org/m92qzavn7/Screenshot_20160123_231329.png

Annoying huh? Yeah you bet

SO
When I clean-installed the xfce desktop, selected the Breeze theme (icon theme above) and there were the black boxes again. So I tried the steps below:

  1. Installed Bumblebee according to this page SDB:NVIDIA Bumblebee - openSUSE Wiki (yes my laptop supports switchable graphics)
    2)Enabled openGL from libre office menu (Tools>Options>View)
    3)Problem solvedlol!

Now I am using the KDE plasma 5 (clean install) and, following the same steps, the “black box” issue wont fix (I have reported a bug a few days ago too)

Plus, nvidia setting wont launch too even though I have the icon on the application menu. Weird because the installation of bumblebee went fine and I even tested it (I ran

optirun glxspheres
and I saw the spheres)

What can I do to resolve the two (probably relevant) problems?
(Especially the libre office problem, that’s what I care about mostly )

lol!

are you using bumblebee with novou or with the nvidia run file, as novou does not like plasma 5 yet, so eather get the hard drivers or don’t use plasma 5 there are other DE’s including kde4’s plasma

edit,
intel’s driver does not like plasma 5 too, so if you’re an optimus user don’t use plasma 5

Nvidia settings should be launched by:

optirun -b none /usr/bin/nvidia-settings -c :8

or the desktop launcher modified accordingly:

Exec=optirun -b none /usr/bin/nvidia-settings -c :8

I’m not sure there is a bumblebee nvidia driver for TW, as there is no prebuild nvidia driver for TW, I do believe he has intel+novou and both have issues with plasma 5, one option would be to downgrade to leap and force nvidia instead of intel’s module (try googling this) as there is no stable intel driver for plasma 5, different systems have different issues but if a fix is found it will come in TW first

Yes that worked! Thank you!
But what does that line mean? Why did it worked with this? How did you know? :smiley:

I installed bumblebee after enabling this repository

zypper ar -f [http://download.opensuse.org/repositories/X11:/Bumblebee/openSUSE_Tumbleweed/](http://download.opensuse.org/repositories/X11:/Bumblebee/openSUSE_13.1/) Bumblebee

and following the instructions on this page SDB:NVIDIA Bumblebee - openSUSE Wiki

First I used bumblebee with nouveau drivers. The black box bug didn’t fix, so I tried using the nvidia drivers (blacklisted nouveau too). I generally followed all instructions and it worked in the xfce environment, everything was fine there. In plasma 5 there must be some kind of complication and it won’t work :sarcastic:

Plus I get that “Failed to load kernel modules” kind of error on start up, but I can’t read it all because it disappears too fast :sarcastic: This started after installing bumblebee. There is some mystery here…

I have to note that kubuntu 15.10 runs fine from the live CD (no graphical bugs or other errors) which means maybe it is not only the DE’s fault… But my laptop supports switchable graphics for ubuntu too (I checked that in uefi/bios settings)

that command optirun forces the use of the nvidia chip, the nvidia propitiatory drivers work fine with plasma 5, it’s intel’s that are buggy, it should be fixed soonish and as you are using TW you you always have the latest intel drivers (they’re part of the kernel), you could add wolfi’s plasma 5 repo and install kde4 too so you’ll have an option between kde4 which works fine with intel and plasma 5 which should work soonish.

[optirun]
You need the Nvidia chip to be activated by optirun to have nvidia-settings find an interface to talk to.
-b none]
You don’t want nvidia-settings to display its panel via accelerated graphics (might be omitted).
-c :8]
Bumblebee starts an auxiliary Xserver (# 8) to render accelerated graphics and links the Nvidia chip to it.

See “man optirun” and “man nvidia-settings” for further details.

Thank you very much for your answers! :wink:
My hardware is pretty new, so as you implied, the only possible solution is to wait for an update that may improve intel graphics drivers which will fix these minor bugs?

WRT your LibreOffice interface problem you might also try switching

System settings > Display and Monitor > Compositor > Rendering Backend

One of the 3 options offered might work, depending on your HW.
(BTW, I cannot reproduce your problem here…)

Okay, I tried
It offers three options:
1)openGL 3.1
2)openGL 2
3)xrender

Switching between them doesn’t change anything. :shame:

I am bringing this up a little…I am still having the issue.

I noticed that in gnome I can enable openGL and the issue is fixed. However in KDE when i check “enable openGL” in “View settings” and restarting, openGL is still disabled as stated below the option (“openGL status: Disabled”)
Plus there are other minor graphical glitches like white lines outside the paper, etc

Is there any way to force openGL?
Hackers please help me :wink:

it’s a bug with intel’s driver and plasma 5’s acceleration as gnome does not use plasma 5 this bug is not present in gnome or in any other desktop.
try using uxa for intel’s chip
edit or create the file /etc/X11/xorg.conf.d/20-intel.conf

kdesu kate /etc/X11/xorg.conf.d/20-intel.conf

paste this


Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "uxa"
EndSection

according to the kde people this might help some users
https://mail.kde.org/pipermail/kde-distro-packagers/2015-August/000088.html

The problem is fixed! rotfl! wow I have been trying to solve this since autumn
I read about the bug…
I’m very happy right now…but I have to note that while the cpu is in normal levels ( 5 - 25 % ) the browser has become very slow, after applying the fix and rebooting, especially youtube videos (I haven’t installed flash player yet)

One more thing: to undo the fix, I can simply delete the lines, right?

http://s17.postimg.org/is06pi33h/Screenshot_20160408_091051.png

I am afraid I can’t keep using the fix. It causes internet browsing with firefox very slow with constant freezes especially on youtube.
Is there a way to apply the fix only for libreoffice? Or some other update about fixing the problem? :frowning: Why this issue isn’t present in kubuntu? Maybe there is a missing package ?

I read that the UXA method is inferior (slower) to SNA so I guess there is no hope :’(:stuck_out_tongue:

It should not be significantly slower. It is slower but it should not be noticeable by eye only in benchmarks. But it all depend on the exact hardware

In my case it is quite noticeable when browsing with firefox especially in scrolling, right clicking, opening tabs

Youtube constantly freezes the browser for a few seconds, opening tabs is impossible during the short freeze

Browsing is unusable in my case when using UXA :’( Other than that, there are no other issues (that I’m aware of) with other applications. Only web browsing.

Update: used the uxa method again and now I tried the Opera (proprietary) browser from the official openSUSE Non-OSS repos. It works fine. Yay.
Seems that the issue is with firefox only. For some reason it doesn’t like the uxa method.

I use firefox a lot. Any chance to make it work without the freezes?

I do believe Firefox blocks hardware acceleration on most intel gfx devices, if it’s on for your machine try disabling hardware acceleration, if the problem persists file a bug report at mozilla’s or opensuse’s bugzilla

the uxa fix is meant mostly for the plasma 5 desktop not Firefox, afaik Firefox is gtk2 not a qt app and does not use any kde libraries and as strange as it seams Firefox is slower when using hardware acceleration on intel chips

https://wiki.mozilla.org/Blocklisting/Blocked_Graphics_Drivers#On_X11

Hmm…I don’t think I understand correctly. I set the hardware accelaration to UXA, instead of SNA which would be fine but causes the above issue with libreoffice. So you mean I can disable hardware accelaration for firefox or…in general? And how? I’m kind of lost.

And yes firefox was a bit slow even before applying the uxa fix :shame: