leap 42.3: okular prints PDF files smaller, only about 1/2 of oririginal size.


today I noticed not for the first time that printing PDF-Documents (A4 size) from okular results in prints that are much smaller that they should be. A document I wanted to print from my office desktop system that covers the whole A4-page is printed in the lower right corner of the page and has only about half the height and half the width of the A4 paper. I checked that in the printer dialog settings A4 is selected as paper size.

Moreover I had to set the page orientation in the printer settings to the wrong value. The document is in portrait orientation (which is also shown in okulars document properties dialog) but the print only comes out in portrait if I select “landscape” in the printer settings.

When I print the very same document from the same system to the same printer using evince everything works fine, correct size and no need to change any orientation setting for printing.

At home I recently had a similar experience. I have two openSuSE 42.3 systems, where one system (the client) learns all printers from the other system (the server) via cups-browsed. Here the print comes out smaller when printed from the client via okular. Next I printed the same document from the “server” using okular and it came out without any problem in full A4 size. I do not remember however if I changed the orientation from portrait to landscape in this case.

Very strange. Did anyone else experience a similar behavior?


Me. But I have no solution either.

I don’t have a definitive answer here (and I don’t have the same issue when printing from Okular), but does this apply to all PDFs that you try to print?

What is reported by pdfinfo for a given problem pdf file?

pdfinfo /path/to/foo.pdf

Yes, all pdf are affected.

Are your print jobs defaulting to print two pages per sheet?
What PPD are you sing?
What happens with (from the command line) “*lpr -P <printername> filename.pdf *”?

Trawling through some bug reports, I did find the following
Strangely, it links to another bug report (which concerns incorrect scaling with custom page size and ‘fit-to-page’ in use). I’m not sure whether the issue you describe is due to this but here it is anyway…
…and where it was apparently resolved around Aug 2017. I’m sure that Okular (in Leap 42) would have received this patch though (it does in Okular 1.3.3, Leap 15)…

rpm -q okular --changelog|grep -i custom -A3

If not a bug report might be needed perhaps.

A workaround for now might be to just to print PDFs from CLI eg

lpr -o landscape -o fit-to-page -o media=A4 filename.pdf

I tried “evince” instaed of okular as it has a “shrink to fit” option, and this prints my PDFs perfectly.

Okular always seems to print PDFs just a little bigger than the margins of the print will allow, but evince is fine.