Leap 15.2. NVIDIA driver does not work

After compiling my custom kernel 5.7.2, and after patching+compiling the Nvidia driver 440.82 manually as recommended by Isaak Aleksandrov (https://gitlab.com/snippets/1965550), my GeForce GTX 1050 works again as expected.

As far as userland goes, I’m still largely on Leap 15.0, so our results may not be fully comparable. Worth a shot, though.

Edited to add: just noticed the card model in the OP — above patch doesn’t apply, I don’t think. Sorry for the noise. :X


mike@localhost:~> inxi -SGxxz
 System:
   Kernel: 5.3.18-lp152.26-default x86_64 bits: 64 compiler: gcc v: 7.5.0  
   Desktop: MATE 1.24.0 wm: marco dm: LightDM Distro: openSUSE Leap 15.2  
 Graphics:
   Device-1: NVIDIA GF108 [GeForce GT 630] vendor: ZOTAC driver: N/A  
   bus ID: 01:00.0 chip ID: 10de:0f00  
   Display: x11 server: X.Org 1.20.3 compositor: marco driver: nouveau,nvidia  
   unloaded: fbdev,modesetting,vesa alternate: nv resolution: 1024x768~76Hz  
   s-dpi: 96  
   OpenGL: renderer: llvmpipe (LLVM 9.0.1 256 bits) v: 3.3 Mesa 19.3.4  
   compat-v: 3.1 direct render: Yes  

mike@localhost:~> su
Password: 
localhost:/home/mike # lsmod | grep -E "nvidia|nouveau"
localhost:/home/mike # sudo lsmod | grep -E "nvidia|nouveau"
localhost:/home/mike # 

The third output, please give a hint, how to perform it better?

Neither the nouveau nor the nvidia kernel driver are engaged, so you are left with the basic framebuffer (large icons, large text etc.).

mike@localhost:~> su
Password: 
localhost:/home/mike # lsmod | grep -E "nvidia|nouveau"
localhost:/home/mike # sudo lsmod | grep -E "nvidia|nouveau"
localhost:/home/mike # 

Confirming that neither nouveau nor nvidia kernel modules are engaged.

The third output, please give a hint, how to perform it better?

This is not needed, the nouveau kernel module didn’t load, so there is a “blacklist nouveau” somewhere.
So we are left with the problem of why the nvidia module didn’t load.
Please post the result of:

uname -r

just to confirm what kernel you are actually running.
Then please open a console (CTRL+ALT+F1 or F2-8 if F1 is already taken), login as root and issue:

modprobe nvidia

and post here any errors the system gives.

The first point is:


mike@localhost:~> uname -r
5.3.18-lp152.26-default

Please wait a bit until I perform the second one

as root: modprobe nvidia:
modprobe: ERROR: could not insert ‘nvidia’: Operation not permitted

Have a look at what is really installed in yor system:

zypper se -i -s nvidia kernel gcc make

mike@localhost:~> zypper se -i -s nvidia kernel gcc make
Loading repository data...
Reading installed packages...

S  | Name                      | Type    | Version                            | Arch   | Repository
---+---------------------------+---------+------------------------------------+--------+-----------------------
i+ | automake                  | package | 1.15.1-lp152.4.107                 | noarch | Main Repository
i+ | gcc                       | package | 7-lp152.4.114                      | x86_64 | Main Repository
i+ | gcc7                      | package | 7.5.0+r278197-lp152.2.46           | x86_64 | Main Repository
i+ | kernel-default            | package | 5.3.18-lp152.26.2                  | x86_64 | Main Update Repository
i+ | kernel-default-devel      | package | 5.3.18-lp152.26.2                  | x86_64 | Main Update Repository
i+ | kernel-devel              | package | 5.3.18-lp152.26.2                  | noarch | Main Update Repository
i+ | kernel-firmware           | package | 20200107-lp152.1.1                 | noarch | Main Repository
i+ | kernel-macros             | package | 5.3.18-lp152.26.2                  | noarch | Main Update Repository
i+ | libgcc_s1                 | package | 9.3.1+git1296-lp152.2.3.1          | x86_64 | Main Update Repository
i+ | libpagemaker-0_0-0        | package | 0.0.4-lp152.3.7                    | x86_64 | Main Repository
i+ | libstdc++6-devel-gcc7     | package | 7.5.0+r278197-lp152.2.46           | x86_64 | Main Repository
i+ | make                      | package | 4.2.1-lp152.8.110                  | x86_64 | Main Repository
i+ | make-lang                 | package | 4.2.1-lp152.8.110                  | noarch | Main Repository
i  | nvidia-computeG05         | package | 450.57-lp152.35.1                  | x86_64 | nvidia
i  | nvidia-gfxG05-kmp-default | package | 450.57_k5.3.18_lp152.19-lp152.35.1 | x86_64 | nvidia
i  | nvidia-glG05              | package | 450.57-lp152.35.1                  | x86_64 | nvidia
i+ | purge-kernels-service     | package | 0-lp152.4.1                        | noarch | Main Repository
i+ | x11-video-nvidiaG05       | package | 450.57-lp152.35.1                  | x86_64 | nvidia
mike@localhost:~>

Installed packages seem OK, but for some reason the nvidia kernel module didn’t build or is not where the system expects to find it.
Please check as superuser:

modinfo nvidia | grep filename

localhost:/home/mike # modinfo nvidia | grep filename
filename: /lib/modules/5.3.18-lp152.26-default/weak-updates/updates/nvidia.ko
localhost:/home/mike #

Ok, so the module is where it is expected to be, but it doesn’t engage at boot and you can’t even modprobe it…
That’s beyond me… unless you are using secure boot perhaps…

I don’t think I use secure boot, just regular boot, as far as I understand…thank you for trying to help though

# inxi -SGIxxza
System:    Kernel: 5.3.18-lp152.20.7-default x86_64 bits: 64 compiler: gcc v: 7.5.0
           **parameters**: root=LABEL=s152 noresume mitigations=auto consoleblank=0
           Desktop: KDE 3 info: kicker wm: kwin dm: N/A **Distro: openSUSE Leap 15.2**
Graphics:  Device-1: **NVIDIA** GF119 [NVS 310] vendor: Hewlett-Packard **driver: nouveau** v: kernel bus ID: 01:00.0
           chip ID: 10de:107d
           Display: server: **X.Org 1.20.3 driver: modesetting** unloaded: fbdev,vesa alternate: nouveau,nv,nvidia display ID: :0
           screens: 1
           Screen-1: 0 s-res: 1920x1200 s-dpi: 120 s-size: 406x254mm (16.0x10.0") s-diag: 479mm (18.9")
           Monitor-1: DP-2 res: 1920x1200 hz: 60 dpi: 94 size: 519x324mm (20.4x12.8") diag: 612mm (24.1")
           OpenGL: renderer: llvmpipe (LLVM 9.0.1 128 bits) v: 3.3 Mesa 19.3.4 compat-v: 3.1 direct render: Yes
Info:      ...Shell: Bash inxi: 3.1.04

Please use code tags ( # above the input window) to wrap your commands and their output in order to preserve the output formatting and readability.

Okay, sure. Sorry about that

Hi
In weak-updates… the module needs rebuilding for the current kernel, as in rpms… or is dracut meant to take care of this? Now I know why I keep sticking to the hard way of installing (except SLE) :wink:

The current kmp in the nvidia repo is nvidia-gfxG05-kmp-default-450.57_k5.3.18_lp152.19-lp152.35.1.x86_64 so it is intended to install at /lib/modules/5.3.18-lp152.19-default/updates/
weak-updates should normally work, unless something changed recently (but I think the k-ABI is stable throughout the 15.2 lifetime…).

@blackcatt do you still have the lp152-19 kernel on your system and are you able to boot that kernel, just in case?

Yes lp152-19.2 is in the list of available kernel versions in Yast. Should I change version to this?

Hi
You should be able to reboot and select ‘advanced’ option in grub to boot into that kernel.

If it is already ticked you should find it in the GRUB menu (please scroll down all the options if it does not show on the first screen).
Anyway, if Malcolm is correct, trying to install and boot that kernel is a test I would do. I don’t know if you have to reinstall the nvidia packages after that.

No, there it offers two options: normal boot and recover, both with only the newest kernel (152.26). 152.19 is not ticked in Yast, in this case it would be installed.

So I installed kernel 152.19. Then in Advanced options chose it to boot, then removed driver, rebooted and installed it again. Finally I issued mkinitrd. No result.