Leap 15.2. NVIDIA driver does not work

Hello everyone
My vcard is NVIDIA GF108 [GeForce GT 630]. I’ve installed G04 driver from download.nvidia.com/opensuse/leap/15.2, but it doesn’t work. In NVIDIA Settings I got the following: You do not appear to be using the NVIDIA X driver. Run “nvidia-xconfig” as root.
But this is followed with OS not to load after reboot, just a black screen with a flashing dash in the left upper corner. I didn’t have any problems with my vcard on all previous SUSE releases. Please give me a hint what can be done about that? Thank you in advance

I would suggest making sure your system is all up to date esp. kernel wise and switch to the G05 driver since your card supports this one. I would also delete the /etc/X11/xorg.conf file created by running the nvidia-xconfig command, this should not be needed. You also need to ensure the nouveau driver isn’t present in the output from lsmod.

Malcolm, thank you for the response.
I no doubt have my OS up-to-date. Then, on previous SUSE releases I used GO4, moreover this driver version was suggested automatically via Nvidia repo now. Do you really think I should try GO5?

Either will (well should) work, but later driver will have additional features/fixes.

Have just tried G05. Even worse, in it’s own way. Meaning after installation, NVIDIA Settings window can’t be opened at all. With G04 I could open the Settings window at least. Fortunately removed G05 back.

Then something up with your process of installation… there is no tweaking to do, install and go… are you sure there is no configuration changes down in /etc/X11? Is the nouveau driver blacklisted? Have you rebuild initrd to ensure the nouveau driver is gone?


Are you running Wayland perhaps? What desktop environment?

I use the hard way… https://en.opensuse.org/SDB:NVIDIA_the_hard_way


Screenshot from 2020-07-21 15-26-58.png

Malcolm I have a freshly-installed Leap 15.2, with Mate environment. I guess you could take it as Gnome. While the OS was being installed, I chose “Disagree” with adding nouveau driver so it’s not installed now and my OS is actually working without any driver at all.
All what I’ve done I added nvidia repo and installed the suggested driver, I haven’t corrected anything in Xorg or whatever else. As soon as I’m not much into the stuff./home/mike/Desktop/1.jpg

The image didn’t upload :wink: It is likely run the DXX driver, if you install inxi and post the output from;

inxi -SGxxz

mike@localhost:~> inxi -SGxxz
  Kernel: 5.3.18-lp152.26-default x86_64 bits: 64 compiler: gcc v: 7.5.0 
  Desktop: MATE 1.24.0 wm: marco dm: LightDM Distro: openSUSE Leap 15.2 
  Device-1: NVIDIA GF108 [GeForce GT 630] vendor: ZOTAC driver: nouveau 
  v: kernel bus ID: 01:00.0 chip ID: 10de:0f00 
  Display: x11 server: X.Org 1.20.3 compositor: marco driver: nouveau 
  unloaded: fbdev,modesetting,vesa alternate: nv,nvidia 
  resolution: 1680x1050~60Hz s-dpi: 96 
  OpenGL: renderer: llvmpipe (LLVM 9.0.1 256 bits) v: 3.3 Mesa 19.3.4 
  compat-v: 3.1 direct render: Yes

So it is using the nouveau driver… :wink: What do you want to do?

Interesting…I’m pretty sure I’ve refused nouveau when was installing OS. What do I want? In case it’s actually set on, I’d like to replace it with NVIDIA but don’t know how.

Interesting…I was pretty sure I’d refused nouveau when was installing OS. In case it’s actually set on, I’d like to replace it with NVIDIA but don’t know how.

I want to replace it with NVIDIA. I can’t understand why nouveau turned out to be installed…I refused it when was installing OS

Follow the guide here: https://en.opensuse.org/SDB:NVIDIA_drivers

One thing I would suggest is install via the TTY (Console: press ctrl+alt+F1) with zypper and be root user (don’t use sudo), are you using wicked or NetworkManager? Then I would suggest just making sure that there is a file in /etc/modprobe.d that blacklist nouveau driver, then also run the command mkinitrd as root user and reboot (systemctl reboot).

I use Network manager. Will try installation tomorrow (it’s late here). Thank you:)

There are two competent FOSS drivers to choose from for X for NVidia GPUs. https://forums.opensuse.org/showthread.php/541438-AMD-Intel-amp-NVidia-X-graphics-driver-primer explains. Because of the default DDX to fallback to, even if you did refuse the Nouveau DDX, X should have been running on the default DDX.

Malcolm I’ve tried to install. I used terminal as su, not console. After installation I checked modprobe.d folder, there are many blacklist files there but I didn’t see any consisting exactly “nouveau” in its name. Also, while installation there were few warnings, here is it:

                       rm: cannot remove '/lib/modules/5.3.18-lp152.26-default/updates/nvidia*.ko': No such file or directory
depmod: WARNING: could not open modules.order at /lib/modules/5.3.18-lp152.19-default: No such file or directory
depmod: WARNING: could not open modules.builtin at /lib/modules/5.3.18-lp152.19-default: No such file or directory
Generating a RSA private key
writing new private key to '/tmp/MOK.priv.TsMzoW'
update-alternatives: using /usr/lib/nvidia/alternate-install-present-default to provide /usr/lib/nvidia/alternate-install-present (alternate-install-present) in auto mode
Modprobe blacklist files have been created at /etc/modprobe.d to prevent Nouveau from loading. This can be reverted by deleting /etc/modprobe.d/nvidia-*.conf.
*** Reboot your computer and verify that the NVIDIA graphics driver can be loaded. ***
grep: /etc/sysconfig/kernel: No such file or directory

but maybe it’s okay, I don’t know. Do you think I should run mkinitrd now?

Stepping in because Malcolm is likely sleeping now due to his timezone.
You should see a “blacklist nouveau” line in a /etc/modprobe.d/nvidia-*.conf file just installed.
And YES, I think it’s time to issue mkinitrd (or better still “dracut --hostonly --force”) and then reboot.

Have done. No, driver doesn’t work and I can’t access Nvidia-Settings window (it doesn’t open). Got huge icons and text on my screen.

You are apparently using software rendering…
Still the same output for:

inxi -SGxxz

and what is the output for:

sudo lsmod | grep -E "nvidia|nouveau"

If nouveau is still in use (the kernel driver, what you refused to install is the X11 driver…) can you boot adding to the kernel boot line the following option?