Latest updates killed my GUI (4th week of Jan'23) - Kernel 6.8.1?

Not super skilled, so bear with me. Have been running Leap for years, but got tired of the full upgrades required so I switched to Tumbleweed in December (maybe a bad choice…). So here it is 2 months later and my laptop will not boot into GUI mode after the last batch of updates that came down. I get “Localhost login” and that’s it. I did manage to roll back with help from the internet, so I am up and running - for now.
So what’s the next step? Never update again?

I know it is probably the display driver. I am at kernel and tumbleweed 20230119. I know when it rolled to 6.8.1 is when it stopped working. I get thru the boot and select an option screen, then when the GUI should load I get a gray screen, 3 green square dots in the middle that start to cycle like it’s thinking, and then the machine shuts off. I think it puts it into sleep or hibernate mode. I press the power button again, and I managed to get to the “LocalHost Login”.

Laptop is a Lenovo T410 (yeah, it’s old).

1 Like

Sorry - updated to 6.1.8 kernel…

The reason is not the kernel, but a problem with the package nvidia-open-gfxG06-kmp-default. It gets wrongly pulled in and you need to remove it to be able to start your system again.

If you have done your system upgrade via console, you would have seen that there was a file conflict whilst this wrong package got pulled in…
So upgrade your system via console and refuse to install the open driver when you get asked what to do for the file conflict…

If I follow you correctly, you think that driver nvidia-open-gfxG06-kmp-default is the problem and the only way to get rid of it is an upgrade via console rather than yast?
So, OK, I switched into console and ran zypper dup. It took quite a while, there were no conflicts that required intervention, and after reboot - same problem - no GUI. So I had to rollback yet again.
The only file being installed nvidia-wise was: nvidia-open-driver-G06-signed-kmp-default-525.85.05_k6.1.8_1-2.1x86_64

Tumbleweed is a phenomenal operating system, I run it on 4 computers trouble free. That said, if I had Nvidia graphics, I would be careful about kernel updates. New kernels are often not compatible immediately with the proprietary nvidia blobs. It may take a few days or longer for the nvidia driver to be properly ported to the new kernel. You could of course try re-installing the nvidia driver it may or may not help. If it doesn’t help, you can roll back to the previous kernel until the nvidia driver catches up. You should also have X11 nvidia or something similar installed.

1 Like

@sheydayi they are incorrect, unless you want to run the open version of the driver from the oss repo, as opposed to the nvidia repo on and you have a Turing arch or greater gpu. Uninstall add locks and force the re-install of the nvidia repo versions.

1 Like

My laptop is really old, so it looks like all those drivers are for newer GPUs. I looked at that nvidia-open-driver-G06-signed-kmp-default-525.85.05_k6.1.8_1-2.1x86_64 file in YAST, and it is NOT installed yet in my working version (kernel 6.1.7) but is installed during the update to 6.1.8. Maybe that is the culprit.
I don’t know a lot about all these video drivers, but I think I have: xf86-video-nouveau - Accelerated Open Source driver for nVidia cards, installed. I also looked at the git for that nvidia driver and my card (NVS 3100M) does not appear on the supported hardware list…

G06 is likely not the correct driver as the 3100m is a legacy device. You might try the G05 or G04 if it exists

1 Like

I just added the nividia repo to one of my systems, the G04 driver is there, that is what I would use.

1 Like

@sheydayi yes that went when the G03 series was alive… so very likely nouveau (or maybe modesetting) need to see the inxi -Gxx output

In your case you do need to add locks to avoid those getting installed…

Did any of you actually read what i wrote in my first comment? (Except Malcom who undestood the case…)

The latest Tumbleweed snapshot pulls in a wrong nvidia-open-driver-G06-signed-kmp-default, even if you are using the proprietary driver or a the G05 or G04 series. This is because of a packaging problem of the open driver, which claims to be compatible with to much graphic cards even if that is not the case. Not all models are affected but many old ones. I had two machines with older cards where zypper dup tried to pull the open driver. My high end machines with actual graphic cards where not affected.

That is the reason why i linked the bugreport.

The solution is to remove the wrong nvidia-open-driver-G06-signed-kmp-default (or be more carefull whilst upgrading to the latest snapshot). After you have removed the wrong driver the system starts up normally.
When you have already the wrong driver installed, boot your system until you reach the prompt “Local Host Login”. Login as normal user (your username and password). Do a sudo zypper remove nvidia-open-driver-G06-signed-kmp-default

Thanks, now it is starting to make sense. I guess it is a learning curve for me.
That driver was not installed - but got installed during the update. Then my system was dead. I guess in hindsight I may have been able to stumble through console yast and uninstall the driver manually after the upgrade. After the rollback I didn’t find the nvidia-open driver installed, any version, so I was confused thinking it may not be the real cause…
Thanks for all the help.

And it doesn’t really help to confuse other users with “tips” if you don’t even have Nvidias in your machine park. The topic opener has a completely different problem which is not caused by “the Nvidia driver needs to catch up to the kernel”…nonsense.

When you do a rollback, you boot into a snapshot where the update was never applied. So that is the reason why you can’t see the wrong driver in your old snapshot.

I saw this nvidia that was to be installed in tumbleweed. I was surprised because I am using the run file.
I did the zypper dup anyway and thinking of asking about it here in the forum when I saw this thread.
After the zypper dup I rebooted and install the .run driver when done login to tumbleweed and deleted the installed nvidia open package.

And blacklist it so it does not get reinstalled on the next update.

Faced with this issue, I ran zypper dup but that does not give me the option to skip the nvidia open package. I had to go into Yast, find that package (which is not installed on my system anyway), and mark it as “taboo.” Then I was able to run zypper dup which did not then try to install the nvidia package, and now it appears that all is well.
But that brings up some questions about the best way to update Tumbleweed. I usually just rely on the Task Manager update option, but that does not allow me to choose which packages to update: I can uncheck “select all,” but then as soon as I check any package for update, it rechecks “select all” and I can’t uncheck anything. On the other hand, if I go into Yast and select “Online Update,” no updates appear at all.
Usually, when using the Task Manager option, I can work out conflicts that arise, fix them in Yast, and proceed. But in this case, I just had a broken system and couldn’t figure out what the issue was. Thank heavens for this forum and the rollback feature, otherwise, my goose would have been well cooked!

I got the notification whilst zypper dup that a file from the installed nvidia-gfxG04-kmp-default conflicts with the to be installed nvidia-open-driver-G06-signed-kmp-default
As i know that the graphic card at this particular machine is not supported by the G06 series, i hit “cancel” and remembered that i saw a bug regarding the open driver. After locking the open driver and restart of zypper dup, all went fine.

1 Like

Yup, that’s great if you browse bug reports, but the rest of us just get hit with broken systems :wink:

And I should add, given my experience with social media and email, that that is certainly NOT intended as a snide remark, again expressing gratitude for rollback and people like you who are able to figure out the problem! Being retired, I can spend a day resolving issues like this, but for others I have to wonder about the impact.