Latest updates killed my GUI (4th week of Jan'23) - Kernel 6.8.1?

TW requires good technical knowledge and awareness of updates. Leap is a better option for those that can’t put such effort in. (I have always preferred the relative stability of Leap for trouble-free day-to-day use.)

Some pertinent comments from experienced users:


Those are all valid points, of course, but it might be nice to put that on the website before people install it. Currently, it only says “Tumbleweed – Get the newest Linux packages with our rolling release. Fast! Integrated! Stabilized! Tested!” It’s not until you get to the second “learn more” option on the installation page that there are any warnings about who should not use Tumbleweed or what can happen. People will inevitably just want the newest/latest without realizing what they are getting into. Why use those typical Wall Street marketing techniques here?

It’s explained on the page I linked to…

"Who should use openSUSE Leap instead of Tumbleweed?

While every effort is made to build them, at this point there is no guarantee to have all additional modules available in openSUSE Tumbleweed like for example, VMware or VirtualBox. And while the Packman Tumbleweed Essential repository attempts to deliver them there is no guarantee they will always succeed due to the incompatibilities with the quickly advancing Linux kernel. The problems with proprietary graphics drivers are similar and there is no guarantee they will work tomorrow, even if they do today. If you don’t know how to compile your own additional kernel modules and you don’t wish to learn or keep a very close eye on what is being updated, please don’t use Tumbleweed."

IMHO, there will always be those who choose to install it (regardless of any caveats), when perhaps they are not ready to deal with any regressions it may present following its constant rolling updates. Even though I’ve been using Linux for over 20 years, along with experience using it in the workplace, TW is not a practical option for me currently. I’m not sure using the ‘latest and greatest’ rolling-release is of benefit to most ordinary desktop users either, (when that is often the sole reason for making the choice).

1 Like

I just ran zypper -v dup -d on the following:

# pinxi -GSaz --vs --zl --hostname
pinxi 3.3.23-05 (2022-11-07)
  Host: p5bse Kernel: 5.19.13-1-default arch: x86_64 bits: 64 compiler: gcc
    v: 12.2.1 parameters: root=LABEL= ipv6.disable=1 net.ifnames=0
    noresume mitigations=auto consoleblank=0 vga=791 video=DP-2:1440x900@60
    video=DP-1:1920x1080@60 5
  Desktop: KDE v: 3.5.10 tk: Qt v: 3.3.8c info: kicker wm: kwin vt: 7 dm:
    1: KDM 2: XDM Distro: openSUSE Tumbleweed 20221129
  Device-1: NVIDIA GF119 [NVS 310] vendor: Hewlett-Packard driver: nouveau
    v: kernel non-free: series: 390.xx+ status: legacy-active (EOL~late 2022)
    arch: Fermi code: GF1xx process: 40/28nm built: 2010-16 pcie: gen: 1
    speed: 2.5 GT/s lanes: 16 ports: active: DP-1,DP-2 empty: none
    bus-ID: 01:00.0 chip-ID: 10de:107d class-ID: 0300 temp: 50.0 C
  Display: x11 server: X.Org v: 21.1.4 driver: X: loaded: modesetting
    unloaded: fbdev,vesa alternate: nouveau,nv,nvidia dri: nouveau gpu: nouveau

No kmp or nvidia was listed among new packages to be installed. Dup was total success, no issues.

Is there a link to similar issues on LEAP 15.4? Recent updates broke my GUI too, also using Nvidia graphics. If it is not related, I’ll open a new discussion. Currently I only get GUI if I add “nomodeset” to GRUB:

S | Name | Type | Version | Arch | Repository
i | kernel-firmware-nvidia | package | 20220509-150400.4.13.1 | noarch | Update repository with updates from SUSE Linux Enterprise 15
i | nvidia-compute-G06 | package | 525.85.05-lp154.4.1 | x86_64 | NVIDIA
i | nvidia-compute-G06-32bit | package | 525.85.05-lp154.4.1 | x86_64 | NVIDIA
i+ | nvidia-compute-utils-G06 | package | 525.85.05-lp154.4.1 | x86_64 | NVIDIA
i+ | nvidia-driver-G06-kmp-default | package | 525.85.05_k5.14.21_150400.22-lp154.4.1 | x86_64 | NVIDIA
i | nvidia-gl-G06 | package | 525.85.05-lp154.4.1 | x86_64 | NVIDIA
i | nvidia-gl-G06-32bit | package | 525.85.05-lp154.4.1 | x86_64 | NVIDIA
i+ | nvidia-utils-G06 | package | 525.85.05-lp154.4.1 | x86_64 | NVIDIA
i | nvidia-video-G06 | package | 525.85.05-lp154.4.1 | x86_64 | NVIDIA
i | nvidia-video-G06-32bit | package | 525.85.05-lp154.4.1 | x86_64 | NVIDIA

Yes, you are best advised to start a new topic for your issue.

Hit this same problem this morning, even days after this thread was started which I did see, I was “in a hurry” and ran the zypper dup -l for 290 ± packages. It stalled on the “G06” package and that’s when I realized I was “in trouble” . . . . I wasn’t worried about it before because I use “default” driver rather than proprietary for my nvidia card.

But, on reboot it went to TTY. Took me a minute to remember which name TW uses to log in and reboot . . . regressed to 6.1.7 and same problem. Had to reboot a number of times, finally choosing 6.1.8 (recovery) and that actually “worked” to get to the GUI, but only on a one time basis.

Found my way back to the forum, found this thread, read a couple posts, saw the OP’s “I cheked Yast and it wasn’t there,” but in my case it was . . . . So I tried to “delete” it in Yast, and that was “interesting” . . . in that the operation seemed to continue . . . far longer than it should have via console . . . . Went on for quite awhile.

Tried the console after reading Hui’s comments about “removing” the package . . . seems like it finally got done. Questioin is, why did this package wipe the GUI even though I’m using “default” video driver??

Because the open driver falsly claims to be compatible with your hardware but isn’t in reality.

1 Like

@hui well that does depend on the users GPU… I can run the open driver here, but don’t because it’s not compatible with my Tesla P4, if it was T4 it would…

In my case an ancient GTX 780???

What is “odd” is that, as mentioned, I tried to remove the G06 package in Yast and the cursor was spinning and the cig bar was staying right at the beginning, “nothing” appeared to be happening, tried to cancel out of it, failed.

Went to console, ran Hui’s command and that started off, but then some “error” . . . I figured it had already been removed?? On reboot, went to the GUI, so all is well??

Checked Yast for the package to try to “lock” or “prevent” it, and Yast shows it “installed”?? Nothing in the parentheses.

Ran lsmod and “video” shows nouveau?? Over on the factory list-serve a number of threads saying this package “blacklists nouveau”?? Somehow my system has found a way to both keep G06 AND unblacklist nouveau to provide running GUI???

Tried to “remove” the package:

The following package is going to be REMOVED:

1 package to remove.
After the operation, 4.2 MiB will be freed.
Continue? [y/n/v/...? shows all options] (y): y
warning: file updates: remove failed: No such file or directory
warning: file 50-nvidia-default.conf: remove failed: No such file or directory
warning: file 60-nvidia-default.conf: remove failed: No such file or directory

Cursor still blinking.

Did you try striking ENTER or switching to a different vtty? If using vtty1, and you have logged in on it immediately after a boot completes, there may come a delayed line feed to wipe out one line of what you should be seeing. Vtty1 is mildly peculiar compared to 2-6. They don’t have the same quirks.


Thanks for the thought . . . at that time I was in the regular GUI console . . . . After I posted that data, I just left it blinking and maybe it took 20 to 25 mins to come back as “done” . . . . So, it did “get done” . . . albeit very slowly. Yesterday I had tried to do the same command and after 15 mins I aborted out of it, but that had showed similar errors about “we can’t remove this package,” which I believed. Today I just let it run . . . and it was “successful.” Did not have time to confirm with YaST to see what the status is on it.

I then added the package to “lock” . . . so hopefully if zypper brings it in again it won’t get installed???

A post was split to a new topic: ALP replacing Leap?