Kernel 6.2 AMD GPU boot stuck because of iommu

I just updated to 6.2 tumbleweed kernel.
Yes everything, include working AMD GPU, worked on previous kernel/opensuse.

Boot always stuck on first second of boot - because Ryzen CPU with integrated AMD GPU.
I use Ryzen 3 3200, Vega 8 integrated GPU

kernel: [drm] amdgpu kernel modesetting enabled.
kernel: amdgpu: Topology: Add APU node [0x0:0x0]
kernel: amdgpu 0000:07:00.0: enabling device (0006 -> 0007)
kernel: [drm] initializing kernel modesetting (RAVEN 0x1002:0x15D8 0x1002:0x15D8 0xC9).
kernel: [drm] register mmio base: 0xFC500000
kernel: [drm] register mmio size: 524288
kernel: [drm] add ip block number 0 <soc15_common>
kernel: [drm] add ip block number 1 <gmc_v9_0>
kernel: [drm] add ip block number 2 <vega10_ih>
kernel: [drm] add ip block number 3 <psp>
kernel: [drm] add ip block number 4 <powerplay>
kernel: [drm] add ip block number 5 <dm>
kernel: [drm] add ip block number 6 <gfx_v9_0>
kernel: [drm] add ip block number 7 <sdma_v4_0>
kernel: [drm] add ip block number 8 <vcn_v1_0>
kernel: amdgpu 0000:07:00.0: amdgpu: Fetched VBIOS from VFCT
kernel: amdgpu: ATOM BIOS: 113-PICASSO-118
<stuck here, no disk activity it just stuck I waited for 5 mins three times>

Solution - turn off IOMMU in BIOS/UEFI settings

Yes you need second GPU - I use discrete Nvidia, and it works with 6.2 kernel, 525 Nvidia driver.
Boot also works but without IOMMU AMD GPU will not work
But boot not stuck so it will boot to text-terminal mode when AMD GPU used, and you can install Nvidia driver from there like I did.

Kernel show this errors because of IOMMU, but continue boot, so it works:

kernel: kfd kfd: amdgpu: error getting iommu info. is the iommu enabled?
kernel: kfd kfd: amdgpu: Error initializing iommuv2
kernel: kfd kfd: amdgpu: device 1002:15d8 NOT added due to errors

screenshot from other thread, look like there Intel integrated - No boot with kernel 6.2 - #13 by suse_rasputin
look similar to what I saw on AMD - also stuck around 4%

and look like this Bug 1208938 – Boot fails with kernel 6.2.1-1-default
is same what I have

my solution with turning off IOMMU in bios works
so this my thread have value for people with similar problem

This bug Fixed in kernel 6.2.4-1-default