I have needed with openSUSE Leap 15.4 Installation Issue

Hey guys :smiling_face_with_three_hearts:

I have been using openSUSE for a while now, but I’m hitting a wall trying to install Leap 15.4. Here’s the deal:

I boot from the USB stick, everything seems smooth until I get to partitioning. The installer doesn’t see my SSD properly. It shows the whole drive as empty space, instead of my existing partitions. Now, I gotta keep my current setup – dual booting with Windows 10 – and all that sweet data on the SSD safe.

Here’s my rig for reference: :star_struck:

To fix this, I’ve tried:

  • Double-checking the install media for any issues.
  • Tweaking BIOS settings for SATA mode (tried both AHCI and RAID).
  • Booting into a live session – the SSD shows up perfectly there, with all partitions visible.
  • But no dice, the installer is still blind to my existing partitions. Anyone else faced something similar? Any tips on how to move forward would be a lifesaver!

Thanks a bunch in advance for the assist!

openSUSE Leap 15.4 is EOL since end of 2023. You need to use the actual Leap 15.5 as it also provides support for newer hardware…

Booting into a live session of what exactly? Show

fdisk -l
blkid 

from the live system.