How to remove KDE Plasma6 as far as possible

how can I remove as much as possible of KDE/Plasma6 ?
is there any config files that I can get rid off to get a clean plasma6 on Wayland?

Firstly: I have been reading plenty of entries on this topic, but the freshest one dates back to 2018.

Secondly (and maybe more importantly): My purpose is not to get rid of KDE. My purpose is to reinstall it.

My KDE broke. I was unable to get it to log in on Wayland. I am not sure if it ever worked, as I noticed that I was on X11 just because I saw some X11 packages showing up while doing an update.

This is a relatively fresh installation: Installed from DVD and network, and just finished getting all the stuff I need (basically VSCode and little more).

I am now running on Gnome Shell + Wayland, which runs nicely, but it feels a tad like brushing against the hair.

From what I have gathered, the problem is a sort of bug in Plasma6 that makes if fail to start with some unsupported widgets (note: I only had 1 native plasma6 widget installed) and in some cases because of the NVIDIA driver (not my case, Dell Latitude 7420). I do suspect that the problem is rather a config file.

Long ago (KDE2 -3) , it was possible to just remove a config file (.kde) to force KDE to rewrite it, which was our standard way of getting our desktop back.

My idea is thus, to remove all the software that I can and eventually all the configs that are possible to remove without affecting Gnome / IceWM (as I need these as fallback).

Thank you so much for any suggestions. I will continue testing ideas and if I come up with anything, I will post it here.

Enric

In this situation, reinstalling the desktop environment is really not needed (at least at the system level). Instead, you can create a new user environment and then log in as that user to see if that works.

For a ‘broken’ user account, you could remove the key config files via a VT…

rm -rf ~/.config/plasma* ~/.config/kde* ~/.config/kwin*

That might be sufficient to restore a ‘default’ working session again.

This may be of value to you:

Already tried that.
No luck.
:frowning:

I did resolve the issue. Yet, I am still trying to figure out what the root cause was:

My installation was fresh from scratch and I hadn’t had time to fumble around too much (seemingly enough to break some stuff, LOL).

Fortunately, Yast2 offered a good workaround. Yast2 was, BTW, the reason why I chose openSUSE Tumbleweed instead of Debian Bookworm. This is my production machine and I wanted a rolling update. I got used to Yast a long time ago so that I considered it a big plus.
(OK, and Plasma6, which was for me the main point of sale, I’m a sucker for all things KDE)

What I did was brute-forcing it all: Open Yast2 software, search for “Plasma6”, go wild hitting the minus key on everything, marking it for deinstallation, and repeat with the term “KDE”.

Once it was done, I repeated it the other way around. The pop-ups warning about dependency issues were quite handy to avoid getting tangled with different versions of the same package (which is usually a source of headaches in most other distros).

I am writing this from my beloved Plasma6 :slight_smile:
I didn’t need to do anything with the configs.

TL;DR:

  1. Open Yast Software Manager
  2. Install GDM and Gnome to have a fallback
  3. Remove SDDM
  4. Reboot (you can just shut down Wayland / X11, but that’s easier)
  5. In Gnome open Yast Software Manager
  6. Search Plasma6
  7. Go wild making everything for removal
  8. Rinse and repeat for “KDE”
  9. Wait for completion
  10. repeat 6 - 9 but this time installing

Notes:

  • The display manager will be handled automatically, but if there were any issues, just open Yast and search for “Alternatives”
  • Yast looks pretty wonky in Gnome. The fonts don’t render correctly. I know there must be a setting somewhere, but in this scenario, Gnome is used solely as a temporary springboard back to proper Plasma.

Then not just an incompatible widget, theme etc (a more common situation). Having to reinstall the entire plasma environment seems a bit extreme. Reads more like something was missing or not upgraded (broken). Anyway, good to read that it is back working for you.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.