Google chrome is not working in Wayland after updating

I updated this morning the OS tumbleweed with regular updates and now I am not able to use google chrome. No thumbnail showing up neither any video is playing. Google Chat also broken icon and no images.

Thanks for you help if some one resolved this issue.


Same thing happens to me

Please can you be more precise?:
How did you install Google Chrome? Flatpak? Real Chrome repo? How?
What thumbnail is where not showing?
What videos are not playing? Do you use packman and did you perform a proper vendor switch?

The same question applies for Google Chat…

Did you try to use a X session?

This answer was written from Google Chrome 113.0.5672.92 installed via the official Google Chrome repos and openSUSE Tumbleweed 20230513-0

Problem started after updating this morning. I download the rpm package from google site. please see the attached screenshot.

The problem does not lie in Google Chrome, but probably in the MESA driver update. To fix it, you need to do a rollback to version before update.

Interestingly in chromium browser no issue. please see the attached screenshot. Not sure how to roll back the MESA driver. Any direction will be highly appreciate.


Had the exact same problem with my Chrome after yesterday’s Tumbleweed update. No need to rollback in my case.

Just went to Settings in Chrome and selected Reset Settings. Then went to the appearance tab and re-selected GTK as my theme. Everything went back to normal.

For the record, I’m on Xfce (XWindows) and my Chrome is from the Chrome repo, originally installed via RPM.

Same trick works for KDE Plasma Wayland.
Thank you

Same issue, but I noticed ALL Chrome based browsers show this issue, for me … Chromium, Chrome (stable), Brave … oddly, Opera renders fine.

(With a couple of odd exceptions) I always update a laptop first, reboot, and briefly check for any issues. All was fine after update (even Chrome based browsers), so updated other laptop … all fine.

Then I updated the 1st desktop. Chrome browsers fail a proper render. I booted the second desktop … same issue.

HOWEVER … Chrome Beta works on the primary desktop.

Using the Slate theme as default … switching themes, or not using one, doesn’t change. “Use GTK” or not, doesn’t change. I use “Auto Dark Mode for Web Contents” found in “chrome://flags” - altering that doesn’t change the issue.

If I’m bored, I might further investigate …

But yea, if you rename the “chrome stable” subdirectory found in the “/home/username/.config” subdirectory, that’ll fix it, but doing that is like “starting Chrome for the first time after installing”.

I’m not convinced it’s Mesa … I’ve looked back in Yast at everything related to “Mesa”, and the last update for me, is 22 Apr 2023 for some packages, and Mar for other packages.

Do you use NVIDA driver?? if so parts of mesa are replaced by it. And in any case Wayland does not play well with Plasma +NVIDA

I am using AMD Radeon graphic card


My desktops have NVIDIA cards, but I don’t use the dedicated drivers … and I stay away from Wayland - it’s still too immature.

For the laptop … it has a Mesa Graphics 620 (it’s the machine that is rendering no problems) … Dell Latitude 5500 laptop.

I just finished a zypper dup … an update for Chrome Stable was included … the rendering issue everyone was experiencing is fixed - at least it is on my desktops :+1:

Sidenote: Chrome Beta continued to render properly, while Stable was broken for 2-3 days.
The laptops which have Stable continued to render fine (uses a Mesa Graphics 620)

So, this just happened to me AGAIN yesterday. Once again, the full Chrome settings reset fixed it. Mesa was what was upgraded, so I would say that this is tied to that package upgrade.

1 Like

Agreed !!

The problem cropped up again for me.

Chrome Stable and Brave are affected for me.

Chrome Beta, Chromium, and Opera render fine.

I don’t do the “Settings reset” for a couple+ reasons:
a) the “Reset” button isn’t rendered.
b) It’s a pain to re-establish passwords and open tabs, etc
c) I can simply click on Chrome Beta or Unstable, and they work.

However … ALL those browsers work on the laptop which has a Mesa 620 graphic. The desktop, where it doesn’t render properly, uses Nvidia.

I am facing the same issue again. It is painful to reset but still doesn’t work.

Easy fix … use Chrome Beta in the meantime until the next fix :+1:

Do you have experience with GNOME DE as compare to KDE DE?