Getting sound to work MacBook Pro 3,1 (early Core 2 Duo), SUSE 11.2 64-bit

With some guidance from the post here:
Macbook Core Duo/OpenSuse 11.2 - No Sound Headphone Port - openSUSE Forums
I was able to get the sound working on my 17" MacBook Pro 3,1 running SUSE 11.2 x86_64.

I ran the script:
saved the output locally, and took a look at how my sound card was identified in the output file, which was saved as a file named something like:
in my /tmp directory.

The sound card was identified as follows:
Card hw:0 ‘Intel’/‘HDA Intel at 0xdb500000 irq 20’
Mixer name : ‘Realtek ALC889A’
Components : ‘HDA:10ec0885,106b2e00,00100103’
Controls : 32
Simple ctrls : 17

Using that information I took a look at the file:
to find the correct abbreviation to represent my sound card/computer, looking for “889”. A few MacBook Pros are listed toward the top of the list for the cards ALC882/883/885/888/889, but the one that worked was nearly at the end –
mb31 MacBook 3,1

I then edited both the:
files as root (probably only need to edit one, but I have not gone back and tried deleting the content from one and then the other to determine for sure if only one is being referenced) so that they contained:
options snd-hda-intel model=mb31
options snd slots=snd-hda-intel

u1Nb.2frKzjmhZt4:82801H (ICH8 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel
Originally the 50-sound.conf was empty, but I copied the contents of /etc/modprobe.d/50-sound.conf.YaST2save into it, and added the “options snd-hda-intel model=mb31” line to both.

As described in the link above, I tried a few different values in place of “mb31” before hitting upon the right one, restarting the ALSA sound service between each one by issuing the command:
rcalsasound restart
as root and then trying the sound.

Within the Sound preference panel of the Control Center (on the Gnome desktop) the hardware ended up being listed as “Analog Stereo Duplex”, and I believe this was set automatically once I hit upon the correct abbreviation for my sound card. Just mention this because I was wondering whether I needed to change this or not, and whether the setting would impact whether I would be able to know when I had found the correct abbreviation for my sound card - seems as though it did not, because I think I had set it to Digital in/Digital out, and it then set itself to a different value when I hit upon the correct abbreviation.


Congratulations on getting this to work. Thanks for sharing your solution.