Firefox 3.0.10, YouTube no video after first one is played.

Running opneSuSE 11.1 with most recent kernel installed, KDE 3.5 multimedia works in all other cases.

When I follow a link on Youtube after playing a video the the next video is not displayed. The audio plays and the below where the video would be is lacking the “buttons” etc. All I see is a empty white box where the video should be. Is this a Firefox bug? a Linux bug? a openSuSE bug? Can it be fixed?

Run uname -a and post it here.

Linux linux-v5xu #1 SMP 2009-05-26 17:02:05 -0400 x86_64 x86_64 x86_64 GNU/Linux

Since you have 64 bit system i recommend to reinstall the flashplugin
use the native 64 bit plugin from Adobe (never had any problems with it despite “Alpha” status) which you can download using this link, after downloading unpack it somewhere for safekeeping and copy it as root to /usr/lib64/browser-plugins/

If you choose to use the second solution i recommend to uninstall nspluginwrapper and all the flash packages installed in the system.

Flash Player 10 pluging is already installed but “done” anyway.

I know but users were reporting that reinstalling it helped.

Also try the second solution, less problems like the ones you have right now :slight_smile:

The flash plugin you have right now is 32 bit and 64 firefox is using it through the nspluginwrapper.

Ineed it did. Too weird. One more thing to “remember” sigh. Thanks.

You’re always welcome :slight_smile: Have phun!!

Flash is broke good now. All Google sites are wonky and flash doesn’t work at all and I have no “flashplayer” In the multimedia menu.

I uninstalled Flash using YAST2 and copied the flashplayer .so to /usr/lib64/browser-plugins.

I still have a flash plug-in in .mozilla/plugins I see. Do I need to delete that?

YAST2 says KDE 3.5 needs nspluginwrapper. Is there any way around this? I don’t want broken KDE 3.5

trying to undo this left everything broken

On _64 using flash with nsplugunwrapper all from the default repos worked for me.

Well I am back to the default flashplayer install and it’s hit or miss. I can see a YouTube flashplayer video again. What happens after the first video is played is random. I am starting to think this is a YouTube problem and not a Adobe Flashplayer problem. If I select a flash video I have stored locally it plays every time.

I remember how YouTube use to lock up Firefox on me and otehr Linux users too not to far in the past. It could just be Google not considering Linux/FireFox users worth worrying about and making sure their pages work with IE and Microsoft. I just got used to everything working since I switched to openSuSE 11.1 and had forgot how bad my experience was in the past with a old FireFox version and Mandriva 2007 really was.

I have not looked right thru this thread, so sorry if this has been suggested.

Did you try different browsers? Opera, Konqueror, Seamonkey?
Do they behave like FF?

If not - then have you tried a new FF profile?

Opera will not even launch. Konqueror fails to open any YouTube videos. I don’t have Seamonkey.

Sounds like you have issues.

Yea the issue is I installed the software from YSAT2 or it was the default install of openSuSE 11.1 at the original install. So I guess you were trying to be sarcastic and failed.

You miss-interpreted my comment entirely. I was not trying to be sarcastic, rather my comment was meant to suggest you have issues that would appear to be unrelated to the OS specifically but more perhaps your hardware or software configuration.

Why do I say that:
The fact that Opera will not even launch is rather odd (Did you start it in a terminal and see the errors)

Konqueror too not working, must start you thinking, what’s up?

I understand your frustration and apologise if I came over in a negative fashion. We would like to resolve your issue. Can you post tech details on your system, graphics in particular. Your repos( zypper lr --details ).

rpm -qi flash-player nspluginwrapper

Konqueror is fine it just doesn’t work on YouTube flashplayer videos. I am starting to think this is a problem across all Google sites. As I had FireFox and Flash problems with YouTube on my other computer running Mandriva 2008.

Some pretty huge output from those commands I guess I’ll need a place to paste them to.

To be clear I am running KDE 3.5.10 not KDE 4 even though I have KDE 4.0 installed.

Opera launches from the CLI without too much complaint and plays every YouTube Video I throw at it.

Looking for a place to paste this output too.

Output of commands

flamebait@linux-v5xu:~> zypper lr --details

| Alias | Name | Enabled | Refresh | Priority | Type | URI | Service

1 | 11.1 | 11.1 | Yes | Yes | 99 | rpm-md | |
2 | KDE:KDE4:Factory:Desktop | KDE:KDE4:Factory:Desktop | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_11.1 |
3 | KDE:Qt | KDE:Qt | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/Qt/openSUSE_11.1 |
4 | OpenSUSE_11.1-0 | OpenSUSE 11.1-0 | Yes | Yes | 99 | yast2 | hd:///usr/local/src/SU1110.001?device=/dev/disk/by-id/edd-int13_dev81-part1&filesystem=auto |
5 | Packman | Packman repository (openSUSE_11.1) | Yes | No | 99 | rpm-md | Index of /pub/packman/suse/11.1 |
6 | fietze | fietze | Yes | Yes | 99 | rpm-md | Index of /repositories/home:/fietze/openSUSE_11.1 |
7 | google | google | Yes | No | 99 | rpm-md | |
8 | google64 | google64 | Yes | No | 99 | rpm-md | |
9 | hamradio | hamradio | Yes | Yes | 99 | rpm-md | Index of /repositories/hamradio/openSUSE_11.1 |
10 | home:dl8fcl | home:dl8fcl | Yes | Yes | 99 | rpm-md | |
11 | openSUSE:Factory:Contrib | openSUSE:Factory:Contrib | Yes | Yes | 99 | rpm-md | Index of /repositories/openSUSE:/Factory:/Contrib/openSUSE_11.1 |
12 | repo-debug | openSUSE-11.1-Debug | No | Yes | 100 | NONE | Index of /debug/distribution/11.1/repo/oss |
13 | repo-non-oss | openSUSE-11.1-Non-Oss | Yes | Yes | 100 | yast2 | Index of /distribution/11.1/repo/non-oss |
14 | repo-oss | openSUSE-11.1-Oss | Yes | Yes | 100 | yast2 | Index of /distribution/11.1/repo/oss |
15 | repo-source | openSUSE-11.1-Source | No | Yes | 100 | NONE | Index of /source/distribution/11.1/repo/oss |
16 | repo-update | openSUSE-11.1-Update | Yes | Yes | 20 | rpm-md | Index of /update/11.1 |
17 | science | science | Yes | Yes | 99 | rpm-md | Index of /repositories/science/openSUSE_11.1 |
18 | videolan | videolan | No | Yes | 99 | rpm-md |

flamebait@linux-v5xu:~> rpm -qi flash-player nspluginwrapper
Name : flash-player Relocations: (not relocatable)
Version : Vendor: openSUSE
Release : 0.1.1 Build Date: Wed 25 Feb 2009 09:17:18 AM PST
Install Date: Mon 15 Jun 2009 09:34:10 PM PDT Build Host: Super-Pinguine
Group : Productivity/Networking/Web/Browsers Source RPM: flash-player-
Size : 19568820 License: Any commercial
Signature : RSA/8, Wed 25 Feb 2009 09:17:34 AM PST, Key ID b88b2fd43dbdc284
Packager : Submitting Bug Reports - openSUSE
Summary : Adobe Flash PlugIn and standalone Player
Description :
This package contains Adobe’s Flash Plugin for the supported Web
browsers in addition to a standalone flash player application.


Adobe Systems Incorporated

Distribution: openSUSE 11.1
Name : nspluginwrapper Relocations: (not relocatable)
Version : 1.0.0 Vendor: openSUSE
Release : 14.3 Build Date: Wed 03 Dec 2008 06:18:24 AM PST
Install Date: Fri 06 Feb 2009 09:05:04 PM PST Build Host: build16
Group : Productivity/Networking/Web/Utilities Source RPM: nspluginwrapper-1.0.0-14.3.src.rpm
Size : 296087 License: GPL v2 or later
Signature : RSA/8, Wed 03 Dec 2008 06:18:44 AM PST, Key ID b88b2fd43dbdc284
Packager : Submitting Bug Reports - openSUSE
URL : nspluginwrapper [Web > Gwenole Beauchesne]
Summary : Compatibility Layer for Netscape 4 Plug-Ins
Description :
nspluginwrapper is an Open Source compatibility plugin for Netscape 4
(NPAPI) plugins. It enables you to use plugins on platforms they were
not built for. For example, you can use the plugins compiled for i386
in Mozilla on Linux/x86_64 or other architectures. This package
consists of:

  • npviewer: the plug-in viewer

  • the browser-side plug-in

  • nspluginwrapper: a tool to manage plug-ins installation and update


Gwenole Beauchesne <>

Distribution: openSUSE 11.1

opening Opera from the CLI indicated a lock file was active. Deleting the lock file from .opera allowed Opera to open from the Grapical Menu. Opera has no flashplayer problems with YouTube.

CPU is Athlon FX 64 dual core 2.8 ghz
Motherboard is ASUS M2N-SLIDELUXE with 4 gigs of memory
Video Card is a ASUS Nvidia Gforce 8600 GT PCI-E

I recommend You try the second solution that is installing the 64 bit flash player. I never had problems with that one. Try it, you can always install the 32 bit plug-in anytime.

My old man is a radio ham. G4KTS

Back to subject: You need to have refresh ON with Packman.
The kde4 Factory repo is providing what you see in my Lenovo sig (4.3 beta2)
According to the build service guys, you should not need QT repo’s. Some are using QT45 with the beta 4.3 but it’s not needed. i know you are using kde3 but with those repo’s enabled it will affect your sys. Though it is unlikely you have actually updated kde4 properly because your update repo is still set at 20 priority. That’s fine for normal use, but if you do want kde4 updating you would need to change update to 99. If you wanted to update kde4 I would actually suggest removing the factory one you have and adding in this instead: Index of /repositories/KDE:/42/openSUSE_11.1

So is opera actually working now? But not from the launcher?