Dual Monitor with Ryzen 5 5600G not working on Tumbleweed 20220314

I got a new PC with Ryzen 5 5600G and cannot get my second monitor to work. I first installed Leap 15.3 with Kernel 5.3 and found out that the graphics adapter isn’t support by this Kernel, So I switched to Tumbleweed and it worked out of the box.
I then added the packman repo for the video codecs etc. and after a “zypper dup” and a reboot, display output on the second screen is gone… :’( I cannot get it to work anymore, even though it seems that all the drivers are loaded. I even made a BIOS reset and reinstalled the whole system from scratch but to no avail.
My Mainboard is an ASRock X570 Phantom Gaming 4, which has 1x HDMI and 1x DP Video Out. I can switch video out in BIOS Setup from one screen to another, so cabling and screens are fine. I updated BIOS to latest release and it worked before I updated videocodecs with the packman repo.

Does anyone have some suggestions how to investigate further?

**[FONT=monospace]**localhost:/home/ingo/Downloads #** uname -sr 
**[/FONT]Linux 5.16.14-1-default**[FONT=monospace]
[FONT=monospace][FONT=monospace]**[FONT=monospace]**localhost:/home/ingo/Downloads #****[/FONT]zypper repos -d
[/FONT][/FONT]**[/FONT]# | Alias                            | Name                            | Enabled   | GPG Check       | Refresh        | Priority  | Type   | URI                                                                           | Serv->


1 | download.opensuse.org-non-oss    | Haupt-Repository (NON-OSS)      | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/tumbleweed/repo/non-oss/                         |  
2 | download.opensuse.org-oss        | Haupt-Repository (OSS)          | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/tumbleweed/repo/oss/                             |  
3 | download.opensuse.org-tumbleweed | Hauptaktualisierungs-Repository | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/update/tumbleweed/                               |  
4 | ftp.gwdg.de-Essentials           | Packman Essentials Repository   | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Tumbleweed/Essentials |  
5 | repo-debug                       | openSUSE-Tumbleweed-Debug       | Nein      | ----            | ----           |   99      | NONE   | http://download.opensuse.org/debug/tumbleweed/repo/oss/                       |  
6 | repo-source                      | openSUSE-Tumbleweed-Source      | Nein      | ----            | ----           |   99      | NONE   | http://download.opensuse.org/source/tumbleweed/repo/oss/                      |

**localhost:/home/ingo/Downloads #** inxi -Gayz 
  **Device-1:** AMD Cezanne **driver:** amdgpu **v:** kernel **pcie:****gen:** 3 **speed:** 8 GT/s 
    **lanes:** 16 **link-max:****gen:** 4 **speed:** 16 GT/s **ports:****active:** DP-1 
    **empty:** DP-2,HDMI-A-1 **bus-ID:** 08:00.0 **chip-ID:** 1002:1638 **class-ID:** 0300 
  **Device-2:** WaveRider USB 2.0 Camera **type:** USB 
    **driver:** snd-usb-audio,uvcvideo **bus-ID:** 5-2:3 **chip-ID:** 0c46:636c 
    **class-ID:** 0102 **serial:** <filter> 
  **Display:** x11 **server:** X.Org **v:** **compositor:** kwin_x11 **driver:****X:**
    **loaded:** amdgpu,ati **unloaded:** fbdev,modesetting,vesa **gpu:** amdgpu 
    **display-ID:** :0 **screens:** 1 
  **Screen-1:** 0 **s-res:** 1920x1080 **s-dpi:** 96 **s-size:** 508x285mm (20.0x11.2") 
    **s-diag:** 582mm (22.9") 
  **Monitor-1:** DisplayPort-0 **mapped:** DP-1 **model:** Dell P2419H **serial:** <filter> 
    **built:** 2020 **res:** 1920x1080 **hz:** 60 **dpi:** 93 **gamma:** 1.2 
    **size:** 527x296mm (20.7x11.7") **diag:** 604mm (23.8") **ratio:** 16:9 **modes:**
    **max:** 1920x1080 **min:** 720x400 
  **OpenGL:****renderer:** AMD RENOIR (DRM 3.44.0 5.16.14-1-default LLVM 13.0.1) 
    **v:** 4.6 Mesa 21.3.7 **direct render:** Yes

Does appending amdgpu.dc=0 to the end of the linu line after striking the E key at the Grub menu’s default selection help?

Sadly, this does not help

ingo@localhost:~> cat /proc/cmdline 
BOOT_IMAGE=/boot/vmlinuz-5.16.14-1-default root=UUID=d1b43629-5121-48e0-bf1f-d80e848ffeff splash=silent mitigations=auto quiet amdgpu.dc=0 security=apparmor

I will also try nomodeset, just to see if if it might do anything…

Edit: Also didn’t work…

Try amdgpu.dc=1 instead.

Doesn’t work either. :frowning:

  1. Log out of X session
  2. Ctrl-Alt-F3
  3. login
  4. rm ~/.cache/*
  5. Ctrl-D
  6. Alt-F7
  7. login normally

Above is a common fix for Plasma foibles. It might do the same for Mate or other DEs, which may require Alt-F1 or other Fx instead of Alt-F7 to return to your X login manager.

If above was no help, try logging into some session type other than your normal one, e.g. IceWM, or Xorg instead of Wayland, or vice versa. Does this light up the other screen?

If not yet fixed after all the above, reboot (to clear all caching), then from an X session terminal do

cat /var/log/Xorg.0.log | susepaste

and provide here a resulting URI.

Thx, I just tried that and it did not help.

My Xorg.log is here:

I have to add some thoughts on this:
I don’t think that X or Wayland is the problem here. When it worked one time, screen1 was mirrored to screen 2 the moment grub had loaded and all the way through booting screen 2 was on. When X loaded and I logged in, screen number 2 became the second screen, extending screen 1.
I suspect, there is something going on at the kernel module level or something.

I got it to work again!!!

It seems to be a bug in the UEFI/BIOS of that specific mainboard. >:(

There is a setting for the graphics adapter, where you can choose how it behaves and how much RAM it gets for its framebuffer. Changing this setting to a different value, rebooting, then changing it back to the previous value, tadaaaa dual Monitors are working again.
This is ridiculous… 4 days of fiddling…

Anyways, thank you very much mrmazda for your support and time.

I forgot:

For future reference, if someone or myself comes across this problem in the future:
This happens on the Asrock x570 phantom gaming 4, with a Ryzen 5 5600G.

Since i dont see how to upload images here, you can find the option I toggled under:

Advanced -> AMD CBS -> NBIO Common Options -> GFX Configuration -> iGPU Configuration

I changed it from “UMA_Specified” to “Auto”, reboot, then changed it back to “UMA_Specified”. You can also use “UMA_Auto” I guess, or “UMA_Game_Optimized”. I just use this PC for Work, so i specified 128MB which is plenty.

paste.opensuse.org Top-right choose Image, Delete after Never and post the URL of the page (not of the image).

Oh, thats very nice!


When I try that and click “create”, i get an error “The requested page cannot not be found”

When I click Imgae (top-right), I get a small page where the main action is Browse, Clicking that I get a local browing window to browse through my maps and choose an image file. fter that, I clock Create and there it is showing the URL.

Yeah, I do exactly that, but after I click create, I get the error message.

Image size is 800x338px, 106KB JPEG

Adblocker + NoScript deactivated, same result… idk…

Well, as I can not look over your shoulder, I am afraid I can not comment on that. As you saw I (like most people) succeed in browsing to a valid image file and uploading it. You apparently not.

Nice. Now let’s see what a current Xorg.0.log looks like to compare to the previous. The old log has these red flags:

AMDGPU(0): Chipset: "**Unknown** AMD Radeon GPU" (**ChipID** = 0x1638)
AMDGPU(0): Output DisplayPort-0 connected
AMDGPU(0): Output HDMI-A-0 **disconnected**
AMDGPU(0): Output DisplayPort-1 **disconnected**

It wouldn’t surprise me if at some point your BIOS adjustment fails to stick across future boots, until device 0x1638 becomes recognized by the driver.

If this starts happening again in the near future, I suggest giving the modesetting DIX display driver a try. Because it’s not dependent on specific hardware, it works differently, so might work regardless of BIOS settings.

PS: ecologically speaking, it’s best not to set “Delete after” to never. That image isn’t timeless. It will become obsolete in due time, thus useless cruft swelling the database needlessly.

No big deal… Maybe it is some weird quirk on my computer, idk.

thx anyways :slight_smile:

Yes, I stumbled upon that “unknown” Chipset 0x1683 as well. Maybe the 5600G or something on the mainboard isn’t fully supported by now. Strangely, it reports DP-0 as connected and then as disconnected, while on HDMI-0 it just says disonnected.

Thats a good advice. If my second display fails again, I will research into that. Since the PC is my Office PC and I’m having the upcoming week off, I will try to look into the issue after that and upload my Xorg.0.log. Maybe we can get a better clue on whats happening, so it might get fixed correctly.

yeah, sounds right. Since uploading didn’t work, I described the exact path to that config, which will be here for future reference forever, so I think thats OK.

I have pasted a new Xorg.0.log while my PC is working now.


I still see the unknown Chipset message

     5.718] (--) AMDGPU(0): Chipset: "Unknown AMD Radeon GPU" (ChipID = 0x1638)

This time, both Display report EDID Data:

     5.815] (II) AMDGPU(0): EDID for output DisplayPort-0
     5.815] (II) AMDGPU(0): Manufacturer: DEL  Model: d0da  Serial#: 927807308
     5.815] (II) AMDGPU(0): Year: 2020  Week: 47
     5.816] (II) AMDGPU(0): EDID for output HDMI-A-0
     5.816] (II) AMDGPU(0): Manufacturer: DEL  Model: d0da  Serial#: 927809868
     5.816] (II) AMDGPU(0): Year: 2020  Week: 47

But still the strange disconnect message from Display-Port-1, that I don’t understand…
This is the new (working)

     5.816] (II) AMDGPU(0): Output DisplayPort-0 connected
     5.816] (II) AMDGPU(0): Output HDMI-A-0 connected
     5.816] (II) AMDGPU(0): Output DisplayPort-1 disconnected

This is old (non working)

     4.470] (II) AMDGPU(0): Output DisplayPort-0 connected
     4.470] (II) AMDGPU(0): Output HDMI-A-0 disconnected
     4.470] (II) AMDGPU(0): Output DisplayPort-1 disconnected

Reporting of non-connected CRTCs in Xorg.#.log is routine. 5600G support may still have bugs to be crushed. Count your blessings for now. :slight_smile: