Dual Monitor Stop Working Tumbleweed

I been using for the past year the same hardware, no issues at all until couple of months ago when a update was apply to tumbleweed. since then im not able to use but one screen of my docking station plus the laptop screen. I been reading and testing a lot with no avail so I decided to create a user in the forum after 13 years of using OpenSUSE :smiley:

Im able to connect the second screen to the docking station , once i go to configure the graphic display in the KDE settings and select “enable” the entire system freeze and i have to hold the power button in the laptop to turn if off.
I find a similar topic and try what they suggested in the there but it dindn’t work for me.

anyway I really need help here (and yes the screen works outside Opensuse with same hardware)
Laptop
Lenovo Thinkpad E595 AMD Ryzen
Lenovo Docking Gen2 - USB - C
Asus monitor VG245 both the same.

─[larva@linux-larvasayan] - [~] - [2023-03-21 01:25:12]
└─[0] <> inxi -Gayz
Graphics:
Device-1: AMD Picasso/Raven 2 [Radeon Vega Series / Radeon Mobile Series]
vendor: Lenovo ThinkPad E595 driver: amdgpu v: kernel arch: GCN-5 code: Vega
process: GF 14nm built: 2017-20 pcie: gen: 3 speed: 8 GT/s lanes: 16 ports:
active: DP-3 off: DP-4,eDP-1 empty: DP-1, DP-2, DP-5, HDMI-A-1
bus-ID: 05:00.0 chip-ID: 1002:15d8 class-ID: 0300 temp: 57.0 C
Device-2: Chicony Integrated Camera type: USB driver: uvcvideo
bus-ID: 1-2:3 chip-ID: 04f2:b6d9 class-ID: 0e02 serial:
Display: x11 server: X.Org v: 21.1.7 with: Xwayland v: 22.1.8
compositor: kwin_x11 driver: X: loaded: amdgpu
unloaded: fbdev,modesetting,vesa dri: radeonsi gpu: amdgpu display-ID: :0
screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 506x285mm (19.92x11.22")
s-diag: 581mm (22.86")
Monitor-1: DP-3 mapped: DisplayPort-2 model: VG245 serial:
built: 2021 res: 1920x1080 hz: 60 dpi: 92 gamma: 1.2
size: 531x299mm (20.91x11.77") diag: 609mm (24") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
Monitor-2: DP-4 mapped: DisplayPort-3 note: disabled model: VG245
serial: built: 2021 res: 1920x1080 dpi: 92 gamma: 1.2
size: 531x299mm (20.91x11.77") diag: 609mm (24") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
Monitor-3: eDP-1 mapped: eDP note: disabled pos: primary
model: AU Optronics 0x21ed built: 2016 res: 1920x1080 dpi: 142 gamma: 1.2
size: 344x193mm (13.54x7.6") diag: 394mm (15.5") ratio: 16:9 modes:
max: 1920x1080 min: 640x480
API: OpenGL v: 4.6 Mesa 23.0.0 renderer: AMD Radeon Vega 8 Graphics (raven
LLVM 15.0.7 DRM 3.49 6.2.6-1-default) direct render: Yes
┌─[larva@linux-larvasayan] - [~] - [2023-03-21 01:25:39]
└─[0] <>

susepaste Xorg
paste. opensuse . org /pastes / 30b3faca03bd

There are many upstream KDE bugs about problems with multiple displays. For the 5.27 series, much work was done trying to improve the situation. Unfortunately, issues remain, some new. Users of docks may be the worst remaining afflicted. You may be best off disabling Plasma’s control of displays by unchecking the KScreen2 box in startup settings. You may then be able to use xrandr to control displays instead. Arandr is a GUI tool available in standard TW OSS repo to generate required xrandr command(s).

A simpler thing to try first would be to uninstall xf86-video-amdgpu. On X restart this should switch from the amdgpu DDX display driver to the modesetting DIX display driver, which possibly could behave better. If it doesn’t, it’s your choice to leave it be, or reinstall xf86-video-amdgpu.

With docks, cable quality can be unusually important. Lots of dubious quality video cable seem to exist on this planet, so it’s not unusual for a graphics problem to be solved by a cable swap.

1 Like

@xlarva Hi, sounds like this bug Screen doesn't turn on when waking from suspend: Failed to pin framebuffer with error -19 (#2213) · Issues · drm / amd · GitLab

1 Like

Well i try uninstalling the xf86-video-amdgpu and that didn’t work.
Then I reinstalled the driver, and tried the patch mentioned in the post but i was unsuccessful at applying the patch, so i decided to do the next step.

Remove KScreen2 from the startup and use xrandr with Arandr to arrange the screens.
I finally was able to see all the screens with out getting the system freeze up.
It still some what weird.,
If I try to to boot TW with the two screen connected the boot will freeze before loading any GUI.

I have to login using only one screen , then connect the second screen at this point nothing will show up in the second screen , this is when I have to log out from session, now at the login prompt all screens will finally show up. Now im able to login and use the two screens. :smiley:

If i try to use KScreen to arrange the screen everything will freeze up again.
It’s a good work around thanks for the help, hopefully this gets resolved in a near future.

At the login screen, before logging in, try connecting second display, then Ctrl+Alt+F3 followed by Alt+F7, then logging in. If this too freezes the screen, try first logging in, then connecting display, then the Ctrl+Alt+F3 followed by Alt+F7 sequence. Any of F2-F6 should work the same as F3. F1 should too, but may produce a surprising difference. F7 is the normal Plasma session location. Three keys (Ctrl+Alt+Fn) are required to leave X, but only two (Alt+F7) to return.