Dell update prevents Linux from seeing NVME SSD

Ok, so I have a Dell Inspiron 7591 laptop. Today there was a Dell OS Recovery Tool update that knocked out GRUB2. I tried several things to get back into Linux:

  1. Attempted to “boot linux” off OpenSUSE LEAP 15.2 DVD, but it said it couldn’t find a Linux installation.
  2. Booted into installer and sure enough, nothing in the form of /dev/nvme0n1 through 0n7. Literally cannot see the onboard SSD.
  3. Went into BIOS, secure boot was off. Re-enabled, booted into Windows and told it to boot from the DVD (attempting to reinstall certificates). Was greeted by curses-looking prompt asking me if I trust the OpenSUSE certificates, to which I obviously said “yes.” Booted installer, still no /dev/nvme*
  4. Can see the Linux partitions in Windows, still intact, just can’t access them.

I’m wondering if there’s a less invasive way to get things back without burning the saved dd image (from when I first got the computer) to the SSD and starting all over. I read what I could on the internet for this problem but nothing seemed to work for me. I tried swapping SSD mode to/from RAID/AHCI but that didn’t fix anything.

Linux at one point showed (internal 120GB SSD in SATA bay for my music) that my music drive had two partitions on it. I did a dd wipe of that drive, wondering if maybe EFI got confused and to see if I could force it not to try to boot off that drive (it’s only going to be used for music and files, no Linux, no booting). I didn’t see an extra partition in Windows but we know Windows lies. Anyways, that also didn’t change anything: now I just have (in “manage computer”) a partition-less 120GB and it is still not letting me see /dev/nvme* in Linux.

I’m at my wit’s end. I guess I learned my lesson, no Dell OS Recovery Tool updates. But anyone know a less drastic way to regain control?

Can you boot from an openSUSE Live USB (or the install media) in rescue mode, then check the output from;

efibootmgr -v

Can you mount the efi partition and check it still has an opensuse directory.

Only windows boot manager, an entry for the SSD, and the rescue DVD I just booted from.

Is there a way to forcefully install certificates for LEAP 15.2 in Windows or the BIOS?

I know it won’t help you much, but: I always install latest BIOS (nothing else, consider all “tools” to be trash at best and malware at worst) and use only legacy boot on my Dells…

To OP: You are using legacy BIOS boot (CSM) or UEFI?

Check BIOS settings.

UEFI and that hasn’t changed. This laptop is essentially brand new.

OK, so you can boot from an openSUSE Live USB (or the install media in rescue mode).

What is the result of

# parted -l

does it show your “missing” SSD?

If so you could try to mount your openSUSE-partition, “chroot” into it and re-install GRUB2.



I’ll get to that in a second. Curiously, BitLocker (this is Win 10 Home?!) was enabled. I was like “what’s that lock icon?” So I disabled BitLocker entirely and rebooted. Tried to boot Linux system from DVD again, still no go. It still doesn’t populate in /proc/partitions.

I’ll try in a bit.

fdisk -l doesn’t list my NVME 1TB SSD (which is my boot drive and runs Windows).

Just to make sure i understand this correctly:

You booted the openSUSE installation media and took the option “Boot from Hard Disk”? If so, then your openSUSE system must be accessible in some way.

Please if you are asked to run a command in a console then show the complete output (i.e. including the prompt, the command, the output and the next prompt) enclosed in CODE tags (that is the # button in the tool bar of the post editor).



First, no, I booted from rescue to run fdisk -l. Booting from “boot Linux” results in an error that it can’t find a Linux system.

Second, with all due respect, I can’t cut and paste when I’m using the same computer to do this, and I don’t want to sit there and type out a long UUID. I did the best I could. I’ve been helped with efibootmgr issues before (it was probably you, and thanks for helping me get my laptop running last time we were working on boot issues).

So I provided the basic idea of the information provided by efibootmgr.

About the closest thing I can do next time is take a picture. But if you’ll forgive me, what information in efibootmgr is important other than what boot entries?

Sorry but i do not understand how this

and this

fits together. Could you please explain this in more details.

Yes, the rescue system is not as comfortable as a full fledged DE. However if you can boot the rescue system you should be able to boot a live system as well (like and that will give you a graphical DE.

The content of the entry (like which disk it points to)?

However i never asked you to provide results from efibootmgr (or even fdisk) but for the results of

# parted -l

and the main reason why i would like to see the detailed results is that i don’t know anything about your machine and still would like to help you to solve your problem.

But if you are not prepared to give me the information i need then i will not be able to help you. So it’s up to you to decide …



Does Windows still boot?

Could the Dell Utility delete the entries in the GPT so that it does not see the NVME device?

Can you put the NMVE in a USB 3 NVME device ( it will look like /dev/sdx not the normal NVME names ) and see the Linux partitions?

This is like I use but I have it with the 3.0 cable not 3.1

I don’t dual boot Windows on any Laptop - I use VirtualBox to created a Windows 10 machine within OpenSUSE.

That way Windows cannot break my OpenSUSE machine and I run religious weekly full tar backups so that I can restore my system should anything go wrong. I do daily deltas (files I change to a different computer - worse case is I loose a days work).

I practice a restore to different drive every quarter. I keep a table of UUID’s to create to that the restore has the exact same partition names.

I have seen companies go under because they did not check their backups to see if they were good and recoverable.

None of my Dells have UEFI BIOS, My 6 PCs with UEFI are Asus, ASRock, MSI & Gigabyte. So, I can only guess what UEFI on a Dell works like, or what a Dell Recovery Tool could do to NVRAM. I’d try a full BIOS reset to see what it and a live Linux boot pick up on their own on first boot after a reset.

Sounds like old confirmed bug 1146017 wasn’t slipstream fixed for 15.2.

Maybe it is a bug: some systems, especially laptops, cannot boot with FAT16 EFI system partition. They requires FAT32.
Windows is using FAT32 for EFI system partition.
openSUSE for reasons beyond my understanding prefer to use FAT16 for that.
I filed a bug Nothing changed for now.
Try to use FAT32 for EFI system partition.
Try to load Windows installer from USB flash or DVD disks.

To boot openSUSE installer use legacy BIOS mode, not UEFI.

Another option: install additional EFI loader - rEFInd or another.

rEFInd is a boot menu and maintenance toolkit for UEFI-based machines. It can be used to boot multiple operating systems that are installed on a single non-volatile device. It also provides a way to enter and explore the EFI pre-boot environment using an interactive shell, for example shellx64_v2.efi

I had maybe similar troubles with HP laptop.

UEFI fails to detect boot disk

The first thing I’d recommend is IMMEDIATELY contacting Dell Support to inform them what happened.
They might or might not respond but at least you’d have done your due diligence to inform so that they are aware a problem needs to be investigated.

Second thing to do is search for anyone else who may be having problems. Maybe nothing since your situation is rather unique and might not affect many Users.
NOTE that according to the little I found about the Dell Host OS Recovery Tool, it can make a difference what OS was factory installed… From your description, it sounds like Windows is the factory installed OS.

If I were to guess what happened, you did more than just update your Dell OS Recovery Tool, you actually ran it, and it over-wrote whatever was in the primary position of your boot chainloader sequence. The problem is, I can imagine your situation as described with either the Windows boot or Grub in the primary position, and I can’t suggest a path forward without possibly causing more problems.

If I were in your situation,
My primary objective would be to see if I could extract and make a copy of your data before doing anything else that might might cause loss of data altogether.
Since it sounds like you can’t access your Linux partitions except from within Windows,
I’d install a virtualization technology in your Windows, I’d recommend either Virtualbox or VMware.
Then create an openSUSE Guest,
Then add the Linux partition(s) as “raw” disks. If you’re particularly worried about damaging your disks, usually there is a “read only” option but unless you make an extremely gross error, chances of corrupting your Linux filesystem data is relatively small (Yeah, famous last words and no two people can be guaranteed to do things the same way).
Boot the Guest and you should have access to your Linux copy your data.

Technically, if you can offload an entire copy of everything that’s valuable, you’d also have an option to re-install and restore your data.
You can decide whether this additional option is easy or not and how worthwhile it is.


With all due respect, I did my best, given my lack of time. I’m in a masters degree program and it has the tendency to engulf my life.

Second, with all due respect, I’d rather not take a photo with my cell phone just to type out my huge UUIDs.

Sorry, I just didn’t have the ability to do what you ask. I don’t have a Live DVD right now.

Basically, no matter what boot option I choose (rescue, install, boot linux installation) it fails or cannot see the NVME hard drive at all.

I recall you or someone helping me use EFI Boot Manager. I did my best to approximate the information.

It’s as if efiboomgr can see the parameters (as if maybe the kernel “remembered” these entries?) but /dev/nvme* doesn’t exist so I have no way to write to it in Linux using any of those options from the LEAP 15.2 DVD. I tried telling Windows to boot from this DVD in advanced reboot options, and it did.

Basically, I’m locked out of my hard drive entirely.

I think it has something to do with a Dell OS Recovery update that forcefully put BitLocker on my hard drive. I went into Windows options to remove it, so that isn’t the problem now. I totally disabled the feature and Windows claims it decrypted all drives.

The boot options above still cannot see my hard drive. Like, no device node whatsoever.

I’m thinking Dell or Microsoft locked me out somehow. Something similar happened when Windows forcefully updated the signature parameters on the EFI on my last laptop: I was locked out until a new signed Linux kernel could be procured.

I will see what I can do. At this point, I’m tempted to pull out the drive, put it in an enclosure, and wipe it over with the stock dd image I took prior to first installing OpenSUSE. I am thinking it’s something Dell/Microsoft related, but I can’t prove it.

I tried (after disabling Bitlocker) re-enabling EFI Secure Boot just to try to install the OpenSUSE kernel signatures, which seemed successful because I got the curses-based EFI manager and it asked me whether I trust the OpenSUSE signatures (to which I obviously replied “yes”). That didn’t work.

I tried disabling EFI Secure Boot, no luck.

Again, I’m out of options.