Dell update prevents Linux from seeing NVME SSD

Have you tried presenting or searching your problem on the Dell forums? Maybe you’re not the first.

May be too far away from your problems and so this psot does not help, if so disregard it.


About 3 years ago I bought a DELL Precision 5520 LINUX laptop with 1TB nvme SSD with DELL installed Ubuntu. Never intended to stay with Ubuntu, shrunk that partition and installed Tumbleweed in the freed space. I had hoped to get it going from one EFI partition but in the end I went for an extra EFI boot partition for TW not shared at all for booting other OSs. There seems to be some general tendency to knock dead the boot files of other installs. That way I learned to use efibootmgr to setup enough entries for all the EFI boot partitions in the BIOS. And how to priorize them. I also learned F12 is sometimes at boot needed to reenable the right boot partition.
And in the beginning I had to repair GRUB2 now and then.

My BIOS boot setup is as follows
Secure boot, but do not verity the booted image
multi EFI partitions
all EFI partitions have entries in the BIOS

but to get there from your actual setup you do need a bootable Live/Rescue DVD or USB Stick to boot from.

If you want more details, please ask.

Now we are in real trouble:

You do not have the time to provide detailed information on your broken system and my crystal ball which could have done so went missing last year.

So i suggest you finish your masters degree first and we then try to sort out your broken system.

Good luck.


Not sure if there is a connection but I bought a new dell desktop computer yesterday - which has a ssd & normal h/d.

I shrank the windows drive (ssd - sda) to make some space for the opensuse install and left this unformatted and switched fastboot off in windows. Went to install opensuse using an iso but it did not show the ssd drive just the normal h/d. Tried another opensuse iso in case something had gone wrong there but was no change.

I did a bit of research and the ‘can’t see the ssd drive’ problem is due to the sata settings that Dell use. Went into the uefis bios settings and the sata settings were shown as a soft raid. Changed this to ahci and re-booted but my computer (windows 10) promtly crashed. Changed the setting back to use the soft raid and windows 10 started started fine. The way to make this change is to use the command msconfig in windows and select the option to boot windows into safe mode. Reboot and go into the uefi bios settings and change the sata controller to use ahci. Reboot windows and take the tick out of the safe mode option again using msconfig. Rebooted and windows started fine. I could then install opensuse fine - as the installation now sees the sdd (sda) and the normal h/d (sba).

Hey sorry about the long delay in replying.

Turns out Dell updates sometimes like to tell the BIOS to put the hard drive back in RAID mode.

Yet more bull krap that Microsoft is pushing on OEMs (I know because I spoke to Dell tech support and Microsoft runs their software after they submit them). (But it’s also possible the Dell tech agent doesn’t know what he’s talking about.)

Anyways, flipping it back to AHCI (using proper Winders procedures so that Windows doesn’t krap itself) fixed the problem.

The delay was caused in part by that laptop getting replaced because it had keyboard issues. I’m now using a 7506 2-in-1. But it had the same issues, so I flipped the NVME controller in BIOS to AHCI using proper procedures and then the installer could “see” the hard drive.

Thanks for all your help!

The Advanced Host Controller Interface (AHCI) is a technical standard defined by Intel that specifies the operation of Serial ATA (SATA) host controllers in a non-implementation-specific manner in its motherboard chipsets.

For modern solid state drives, the interface has been superseded by NVMe.

AHCI is not applicable to NVME.
AHCI is for SATA.
Use NVME drives to avoid hopping AHCI <> RAID.