Cracking sound trough speakers

Hi there!
Yesterday I installed 11.4 in my HP laptop and managed to make all my hardware work.

But I got this annoying cracking sound trough the speakers every once in a while, specially when some on screen stuff appears (like the translucid volume bar) or a new window or whatever.

It even does it with the sound muted.
I had Kubuntu 9.04 installed in this laptop since Apr/2009 until yesterday and had no such issues.

My sound specs:

sergio@laptop-sergio:~> cat /proc/asound/*/*
**Codec: Conexant CX20549 (Venice)**
Address: 0
AFG Function Id: 0x1 (unsol 0)
MFG Function Id: 0x2 (unsol 1)
Vendor Id: 0x14f15045
Subsystem Id: 0x103c30cf
Revision Id: 0x100100
Modem Function Group: 0x2
Codec: Conexant CX20549 (Venice)
Address: 0
AFG Function Id: 0x1 (unsol 0)
MFG Function Id: 0x2 (unsol 1)
Vendor Id: 0x14f15045
Subsystem Id: 0x103c30cf
Revision Id: 0x100100
Modem Function Group: 0x2
Default PCM:
    rates [0x140]: 48000 96000
    bits [0xe]: 16 20 24
    formats [0x1]: PCM
**Sound Driver:3.8.1a-980706 (ALSA v1.0.23 emulation code)
Kernel: Linux laptop-sergio.HUSKY01 #1 SMP PREEMPT 2011-02-21 10:34:10 +0100 i686**
Config options: 0

Installed drivers: 
Type 10: ALSA emulation
Card config: 
HDA NVidia at 0xf6480000 irq 21

Audio devices:



31: system timer

0: Conexant CX20549 (Venice)
Client info
  cur  clients : 1
  peak clients : 1
  max  clients : 192

Client   0 : "System" [Kernel]
  Port   0 : "Timer" (Rwe-)
  Port   1 : "Announce" (R-e-)
Client  14 : "Midi Through" [Kernel]
  Port   0 : "Midi Through Port-0" (RWe-)

00:07.0 Audio device: nVidia Corporation MCP67 High Definition Audio (rev a1)

I thought it was something about pulseaudio and tried to remove it [1], but it just didnt worked out.
I could not start KDE w/o some of the pulseaudio libraries, so I just reinstalled it

[1] SDB:Pulseaudio - openSUSE

Anyone knows what to do about this?
I also could not find where to enable ALSA only and disable PulseAudio.

Thanks for your help.

It seems I cannot edit my post or have a signature, so here are the laptop’s specs:
HP Pavilion DV6646us: AMD 1.9 GHz Turion 64 X2 / 2Gb RAM / 160Gb HDD / NVIDIA GeForce Go 7150M / 15.4" WXGA / BroadCom BCM4311 wireless / Built-in webcam.

You can disable pulse in Yast > Hardware > sound > other (drop down)

If you have a set of headphones or earphones, plug them in and see if they crackle … (Just want to make sure it’s not some flaky wire/connection on your speakers)

Hey caf,
that didnt work. I disabled pulseaudio, rebooted, but the crackling noise is still there.
If I plug the headphones, I still hear it in both phones and speakers.

I have XP dual-boot and theres no noise with it. There was no noise with Kubuntu a couple of days ago.

Any other ideas guys?

Can I ask if you did the multimedia?
Multimedia in One Click

Just did and rebooted. Noise still there.
I updated al ALSA related packages, rebooted and nothing!

sergio@laptop-sergio:~> rpm -qa |grep alsa


Can I ask, what you are using to play sounds?
Have you tried different applications
What about the test sound in Yast, is that crackly ?

The sounds per se are not cracky. Its just a crackling noise everyonce in a while.
Test sound is fine.
I played a DVD in kaffeine, other in VLC and some Youtube videos in Firefox and they play sound just fine.

However, If I press the mute or volume buttons, and the on-screen translucent indicator appears, theres a cracking noise.
If i move the Kmix sliders, crackling noise. Pop up window, crackling noise and so on…
BUT, not every time theres a noise. It sometimes its ok.

A mystery to me…
I think you need a sound guru like @oldcpu
Try not to fiddle too much for now. :smiley:

Ok. I will wait for a while for other tips and suggestions.
Thanks Carl!

  • BU MP *

Two ideas:

  • A hardware issue. You can only test that by using a different soundcard, different Boxes (the cables might be the culprit) etc.

  • Since you disabled PulseAudio, you should have a fully featured Mixer (KMix or the like). Do you see a “Channel Mode”-switch there? If not, it might be disabled by default (see for example the settings in KMix → “Configure Channels” [or something like that, I am on a German KDE here]). In your very first post you mentioned that those sounds appear mainly when some kind of graphical action takes place. I once had a likewise problem, whenever I minimized or maximized a window, scrolled a website etc. I had this weird hissing sound. I could solve this by setting the channel mode from ‘2ch’ to ‘6ch’. I am wildly speculating here, but since there are no other guesses here right now, you might give it a shot.

Good luck!

I did not check those version numbers, but its clear that only listed are the alsa utilities. Its impossible to tell from that listing if you installed an update to the alsa driver (via alsa-driver-kmp-somekernel-version) or updated the alsa library (via libasound2).

Note our multimedia stickie has a list of the information that is most useful to provide if one wishes audio problems looked at in detail: Welcome to multimedia sub-area I know that list appears long, but each piece of information asked for is in that list for a reason.

… also, the wiki for updating alsa makes it clear that not only apps with ‘alsa’ in the file name may need updating but also alsa-driver-kmp-somekernel-version, and libasound2 need updating) : SDB:Alsa-update - openSUSE

Thanks OldCPU! Here’s the info you asked.
I went trough the ALSA update wiki until I reached the kernel updates, to find there are no repos for 11.4 yet.

**sergio@laptop-sergio:~> rpm -qa '*alsa*'**

**sergio@laptop-sergio:~> rpm -qa '*pulse*'**

**sergio@laptop-sergio:~> rpm -q libasound2**

**sergio@laptop-sergio:~> uname -a**
Linux laptop-sergio.HUSKY01 #1 SMP PREEMPT 2011-04-25 21:48:33 +0200 i686 athlon i386 GNU/Linux

I guess this is updated and falls into the UPDATED-KERNEL Section?

**sergio@laptop-sergio:~> cat /etc/modprobe.d/50-sound.conf**

options snd slots=snd-hda-intel
# M71A.k5JPLyF5+X5:MCP67 High

Thanks for your time and help Oldcpu!

The content of 50-sound.conf does not look correct. Please run that ‘cat’ command again and check.

Here’s the output again:

sergio@laptop-sergio:~> cat /etc/modprobe.d/50-sound.conf

options snd slots=snd-hda-intel
# M71A.k5JPLyF5+X5:MCP67 High Definition Audio
alias snd-card-0 snd-hda-intel

and the contents of the folder

sergio@laptop-sergio:~> l /etc/modprobe.d/
total 56
-rw-r--r-- 1 root root 3430 feb 17 21:02 00-system.conf
-rw-r--r-- 1 root root  532 feb 17 21:02 10-unsupported-modules.conf
-rw-r--r-- 1 root root 5841 feb 17 21:01 50-blacklist.conf
-rw-r--r-- 1 root root  128 feb 18 19:27 50-bluetooth.conf
-rw-r--r-- 1 root root   33 feb 18 19:25 50-ipw2200.conf
-rw-r--r-- 1 root root   30 feb 18 19:25 50-iwagn.conf
-rw-r--r-- 1 root root   34 feb 18 19:25 50-iwl3945.conf
-rw-r--r-- 1 root root   86 feb 22 19:21 50-nvidia.conf
-rw-r--r-- 1 root root   18 feb 18 19:25 50-prism54.conf
-rw-r--r-- 1 root root  111 abr 23 16:58 50-sound.conf
-rw-r--r-- 1 root root    0 abr 23 16:58 50-sound.conf.YaST2save
-rw-r--r-- 1 root root  398 feb 17 21:08 50-thinkpad_acpi.conf
-rw-r--r-- 1 root root    0 abr 23 16:58 50-tv.conf
-rw-r--r-- 1 root root   47 feb 17 21:02 99-local.conf
-rw-r--r-- 1 root root   18 mar 21 10:32 nvidia.con

Unfortunately your timing is bad. This kernel was just updated in the last day or so. You now may need to wait a week or so (possible less, possibly more) until the SuSE-GmbH sound packager releases a kernel-driver-kmp-desktop-(for new 2.6.37-6-kernel) … before you can install the updated driver.

Would I’d be able to install it without 11.4 repos?

While waiting for an update to the alsa-driver-kmp-desktop for your kernel, you could also take a look at step-7 here to see if there is anything relevant: SDB:Audio troubleshooting - openSUSE

A silly question - do you have your mic plugged in ? What happens if you unplug it ? Does the static go away ?

I have no ext mic, and the internal mic is disabled in Kmix.

Would I’d be able to install the alsa-driver-kmp without 11.4 repos in the Alsa update wiki?

Thanks oldcpu!