Catastrofic Upgrade KDE COMPIZ XGL Kernel

I Have maybe 5 Different simultaneous upgrade related problems.
I have the same problem in 2 different PCs.
One have an onboard intel video card and teh other have an nvidia 8800.
But both show the same behavior.
I add Some repositories to get the QT 4.4 required by kde 4.4.1
Then I make a big upgrade to,
-XGL git_071026-79.3
-Xorg 7.4-5.1
-Compiz 0.7.8-2.3
-Compiz Fusion 0.7.8-3.1
-KDE4 4.1.2

After that I needed to reinstall video drivers and then
I have 3d acceleration but not desktop effects in any desktop (KDE3, Gnome), and in kde4 the desktop icons don’t show the Gizmos, makin impossible to transform, rotate or move it. and the Konsole always give a signal 11 (SIGSEGV).

Both PCs do the same.
Should I Wait for some new upgrades?

i have same catastrofic after upgrade compiz and XORG

Same here > Gnome.

I also use Compiz in my openSuSE 11.0. My kernel, xorg etc. were upgraded without upgrading Compiz, fuzion and emerald (I just kept my 0.7.4-something) and my 3D effects were fine. When I upgraded compiz packages to the new ones (0.7.8-x) my 3D effects were gone! This happens in all graphical environments (both KDE 3.5.10 and 4.1.2 and GNOME 2.22)

I run dmesg from a console window and I get the following:

compiz[14496]: segfault at 20726176 ip 20726176 sp bf9fee5c error 4 in[b74e7000+c000]

Well, I find a partial solution
I have Downgrade compiz to 0.7.4
And The 3d effects are back, but the KDE 4 Still have with Strange new errors by now.
I’m working with KDE 3.5

I had the same problems, but after downgrading, I still don’t have my effects back. Is there something else one should do after downgrading?

My bad. I went back to see if I had missed anything (I should have done that before writing), and I had found that I in fact had missed a few of the required downgrades. After doing the required downgrades, everything has gone back to the way it should (effects, etc…). Sorry!

Meh I don’t wanna downgrade… :frowning:

Who controls what is getting placed in that repository and where can I check if there is a solution thats being worked on? Cause it sounds like a bug and not wrong settings or corrupted files on our PC’s.

I don’t mean to nag, its just, like ever other update in that repository kills something in a bad way. If it’s bleeding edge kinda stuff then there should be a place to report stuff right?

some solution?

I Find some interesting Symptoms, The Xorg Upgrade overwrite the DISPLAYMANAGER_XSERVER Variable to “Xorg” in the /etc/sysconfig/displaymanager File, so I needed to change it to “xgl” again.
But anyway the usual methods to auto start compiz at the startup simply don’t work finaly I added a .desktop file in my kde3 autorun folder pointiong to Compiz.

And also many qt4 software, like skype and others using qt4 show corrupt graphics or missing parts of the screen, but it looks ok after clicking on the corrupt area. ¿Some Sort of refresh error?

AND I have a large list of missing features in KDE4.
For example i alway use the Search box in the launch as a calculator, in KDE 4.0 it works, but since 4.1 it don’t work.

By Now I have KDE 3.5 working.
But if the Nvidia driver Is “Sync to Vblank” Active.
It produces complete system crash after some minutes of using an openGL aplication.
Really Strange for me.

Hi All!

Since I upgraded to compiz 0.7.8 I can run compiz with the “Xorg”, but not with the “Xgl” setting anymore in /etc/sysconfig/displaymanager. But I do need Xgl as with Xorg the 2D extremely slow, not usuable to work with.

Any help appreciated. I have:


if you go to the compiz forums you will find that this is a known bug that is being worked on. So umm, why are you blamming the respositories. Bugs happen, report them, wait for a fix, why get out of bent over it?

of course there is a place to report bugs with compiz, at their forum

/Off topic
I’m not blamming the repository, thats kinda silly since it’s not a living breathing thingy…

I am asking where you can report bad stuff that’s placed in it. Who controls these community repo’s? And I’m asking because a lot of stuff go wrong with the community repositories that come with SuSE. I don’t mean bugs but version conflicts, wrong language files ect ect.

And yes, I understand that at some point someone is working on this or any bug. I just don’t understand why the bad version is still in the repository and keeps killing Compiz on pc’s that were turned off these last days. Perhaps this is just lack of understanding how things work from my part ofc.

aspell dutch, in SuSE 10.x the Dutch language file was Norwegian and the Norwegian was… also Norwegian. So no Dutch file. So the net is filled with Dutch people that are asking how they can get Dutch spell check in Evolution. No one ever fixed that as far as I know. You could download the Dutch RPM from fedora and that worked.

Same goes for aMSN a few months ago. Wrong version of TK and it breaks. It stayed broken for weeks. In the end they downgraded in that repo. Uninstall and reinstall and aMSN worked. It shouldn’t have been weeks. I had to turn off the repo at some friends and downgraded TK manually untill it got fixed. They had the same problem @ Ubuntu but that got fixed way faster.

Now I see this compiz error and no one seems to have an answer. You tell me it’s a known bug so known bugs that can’t be solved right away means remove the bad software if possible from the repo untill it’s fixed. This is not a small bug, it should never reached that repo. And when it does, remove it. I knew about this bug minutes after the repo my laptop checks got updated. The only people I knew I could warn were my friends that use SuSE so they could turn off the repo.

All I want is a place where you can report this. I don’t mean the Compiz forums, I mean someone that can remove the bad software so other pc’s wont get the update and we can uninstall and reinstall a working version. There is no reason for everyone that uses this repo to get devastating software (devastating as in Compiz is completely dead) if others are quickly to respond and report.

And I’m not getting out of bent over it. I just feel the repositories give a lot of problems for ‘normal’ users and it doesn’t have to be like that.

I have no idea who to contact about stuff like I just wrote about. I’m sure the info is somewhere, I just can’t find it. There is this Dutch software a lot of people use over here to find software in newsgroups. They have a Linux version and a SuSE repo. I know who to contact if there is an error.
/Off topic

I have to agree with Ricochet. Why have packages that don’t work in the repositories? I don’t get it.

Now… which version was it that actually worked?

To answer my own question: I don’t know but the one on the openSUSE DVD obviously did. Just remove the online Compiz repository and reinstall the DVD version (0.7.4-x). Works for me for now - but I’m the impatient type…

I too have to agree with Ricochet. I think compiz 0.7.6 (not totally sure, though, it was this version) worked fine. I absolutely don’t understand why the broken packages in the repositories are not replaced with the previous version packages that worked just fine.

Even worse, 0.7.4 doesn’t work for me either, I always get a white screen on login. I read somewhere it’s a known bug without a fix. That’s not totally true, you can remove .kde/share/config/ksmserverrc before login in, and then the white screen doesn’t appear, but this is a very crappy workaraound.

Does anyone know if somewhere on the web the previous packages still available?

If I remembered correctly 0.7.8 was the latest working version. Last Thursday a small update was placed in the repo, I think it was also 0.7.8 but I don’t remember the build or exact long version number.

If you subscribe to the compiz repo you should expect bugs. That is the price you pay for having the latest stuff. Totally broken stuff just seems like an high price to me. Thats all. And about my repository story, I think this could be an area where the community (we) can help to make it better :slight_smile:

Today I got some more compiz updates btw, but they didn’t solve it.

This user has the 0.7.6 versions…

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 2:35, 1 user, load average: 0.01, 0.03, 0.06
GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12


Thanks malcolmlewis, but unfortunately, this repository is not complete.

However, I can list the exact version that worked fine for me as from time to time a save a file created by “rpm -aq | sort” :slight_smile: :


Are all these packages still somewhere :nerd: ?

i has the same problem … tried a lot of things and nothing. so i reinstall opensuse 11 again. when i update compiz 0.7.8 and kde 4.1.2 got everything working ok. this is what i did :

  1. Install fresh opensuse 11.o and when finish i add KDE4 and X11 Xgl repositories … run full update.

!!! I DONT USE COMPIZ YET !!! (i tried avoid problems between configuration files )

  1. Install the beta driver nvidia
    i get the righ one here :
    NVIDIA Driver Downloads - Advanced Search
    and follow the hard way instructions for install
    NVIDIA - openSUSE
    im also run the commands from the console as root
    nvidia-xconfig --composite
    nvidia-xconfig --render-accel
    nvidia-xconfig --add-argb-glx-visuals -d 24
    and restart xserver
    i check with NvidiaX server settings …

  2. Install kde 4.1.2 release 44.2
    using 1-click adn install from (KDE 4.1.x)
    KDE/KDE4 - openSUSE

  3. Open yast2 and search compiz, there is some compiz packages for update → rigth click all in this list → update if newer version is …

5 i run simple compiz config manager … activate !! AND …

Could be only result of the new updates i dont know.
i dont know if its the last driver of nvidia or keeping the repositories without mixing things… or if the new clean configurations files generated only for the latest

sorry for my english im from colombia… hope this help someone…