Can't change boot resolution

Another update, the same glitch. It’s the same old problem that keeps returning after the occasional update. 15.5 XFCE boots at 640 x 480. I can’t change the resolution because the “Apply” button is off the screen. So I have to boot Garuda, or MX linux, or any other OS (all of them actually do work) in order to correct an OpenSUSE bug. Can somebody provide me with a console command that forces and keeps a different resolution?

Can’t you move the screen by holding left-ALT and dragging?
Works here in leap KDE

Thanks, I’ll try that as soon as I reboot (for the umpteenth time).

No that didn’t work. I can drag, but only left, right, and down. Not up so I can see the “Apply” button. But then I’m using XFCE not KDE.

Are you trying to change the display resolution in xfce settings manager?
If you can’t see the apply button because it is hidden under the screen below. Use TAB until you know that the selection already reach the apply button then hit RETURN key (enter).

I’ll try that. Rebooting right now.

Success! I couldn’t see the “Apply” button but I figured out it was the 5th. tab press. So now I can at least see what I am doing. Now to find a permanent solution so I don’t have to repeat the process at every boot. Thank you very much. Frustration much reduced.

Good it worked.
Your thread title is misleading. This is not about boot resolution but DE resolution.

Yes of course you are correct. I can boot to a console that’s usable.

xfce is still running xorg, right?
maybe create a xrandr script to set your desired resolution on login?

I did that some time ago, and it worked for a few days, but not after an update. Something like…

cvt 1280 1024 75
xrandr --newmode “1280x1024_75.00” 138.75 1280 1368 1504 1728 1024 1027 1034 1072 -hsync +vsync
xrandr --addmode VGA-0 “1280x1024_75.00”

So I removed all the modifications I tried and after a while things settled down, and it now boots in 720x480 (not 640x480 as it did before) and I can set 1152x864 and it keeps it. I never understood what caused it to change, and I’m not going to fool around with it to find out. I always felt it was set in the BIOS. I don’t know if that’s possible. No option I could see.

The problem is back. When I turned my desktop on this morning, it wouldn’t boot reporting “Output not supported”. Then I booted Debian on the same drive successfully, and after that it booted into XFCE. So wanting to see the journal I invoked…

desk:/home/ion # journalctl --list-boots
0 20975eab4e4e479db6d78a30093dac71 Sun 2023-12-24 09:19:35 CST—Sun 2023-12-24 09:24:03 CST
desk:/home/ion #

Only one reported. And journalctl shows only the last boot. How do I find previous boot journals?

I’ve been with openSUSE since 9.1 but considering changing to another distro. 15.4 works, Debian and Garuda and MX Linux all work, all the time. Hard to report a bug as things keep changing. I never changed any of the journal settings, yet all of a sudden journalctl doesn’t show much.

desk:/home/ion # journalctl -b-1
Specifying boot ID or boot offset has no effect, no persistent journal was found.
desk:/home/ion #

@ionmich journalctl -b --list-boots then which ever one your wanting is -N eg to list last boot would be journalctl -b -1.

Corrected my input.

desk:/home/ion # journalctl -b -1
Specifying boot ID or boot offset has no effect, no persistent journal was found.
desk:/home/ion #

@ionmich systemd-analyze cat-config systemd/journald.conf I suspect Storage=is auto, change to persistent or as per the journald.conf man page you need a directory /var/log/journal

And yet the logs exist.

desk:/home/ion # ls /var/log/boot*xz
/var/log/boot.log-20231218.xz  /var/log/boot.log-20231221.xz  /var/log/boot.log-20231224.xz
/var/log/boot.log-20231219.xz  /var/log/boot.log-20231222.xz
/var/log/boot.log-20231220.xz  /var/log/boot.log-20231223.xz
desk:/home/ion # 

@ionmich did you check your config to see how your system is configured?

Yes #Storage=auto. Which file do i modify using nano? And why did it change? Previously journalctl showed all the boots.