Cannot update.


I installed opensuse kde 11.2. I have problems updating via yast. please help.



Please post result of this from a terminal

zypper lr -d

| Alias | Name | Enabled | Refresh | Priority | Type | URI | Service

1 | repo-debug | openSUSE-11.2-Debug | No | Yes | 99 | yast2 | Index of /debug/distribution/11.2/repo/oss |
2 | repo-non-oss | openSUSE-11.2-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/non-oss |
3 | repo-oss | openSUSE-11.2-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/oss |
4 | repo-source | openSUSE-11.2-Source | No | Yes | 99 | NONE | Index of /source/distribution/11.2/repo/oss |
5 | repo-update | openSUSE-11.2-Update | Yes | Yes | 99 | NONE | Index of /update/11.2

Now, in a terminal become su and do

zypper ref


zypper lu

what does lu report

I am not so good at linux commands. so I did this in terminal:

sudo zypper ref

it asked me for password, on password I got this :

System management is locked by the application with pid 4601 (/usr/lib/YaST2/bin/y2base).
Close this application before trying again.

nothing is open as I see on my desktop.


Make sure Yast is closed

I killed it using system monitor and right now it is running.

I can see this on my terminal :

Retrieving repository 'openSUSE-11.2-Non-Oss' metadata

but I see that my network is not being accessed when I do this. should it access the internet when I give this command??


oki I got an error :

Failed to download ./suse/setup/descr/packages.en.gz from

and its asking whether to abort or retry?


Don’t you have an internet connection?
Are you typing this on a different PC

I have only one pc. that is this. right now I am responding to you on the same suse kde system.



Click this: Index of /update/11.2
Do you get to it OK in your browser?

yes I can reach there via ff.


Just try again
Become su in a terminal like this:
Become su in Terminal - HowTo - openSUSE Forums


zypper ref
zypper lu

If this doesn’t work, try doing this
Disable IPv6 - openSUSE Forums
(reboot after this)

Disable IPV6, rebooted.

tried udpating via yast - no luck.

tried zypper - no luck.



oki. i oberved one more thing :

i got an error :

Retrieving repository 'openSUSE-11.2-Non-Oss' metadata -]Failed to download /media.1/media from

so i tried to open media in ff from media.1 here : Index of /distribution/11.2/repo/non-oss/media.1

and nothing was loading.


Please tell me where in the world you are
eg: USA, Australia…

I am in country - INDIA,continent - ASIA


Lets go to Software Repositories and delete all the repos’

I will give you the ones to add back in a mo

oki i tried again :

zypper ref with the result :

Retrieving repository 'openSUSE-11.2-Non-Oss' metadata -]Failed to download /media.1/media from

and had options to abort, retry… selected abort again I got this :

Retrieving repository 'openSUSE-11.2-Non-Oss' metadata [error]
Repository 'openSUSE-11.2-Non-Oss' is invalid.
Can't provide /media.1/media : Failed to download /media.1/media from
Please check if the URIs defined for this repository are pointing to a valid repository.
Skipping repository 'openSUSE-11.2-Non-Oss' because of the above error.
Retrieving repository 'openSUSE-11.2-Oss' metadata |]Failed to download ./suse/setup/descr/dvd-11.2-20.22.1.i586.pat.gz from

sure. sure.